ramips: Xiaomi MIR3G: detect board name from DTS
authorOzgur Can Leonard <ozgurcan@gmail.com>
Tue, 19 Mar 2019 07:04:27 +0000 (10:04 +0300)
committerChristian Lamparter <chunkeey@gmail.com>
Wed, 20 Mar 2019 23:57:54 +0000 (00:57 +0100)
- Former "mir3g" board name becomes "xiaomi,mir3g".
- Reorder some entries to maintain alphabetical order.
- Change DTS so status LEDs (yellow/red/blue) mimic
  Xiaomi stock firmware: (Section Indicator)
<http://files.xiaomi-mi.co.uk/files/router_pro/router%20PRO%20EN.pdf>
<http://files.xiaomi-mi.co.uk/files/Mi_WiFi_router_3/MiWiFi_router3_EN.pdf>
|Yellow: Update (LED flickering), the launch of the system (steady light);
|Blue: during normal operation (steady light);
|Red: Safe mode (display flicker), system failure (steady light);

Signed-off-by: Ozgur Can Leonard <ozgurcan@gmail.com>
[Added link to similar Router 3 model]
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/boot/uboot-envtools/files/ramips
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/MIR3G.dts
target/linux/ramips/image/mt7621.mk

index b70f62656d686f02a7cba34aac54e72c61c6dbb0..589e602f4c13d65db452c8a6ff116f3f9eab31e4 100644 (file)
@@ -32,7 +32,7 @@ zbt-wg2626)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x1000" "0x10000"
        ;;
 xiaomi,mir3p|\
-mir3g)
+xiaomi,mir3g)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x1000" "0x20000"
        ;;
 esac
index 69b95ee540292e72c541cd2f6969a2c80e6a9d27..b42e04f2238b84a59d66343ed6e5fbe19b6b7034 100755 (executable)
@@ -236,17 +236,6 @@ mikrotik,rbm11g)
 miniembplug)
        set_wifi_led "$boardname:red:wlan"
        ;;
-xiaomi,mir3p)
-       ucidef_set_led_switch "wan-amber"  "WAN (amber)"  "$boardname:amber:wan"  "switch0" "0x10" "0x08"
-       ucidef_set_led_switch "lan1-amber" "LAN1 (amber)" "$boardname:amber:lan1" "switch0" "0x02" "0x08"
-       ucidef_set_led_switch "lan2-amber" "LAN2 (amber)" "$boardname:amber:lan2" "switch0" "0x04" "0x08"
-       ucidef_set_led_switch "lan3-amber" "LAN3 (amber)" "$boardname:amber:lan3" "switch0" "0x08" "0x08"
-       ;;
-mir3g)
-       ucidef_set_led_switch "wan-amber"  "WAN (amber)"  "$boardname:amber:wan"  "switch0" "0x02" "0x08"
-       ucidef_set_led_switch "lan1-amber" "LAN1 (amber)" "$boardname:amber:lan1" "switch0" "0x08" "0x08"
-       ucidef_set_led_switch "lan2-amber" "LAN2 (amber)" "$boardname:amber:lan2" "switch0" "0x04" "0x08"
-       ;;
 mlw221|\
 mlwg2)
        set_wifi_led "$boardname:blue:wifi"
@@ -421,6 +410,17 @@ wrh-300cr)
        set_wifi_led "$boardname:green:wlan"
        ucidef_set_led_netdev "lan" "lan" "$boardname:green:ethernet" "eth0"
        ;;
+xiaomi,mir3g)
+       ucidef_set_led_switch "wan-amber"  "WAN (amber)"  "$boardname:amber:wan"  "switch0" "0x02" "0x08"
+       ucidef_set_led_switch "lan1-amber" "LAN1 (amber)" "$boardname:amber:lan1" "switch0" "0x08" "0x08"
+       ucidef_set_led_switch "lan2-amber" "LAN2 (amber)" "$boardname:amber:lan2" "switch0" "0x04" "0x08"
+       ;;
+xiaomi,mir3p)
+       ucidef_set_led_switch "wan-amber"  "WAN (amber)"  "$boardname:amber:wan"  "switch0" "0x10" "0x08"
+       ucidef_set_led_switch "lan1-amber" "LAN1 (amber)" "$boardname:amber:lan1" "switch0" "0x02" "0x08"
+       ucidef_set_led_switch "lan2-amber" "LAN2 (amber)" "$boardname:amber:lan2" "switch0" "0x04" "0x08"
+       ucidef_set_led_switch "lan3-amber" "LAN3 (amber)" "$boardname:amber:lan3" "switch0" "0x08" "0x08"
+       ;;
 xzwifi,creativebox-v1)
        ucidef_set_led_switch "internet" "internet" "$boardname:blue:internet" "switch0" "0x10"
        ;;
index 20a50cc6de44416e5269e8fe0b5347d415465f41..bf71aef5ec2c0b09277322fe1942c807cff1ea7c 100755 (executable)
@@ -179,10 +179,6 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "1:lan:2" "2:lan:1" "3:lan:3" "4:lan" "0:wan" "6@eth0"
                ;;
-       mir3g)
-               ucidef_add_switch "switch0" \
-                       "2:lan:2" "3:lan:1" "1:wan" "6t@eth0"
-               ;;
        psg1218b)
                ucidef_add_switch "switch0" \
                        "0:lan:3" "1:lan:2" "2:lan:1" "3:wan" "6@eth0"
@@ -437,6 +433,10 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "4:lan" "0:wan" "6@eth0"
                ;;
+       xiaomi,mir3g)
+               ucidef_add_switch "switch0" \
+                       "2:lan:2" "3:lan:1" "1:wan" "6t@eth0"
+               ;;
        xiaomi,mir3p)
                ucidef_add_switch "switch0" \
                        "1:lan:3" "2:lan:2" "3:lan:1" "4:wan" "6@eth0"
@@ -568,10 +568,6 @@ ramips_setup_macs()
                lan_mac=$(mtd_get_mac_binary factory_info 13)
                wan_mac=$(macaddr_add "$lan_mac" 1)
                ;;
-       mir3g|\
-       xiaomi,mir3p)
-               lan_mac=$(mtd_get_mac_binary Factory 0xe006)
-               ;;
        miwifi-mini)
                wan_mac=$(cat /sys/class/net/eth0/address)
                lan_mac=$(macaddr_setbit_la "$wan_mac")
@@ -653,6 +649,10 @@ ramips_setup_macs()
        wlr-6000)
                wan_mac=$(macaddr_add "$(mtd_get_mac_binary factory 32772)" 2)
                ;;
+       xiaomi,mir3g|\
+       xiaomi,mir3p)
+               lan_mac=$(mtd_get_mac_binary Factory 0xe006)
+               ;;
        *)
                lan_mac=$(cat /sys/class/net/eth0/address)
                wan_mac=$(macaddr_add "$lan_mac" 1)
index db93710ba7b68466c29b024f0754e127e9dae8b9..093303892c2fea90d783811d53d8e56c3323dd18 100755 (executable)
@@ -277,9 +277,6 @@ ramips_board_detect() {
        *"Mercury MAC1200R v2")
                name="mac1200rv2"
                ;;
-       *"Mi Router 3G")
-               name="mir3g"
-               ;;
        *"MicroWRT")
                name="microwrt"
                ;;
index 67b0f3e7f47f9a1099f5de62f3fba8f12948acb5..7372a379399316227d8cea7c8d0eafd0c6315498 100755 (executable)
@@ -37,11 +37,11 @@ platform_do_upgrade() {
 
        case "$board" in
        hc5962|\
-       mir3g|\
        r6220|\
        netgear,r6350|\
        ubnt-erx|\
        ubnt-erx-sfp|\
+       xiaomi,mir3g|\
        xiaomi,mir3p)
                nand_do_upgrade "$ARGV"
                ;;
index 3af2c752fd63337865592e5b42609e44bb321b54..b0b63f8085c73d3b3d2e2e80729faa9ea23d8abf 100644 (file)
        model = "Xiaomi Mi Router 3G";
 
        aliases {
-               led-boot = &led_status_blue;
-               led-failsafe = &led_status_blue;
+               led-boot = &led_status_yellow;
+               led-failsafe = &led_status_red;
                led-running = &led_status_blue;
-               led-upgrade = &led_status_blue;
+               led-upgrade = &led_status_yellow;
        };
 
        memory@0 {
@@ -28,7 +28,7 @@
        leds {
                compatible = "gpio-leds";
 
-               status_red {
+               led_status_red: status_red {
                        label = "mir3g:red:status";
                        gpios = <&gpio0 6 GPIO_ACTIVE_LOW>;
                };
@@ -38,7 +38,7 @@
                        gpios = <&gpio0 8 GPIO_ACTIVE_LOW>;
                };
 
-               status_yellow {
+               led_status_yellow: status_yellow {
                        label = "mir3g:yellow:status";
                        gpios = <&gpio0 10 GPIO_ACTIVE_LOW>;
                };
@@ -59,7 +59,7 @@
                };
        };
 
-       keys {
+       button {
                compatible = "gpio-keys-polled";
                poll-interval = <20>;
 
@@ -70,7 +70,7 @@
                };
        };
 
-       reg_usb_vbus: reg_usb_vbus {
+       reg_usb_vbus: regulator {
                compatible = "regulator-fixed";
                regulator-name = "usb_vbus";
                regulator-min-microvolt = <5000000>;
index 8b0b28a9413f544e447ed2282ba3f5f52fd80063..1f514a6d040f3189a91916aa7c33eb03a3984c56 100644 (file)
@@ -251,7 +251,7 @@ define Device/xiaomi_mir3p
 endef
 TARGET_DEVICES += xiaomi_mir3p
 
-define Device/mir3g
+define Device/xiaomi_mir3g
   DTS := MIR3G
   BLOCKSIZE := 128k
   PAGESIZE := 2048
@@ -264,11 +264,12 @@ define Device/mir3g
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   DEVICE_TITLE := Xiaomi Mi Router 3G
   SUPPORTED_DEVICES += R3G
+  SUPPORTED_DEVICES += mir3g
   DEVICE_PACKAGES := \
        kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic \
        uboot-envtools
 endef
-TARGET_DEVICES += mir3g
+TARGET_DEVICES += xiaomi_mir3g
 
 define Device/mt7621
   DTS := MT7621