ramips: mt7621: pbr-m1: fix firmware size
authorChuanhong Guo <gch981213@gmail.com>
Sun, 13 Sep 2020 10:57:11 +0000 (18:57 +0800)
committerChuanhong Guo <gch981213@gmail.com>
Sun, 13 Sep 2020 11:15:06 +0000 (19:15 +0800)
This board is equipped with Winbond W25Q256FV 32M SPI-NOR.
Fix partition size for that.

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
target/linux/ramips/dts/mt7621_d-team_pbr-m1.dts
target/linux/ramips/image/mt7621.mk

index 15b717616e47ca5b763fb41aff51539ee78900d7..beaa38081836cdbe978fb5113e56560b25e8b000 100644 (file)
                        partition@50000 {
                                compatible = "denx,uimage";
                                label = "firmware";
-                               reg = <0x50000 0xfb0000>;
+                               reg = <0x50000 0x1fb0000>;
                        };
                };
        };
index 46516b3e40090ff7da65ecce4363346410903cc8..78629563ee547de4c940a6d1910c0c2ff66f2238 100644 (file)
@@ -333,7 +333,7 @@ TARGET_DEVICES += d-team_newifi-d2
 
 define Device/d-team_pbr-m1
   $(Device/dsa-migration)
-  IMAGE_SIZE := 16064k
+  IMAGE_SIZE := 32448k
   DEVICE_VENDOR := PandoraBox
   DEVICE_MODEL := PBR-M1
   DEVICE_PACKAGES := kmod-ata-ahci kmod-mt7603 kmod-mt76x2 kmod-sdhci-mt7620 \