ccache: Build with ENABLE_DOCUMENTATION=OFF
authorDavid Adair <djabhead@aol.com>
Fri, 14 May 2021 23:04:27 +0000 (16:04 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 23 May 2021 13:11:38 +0000 (15:11 +0200)
This adjusts the Makefile to use the new option to turn off the
doc builds. It will not cause any problems except a warning
about unused options if combined with a ccache source missing
the upstream patch.

Since a config setting is required to re-enable the doc build this
is equivalent to unconditionally disabling the docs if the config
setting is not created.

Signed-off-by: David Adair <djabhead@aol.com>
tools/ccache/Makefile

index b4dc81aaaa695fda788dcdd82316763705f647b3..3db6cc0818b20d191efa5f7b3bba594dd48145a6 100644 (file)
@@ -25,6 +25,9 @@ CMAKE_HOST_OPTIONS += \
        -DCMAKE_SKIP_RPATH=FALSE \
        -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOST}/lib" \
 
+ifneq (docs-$(CONFIG_BUILD_DOCUMENTATION),docs-y)
+CMAKE_HOST_OPTIONS += -DENABLE_DOCUMENTATION=OFF
+endif
 
 define Host/Install/ccache
        $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/