uhttpd: Enable integrated Lua by default
authorAnsuel Smith <ansuelsmth@gmail.com>
Sun, 26 Mar 2017 13:17:06 +0000 (15:17 +0200)
committerJohn Crispin <john@phrozen.org>
Tue, 16 May 2017 14:57:01 +0000 (16:57 +0200)
We enabled lua interpreter by default as it doesn't make any problem in the uhttpd config file and we modify the index page to use it.

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
package/network/services/uhttpd/Makefile
package/network/services/uhttpd/files/uhttpd.config

index 39e8894ebc2d361e0e7895151641c751601db411..3d483b692dea784010d83a33a69c9e49b9c76f17 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(LEDE_GIT)/project/uhttpd.git
@@ -46,9 +46,12 @@ define Package/uhttpd/config
   config PACKAGE_uhttpd_debug
     bool "Build with debug messages"
     default n
+  config uhttpd_lua
+    depends on PACKAGE_uhttpd-mod-lua
+    bool "Enable Integrated Lua interpreter"
+       default y
 endef
 
-
 define Package/uhttpd-mod-lua
   $(Package/uhttpd/default)
   TITLE+= (Lua plugin)
@@ -106,6 +109,16 @@ define Package/uhttpd-mod-ubus/install
        $(INSTALL_DATA) ./files/ubus.default $(1)/etc/uci-defaults/00_uhttpd_ubus
 endef
 
+define Package/uhttpd-mod-lua/postinst
+       $(if $(CONFIG_uhttpd_lua),
+       #!/bin/sh
+       if [ -f $${IPKG_INSTROOT}/www/index.html ]
+       then
+               sed -e 's:/cgi-bin::g' -i $${IPKG_INSTROOT}/www/index.html
+       fi
+       ,)
+endef
+
 
 $(eval $(call BuildPackage,uhttpd))
 $(eval $(call BuildPackage,uhttpd-mod-lua))
index 89f99aaeea8ccd3d8aaddf928a383d65a606c58f..563c079a1adc7813391f5ab12ac4b970378d9529 100644 (file)
@@ -51,8 +51,8 @@ config uhttpd main
 
        # Lua url prefix and handler script.
        # Lua support is disabled if no prefix given.
-#      option lua_prefix       /luci
-#      option lua_handler      /usr/lib/lua/luci/sgi/uhttpd.lua
+       option lua_prefix       /luci
+       option lua_handler      /usr/lib/lua/luci/sgi/uhttpd.lua
 
        # Specify the ubus-rpc prefix and socket path.
 #      option ubus_prefix      /ubus