ramips: add support for TP-Link TL-WR841n v14
authorAlexander Müller <donothingloop@gmail.com>
Tue, 27 Nov 2018 14:32:18 +0000 (15:32 +0100)
committerAlexander Couzens <lynxis@fe80.eu>
Tue, 2 Jul 2019 14:17:49 +0000 (16:17 +0200)
TP-Link TL-WR841n v14 is a router based on MediaTek MT7628N.

- MediaTek MT7628NN
- 32 MB of RAM
- 4 MB of FLASH
- 2T2R 2.4 GHz
- 5x 10/100 Mbps Ethernet

Installation:
- copy the
  'openwrt-ramips-mt76x8-tl-wr841n-v14-squashfs-tftp-recovery.bin'
  file to your tftp server root and rename it to 'tp_recovery.bin'.
- configure your PC running the TFTP server with the static IP address
  192.168.0.66/24
- push the reset button and plug in the power connector. Wait until
  the orange led starts blinking (~6sec)

Signed-off-by: Alexander Müller <donothingloop@gmail.com>
Signed-off-by: Alexander Couzens <lynxis@fe80.eu> [small modifications gpio-hog]
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/dts/TL-WR841NV14.dts [new file with mode: 0644]
target/linux/ramips/image/mt76x8.mk

index 9cf6e30d3993c43847f246d8474ffbca82d6f8b3..d020347d725a81d39f7e743667147b1a065f0235 100755 (executable)
@@ -326,6 +326,10 @@ tl-wr841n-v13)
        ucidef_set_led_switch "lan4" "lan4" "$boardname:green:lan4" "switch0" "0x10"
        ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
        ;;
+tplink,tl-wr841n-v14)
+       ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x1e"
+       ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
+       ;;
 tplink,c2-v1)
        ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch1" "0x1e"
        ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch1" "0x01"
index 02ef30cadec58b8a7f4cc4c6c4a2e3f353eed2e0..b13590566ce19fe51cf68b6fb683011bc03d9b7d 100755 (executable)
@@ -246,6 +246,7 @@ ramips_setup_interfaces()
        tl-wr840n-v4|\
        tl-wr840n-v5|\
        tl-wr841n-v13|\
+       tplink,tl-wr841n-v14|\
        u7628-01-128M-16M|\
        ubnt-erx|\
        ubnt-erx-sfp|\
diff --git a/target/linux/ramips/dts/TL-WR841NV14.dts b/target/linux/ramips/dts/TL-WR841NV14.dts
new file mode 100644 (file)
index 0000000..6e12361
--- /dev/null
@@ -0,0 +1,136 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "tplink,tl-wr841n-v14", "mediatek,mt7628an-soc";
+       model = "TP-Link TL-WR841N v14";
+
+       aliases {
+               led-boot = &led_wlan;
+               led-failsafe = &led_wlan;
+               led-upgrade = &led_wlan;
+
+               led-wlan = &led_wlan;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x2000000>;
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               lan {
+                       label = "tl-wr841n-v14:green:lan";
+                       gpios = <&gpio1 7 GPIO_ACTIVE_LOW>;
+               };
+
+               wan_green {
+                       label = "tl-wr841n-v14:green:wan";
+                       gpios = <&gpio1 8 GPIO_ACTIVE_LOW>;
+               };
+
+               led_wlan: wlan {
+                       label = "tl-wr841n-v14:green:wlan";
+                       gpios = <&gpio1 9 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wan_orange {
+                       label = "tl-wr841n-v14:orange:wan";
+                       gpios = <&gpio1 10 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+               m25p,chunked-io = <32>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "boot";
+                               reg = <0x0 0x10000>;
+                               read-only;
+                       };
+
+                       partition@10000 {
+                               compatible = "tplink,firmware";
+                               label = "firmware";
+                               reg = <0x10000 0x3e0000>;
+                       };
+
+                       factory: partition@3f0000 {
+                               label = "factory";
+                               reg = <0x3f0000 0x10000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&ehci {
+       status = "disabled";
+};
+
+&ohci {
+       status = "disabled";
+};
+
+&wmac {
+       status = "okay";
+       mtd-mac-address = <&factory 0xf100>;
+       mediatek,mtd-eeprom = <&factory 0x10000>;
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0xf100>;
+       mediatek,portmap = "wllll";
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "p4led_an", "p3led_an", "p2led_an", "p1led_an", "p0led_an", "wdt";
+                       ralink,function = "gpio";
+               };
+       };
+};
+
+&gpio1 {
+       led_wlan_enable {
+               gpio-hog;
+               gpios = <11 GPIO_ACTIVE_HIGH>;
+               output-high;
+       };
+};
index 2280a1a6180fc55f04a7d7e773551ae76258b1d0..266df857a35975dfaa8416d82425c52e631e87dd 100644 (file)
@@ -259,6 +259,20 @@ define Device/tl-wr841n-v13
 endef
 TARGET_DEVICES += tl-wr841n-v13
 
+define Device/tplink_tl-wr841n-v14
+  $(Device/tplink)
+  DTS := TL-WR841NV14
+  IMAGE_SIZE := 3968k
+  DEVICE_TITLE := TP-Link TL-WR841N v14
+  TPLINK_FLASHLAYOUT := 4Mmtk
+  TPLINK_HWID := 0x08410014
+  TPLINK_HWREV := 0x1
+  TPLINK_HWREVADD := 0x14
+  TPLINK_HVERSION := 3
+  IMAGE/tftp-recovery.bin := pad-extra 64k | $$(IMAGE/factory.bin)
+endef
+TARGET_DEVICES += tplink_tl-wr841n-v14
+
 define Device/tplink_c20-v4
   $(Device/tplink)
   DTS := ArcherC20v4