bcm53xx: use default SUPPORTED_DEVICES for Meraki MR32
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 23 Jan 2021 21:03:51 +0000 (22:03 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 23 Jan 2021 22:42:47 +0000 (23:42 +0100)
Since the new global SUPPORTED_DEVICES are now available in bcm53xx
as well, we do not need to specify an explicit value for the MR32
anymore.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/bcm53xx/image/Makefile

index 00141118a166654c01b0984896d14ab3bf9183ea..90343b1e8811a92717fb4de4d8b845a66d3d866f 100644 (file)
@@ -335,10 +335,8 @@ define Device/meraki_mr32
        pad-to 10362880
   KERNEL := kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb
   IMAGES := sysupgrade.bin
-  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
-
 # Currently the only device that uses the new image check
-  SUPPORTED_DEVICES := meraki,mr32
+  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
 
 # The loader is specifically looking for fdt@2:
 # [    3.190000] find_itb_subimage: error finding fdt@2: FDT_ERR_NOTFOUND