kernel: add disabled POWER_RESET_QNAP
authorSungbo Eo <mans0n@gorani.run>
Sat, 1 Jan 2022 12:57:47 +0000 (21:57 +0900)
committerSungbo Eo <mans0n@gorani.run>
Sat, 29 Jan 2022 14:50:28 +0000 (23:50 +0900)
Move the disabled symbol from target configs to generic configs.

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
target/linux/generic/config-5.10
target/linux/generic/config-5.4
target/linux/kirkwood/config-5.10
target/linux/mvebu/config-5.10
target/linux/mvebu/modules.mk

index 619399a3196ca76d7620a89d7bd711bc2d527e92..30c48d521b53017d3c29904cb46670a9b3ef5db4 100644 (file)
@@ -4504,6 +4504,7 @@ CONFIG_POSIX_TIMERS=y
 # CONFIG_POWER_RESET_LINKSTATION is not set
 # CONFIG_POWER_RESET_LTC2952 is not set
 # CONFIG_POWER_RESET_PIIX4_POWEROFF is not set
+# CONFIG_POWER_RESET_QNAP is not set
 # CONFIG_POWER_RESET_RESTART is not set
 # CONFIG_POWER_RESET_SYSCON is not set
 # CONFIG_POWER_RESET_SYSCON_POWEROFF is not set
index 6ee1d472dbb5cedd58d25298152f1bf0bfc243e4..7fcb045b37e8ea6b0924970aee7aa2af09993db8 100644 (file)
@@ -4134,6 +4134,7 @@ CONFIG_POSIX_TIMERS=y
 # CONFIG_POWER_RESET_LINKSTATION is not set
 # CONFIG_POWER_RESET_LTC2952 is not set
 # CONFIG_POWER_RESET_PIIX4_POWEROFF is not set
+# CONFIG_POWER_RESET_QNAP is not set
 # CONFIG_POWER_RESET_RESTART is not set
 # CONFIG_POWER_RESET_SYSCON is not set
 # CONFIG_POWER_RESET_SYSCON_POWEROFF is not set
index ae9c3b099989350faba8ca158bf2f38f8ead12a1..4963712ef486c1065efaf10b4368e5fceba0303b 100644 (file)
@@ -226,7 +226,6 @@ CONFIG_PLAT_ORION=y
 CONFIG_POWER_RESET=y
 CONFIG_POWER_RESET_GPIO=y
 CONFIG_POWER_RESET_LINKSTATION=y
-# CONFIG_POWER_RESET_QNAP is not set
 CONFIG_POWER_SUPPLY=y
 CONFIG_RATIONAL=y
 CONFIG_REGMAP=y
index 86d8784c744180302700b58b65e7c7b1f117c535..ee9331252c09977510b1dee24d32642e6740e662 100644 (file)
@@ -339,7 +339,6 @@ CONFIG_PLAT_ORION=y
 CONFIG_PM_OPP=y
 CONFIG_POWER_RESET=y
 CONFIG_POWER_RESET_GPIO=y
-# CONFIG_POWER_RESET_QNAP is not set
 CONFIG_PRINTK_SAFE_LOG_BUF_SHIFT=11
 CONFIG_PWM=y
 CONFIG_PWM_SYSFS=y
index 3a5e3167883a583b17d44550aa7f43e598b50176..8d4dc4d96812cef906f613c424c3d02ef3233152 100644 (file)
@@ -4,8 +4,7 @@ define KernelPackage/linkstation-poweroff
   TITLE:=Buffalo LinkStation power off driver
   KCONFIG:= \
        CONFIG_POWER_RESET=y \
-       CONFIG_POWER_RESET_LINKSTATION \
-       CONFIG_POWER_RESET_QNAP=n
+       CONFIG_POWER_RESET_LINKSTATION
 
   FILES:=$(LINUX_DIR)/drivers/power/reset/linkstation-poweroff.ko
   AUTOLOAD:=$(call AutoLoad,31,linkstation-poweroff,1)