uhttpd: add support to generate EC keys
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Mon, 5 Aug 2019 18:34:39 +0000 (15:34 -0300)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 31 Aug 2019 22:35:11 +0000 (00:35 +0200)
This adds the key_type and ec_curve options to enable the generation of
EC keys during initialization, using openssl or the new options added to
px5g.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
package/network/services/uhttpd/Makefile
package/network/services/uhttpd/files/uhttpd.config
package/network/services/uhttpd/files/uhttpd.init

index cc2dc2bd472bd8bcf39b781489193b4c0212c885..85b7be7607d2ec0b7fca03d18898aa2fe029ecc8 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/uhttpd.git
index a3deb9cf04356fbd84396fb583b81158714db266..39089ca25b34bfdcc065682360030e3d3d6433ac 100644 (file)
@@ -118,9 +118,17 @@ config cert defaults
        # Validity time
        option days             730
 
+       # key type: rsa or ec
+       option key_type         rsa
+
        # RSA key size
        option bits             2048
 
+       # EC curve name
+       # Curve names vary between mbedtls/px5g and openssl
+       # P-256 or P-384 are guaranteed to work
+       option ec_curve         P-256
+
        # Location
        option country          ZZ
        option state            Somewhere
index dc496b3e28295e330969a4fa764673cfa3270eb1..6322473b97001eb75b236db0e613ef137a83698b 100755 (executable)
@@ -43,15 +43,19 @@ generate_keys() {
        config_get state      "$cfg" state
        config_get location   "$cfg" location
        config_get commonname "$cfg" commonname
+       config_get key_type   "$cfg" key_type
+       config_get ec_curve   "$cfg" ec_curve
 
        # Prefer px5g for certificate generation (existence evaluated last)
        local GENKEY_CMD=""
+       local KEY_OPTS="rsa:${bits:-2048}"
        local UNIQUEID=$(dd if=/dev/urandom bs=1 count=4 | hexdump -e '1/1 "%02x"')
+       [ "$key_type" = "ec" ] && KEY_OPTS="ec -pkeyopt ec_paramgen_curve:${ec_curve:-P-256}"
        [ -x "$OPENSSL_BIN" ] && GENKEY_CMD="$OPENSSL_BIN req -x509 -sha256 -outform der -nodes"
        [ -x "$PX5G_BIN" ] && GENKEY_CMD="$PX5G_BIN selfsigned -der"
        [ -n "$GENKEY_CMD" ] && {
                $GENKEY_CMD \
-                       -days ${days:-730} -newkey rsa:${bits:-2048} -keyout "${UHTTPD_KEY}.new" -out "${UHTTPD_CERT}.new" \
+                       -days ${days:-730} -newkey ${KEY_OPTS} -keyout "${UHTTPD_KEY}.new" -out "${UHTTPD_CERT}.new" \
                        -subj /C="${country:-ZZ}"/ST="${state:-Somewhere}"/L="${location:-Unknown}"/O="${commonname:-OpenWrt}$UNIQUEID"/CN="${commonname:-OpenWrt}"
                sync
                mv "${UHTTPD_KEY}.new" "${UHTTPD_KEY}"