ramips: add support for TP-Link Archer C2
authorFranz Flasch <franz.flasch@gmx.at>
Thu, 17 May 2018 09:57:00 +0000 (11:57 +0200)
committerMathias Kresin <dev@kresin.me>
Mon, 25 Jun 2018 18:52:18 +0000 (20:52 +0200)
Specification:

- System-On-Chip: MT7620A
- CPU/Speed: 580 MHz
- Flash-Chip: Winbond 25Q64BVSIG
- Flash size: 8192 KiB
- RAM: 64 MiB
- Wireless No1: SoC-integrated: MT7620A 2.4GHz 802.11bgn
- Wireless No2: On-board chip: MT7610EN 5GHz 802.11ac
- Switch: RTL8367RB Gigabit Switch
- USB: Yes 1 x 2.0

Preparing a TFTP recovery image for initial flashing:

Currently the only method to install openwrt for the first time is via
TFTP download in u-boot. After first install you can use regular updates.
WARNING: This method also overwrites the bootloader partition!

Create a TFTP recovery image:

1) Download a stock TP-Link Firmware file here:
     https://www.tp-link.com/en/download/Archer-C2_V1.html#Firmware
2) Extract u-boot from the binary file:
     #> dd if=c2v1_stock_firmware.bin of=c2v1_uboot.bin bs=1 skip=512 count=131072
3) Now merge the sysupgrade image and the u-boot into one binary:
     #> cat c2v1_uboot.bin openwrt-squashfs-sysupgrade.bin > ArcherC2V1_tp_recovery.bin

The resulting image can be flashed via TFTP recovery mode.

Flash instructions:

1) To flash the recovery image, start a TFTP server from IP address
   192.168.0.66 and serve the recovery image named
   ArcherC2V1_tp_recovery.bin.
2) Connect your device to the LAN port, then press the WPS/Reset button
   and power it up. Keep pressing the WPS/Reset button for 10 seconds.
   It will try to download the recovery image and flash it.

It can take up to 20-25 minutes to finish. When it reaches 100%, the
router will reboot itself.

Signed-off-by: Serge Vasilugin <vasilugin@yandex.ru>
Signed-off-by: Franz Flasch <franz.flasch@gmx.at>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/ArcherC2-v1.dts [new file with mode: 0644]
target/linux/ramips/image/mt7620.mk

index 54504c6ee8bb45db0ffa371ec68c3a8fd7e4d673..9ed834eb5bede105c0c7957e3254f98d7cdcaa58 100755 (executable)
@@ -398,6 +398,12 @@ tl-wr841n-v13)
        ucidef_set_led_switch "lan4" "lan4" "$boardname:green:lan4" "switch0" "0x10"
        ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
        ;;
+tplink,c2-v1)
+       ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch1" "0x1e"
+       ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch1" "0x01"
+       set_usb_led "$boardname:green:usb" "2-1"
+       set_wifi_led "$boardname:green:wlan"
+       ;;
 tplink,c20-v1)
        ucidef_set_led_switch "lan" "lan" "$boardname:blue:lan" "switch0" "0x1e"
        ucidef_set_led_switch "wan" "wan" "$boardname:blue:wan" "switch0" "0x01"
index d2c15f8f46a049de84e037091ef55aa02ec6e787..c5e5549e25da12b39788aab255c7d2ade07bee5d 100755 (executable)
@@ -335,6 +335,10 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "1:lan" "2:lan" "3:lan" "4:lan" "5:wan" "0@eth0"
                ;;
+       tplink,c2-v1)
+               ucidef_add_switch "switch1" \
+                       "1:lan" "2:lan" "3:lan" "4:lan" "0:wan" "6@eth0"
+               ;;
        tplink,tl-wr902ac-v3)
                ucidef_add_switch "switch0" \
                        "4:lan" "6@eth0"
index 2f51add331fef4693e997433a4ab0e665da80e02..dd7a646a04b1f870aed1570c93129da90efd2424 100644 (file)
@@ -79,6 +79,7 @@ get_status_led() {
        awapn2403|\
        dir-645|\
        sk-wb8|\
+       tplink,c2-v1|\
        wrh-300cr)
                status_led="$boardname:green:wps"
                ;;
index ffdc5e73e0ede286c10396810954a230c8ea32fc..26236047b442221ce631c7fa0c1bc3a89b37c7db 100755 (executable)
@@ -253,6 +253,7 @@ platform_check_image() {
        c20i|\
        c50|\
        mr200|\
+       tplink,c2-v1|\
        tplink,c20-v1|\
        tplink,c20-v4|\
        tplink,c50-v3|\
diff --git a/target/linux/ramips/dts/ArcherC2-v1.dts b/target/linux/ramips/dts/ArcherC2-v1.dts
new file mode 100644 (file)
index 0000000..6af75e3
--- /dev/null
@@ -0,0 +1,178 @@
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "tplink,c2-v1", "ralink,mt7620a-soc";
+       model = "TP-Link Archer C2 v1";
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "uartf", "wled", "ephy", "spi refclk";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               lan {
+                       label = "c2-v1:green:lan";
+                       gpios = <&gpio0 1 GPIO_ACTIVE_LOW>;
+               };
+
+               usb {
+                       label = "c2-v1:green:usb";
+                       gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+               };
+
+               wps {
+                       label = "c2-v1:green:wps";
+                       gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
+               };
+
+               wan {
+                       label = "c2-v1:green:wan";
+                       gpios = <&gpio2 0 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan {
+                       label = "c2-v1:green:wlan";
+                       gpios = <&gpio3 0 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       gpio-keys {
+               compatible = "gpio-keys";
+
+               reset_wps {
+                       label = "reset_wps";
+                       gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               rfkill {
+                       label = "rfkill";
+                       gpios = <&gpio0 2 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RFKILL>;
+               };
+       };
+
+       rtl8367rb {
+               compatible = "realtek,rtl8367b", "rtl8367b";
+               cpu_port = <6>;
+               realtek,extif1 = <1 0 1 1 1 1 1 1 2>;
+               mii-bus = <&mdio0>;
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x20000>;
+                       read-only;
+               };
+
+               partition@20000 {
+                       label = "firmware";
+                       reg = <0x20000 0x7a0000>;
+               };
+
+               partition@7c0000 {
+                       label = "config";
+                       reg = <0x7c0000 0x10000>;
+                       read-only;
+               };
+
+               rom: partition@7d0000 {
+                       label = "rom";
+                       reg = <0x7d0000 0x10000>;
+                       read-only;
+               };
+
+               partition@7e0000 {
+                       label = "romfile";
+                       reg = <0x7e0000 0x10000>;
+                       read-only;
+               };
+
+               radio: partition@7f0000 {
+                       label = "radio";
+                       reg = <0x7f0000 0x10000>;
+                       read-only;
+               };
+       };
+};
+
+&ethernet {
+       status = "okay";
+       mtd-mac-address = <&rom 0xf100>;
+       pinctrl-names = "default";
+       pinctrl-0 = <&rgmii1_pins &rgmii2_pins &mdio_pins>;
+
+       port@5 {
+               status = "okay";
+               mediatek,fixed-link = <1000 1 1 1>;
+               phy-mode = "rgmii";
+       };
+
+       mdio0: mdio-bus {
+               status = "okay";
+       };
+};
+
+
+&gpio1 {
+       status = "okay";
+};
+
+&gpio2 {
+       status = "okay";
+};
+
+&gpio3 {
+       status = "okay";
+};
+
+&wmac {
+       ralink,mtd-eeprom = <&radio 0>;
+       mtd-mac-address = <&rom 0xf100>;
+};
+
+&ehci {
+       status = "okay";
+};
+
+&ohci {
+       status = "okay";
+};
+
+&pcie {
+       status = "okay";
+
+       pcie-bridge {
+               mt76@0,0 {
+                       reg = <0x0000 0 0 0 0>;
+                       device_type = "pci";
+                       mediatek,mtd-eeprom = <&radio 0x8000>;
+               };
+       };
+};
index b6499c8806f2a94be8a57240da3a4ec00bf62860..325e3104a7e43335316cd4c075bc8830c31e3a8e 100644 (file)
@@ -472,6 +472,18 @@ define Device/tiny-ac
 endef
 TARGET_DEVICES += tiny-ac
 
+define Device/tplink_c2-v1
+  $(Device/Archer)
+  DTS := ArcherC2-v1
+  TPLINK_FLASHLAYOUT := 8Mmtk
+  TPLINK_HWID := 0xc7500001
+  TPLINK_HWREV := 50
+  IMAGES += factory.bin
+  DEVICE_TITLE := TP-Link Archer C2 v1
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-switch-rtl8366-smi kmod-switch-rtl8367b
+endef
+TARGET_DEVICES += tplink_c2-v1
+
 define Device/tplink_c20-v1
   $(Device/Archer)
   DTS := ArcherC20v1