ramips: add support for Edimax EW-7476RPC / EW-7478AC
authorBirger Koblitz <mail@birger-koblitz.de>
Mon, 3 Jun 2019 20:04:12 +0000 (22:04 +0200)
committerPetr Štetiar <ynezz@true.cz>
Thu, 20 Jun 2019 06:31:24 +0000 (08:31 +0200)
SoC: MediaTek MT7620a @ 580MHz
RAM: 64M (Winbond W9751G6KB-25)
FLASH: 8MB (Macronix)
WiFi: SoC-integrated: MediaTek MT7620a bgn
WiFi: MediaTek MT7612EN nac
GbE: 1x (RTL8211E)
BTN: WPS - RFKILL/RF 50%/RF 100% toggle
LED: - Wifi 5g (blue)
- Wifi 2g (blue)
- Crossband (green)
- Power (green)
- WPS (green)
- LAN (Green)
UART: UART is present as Pads with throughholes on the PCB. They are
located next to the switch for the wifi configuration
3.3V - RX - GND - TX / 57600-8N1
3.3V is the square pad

Installation
------------
Update the factory image via the web-interfaces (by default:
192.168.9.2/24).
http://192.168.9.2/index.asp

ramips: add Edimax EW-7478AC

SoC: MediaTek MT7620a @ 580MHz
RAM: 64M (Winbond W9751G6KB-25)
FLASH: 8MB (Macronix)
WiFi: SoC-integrated: MediaTek MT7620a bgn
WiFi: MediaTek MT7612EN nac
GbE: 1x (RTL8211E)
BTN: WPS - RFKILL/RF 50%/RF 100% toggle
LED: - Wifi 5g (blue)
- Wifi 2g (blue)
- Crossband (green)
- Power (green)
- WPS (green)
- LAN (Green)
UART: UART is present as Pads with throughholes on the PCB. They are
located next to the switch for the wifi configuration
3.3V - RX - GND - TX / 57600-8N1
3.3V is the square pad

Installation
------------
Update the factory image via the web-interfaces (by default:
http://edimaxext.setup)
Or push wpa button on power on and send firmware via tftp to 192.168.1.6

The EW-7478AC is identical to the EW-7476RPC, except instead of 2 internal
antennas it has 2 external ones.

Signed-off-by: Birger Koblitz <mail@birger-koblitz.de>
[merge conflict in 01_leds]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/dts/EW-7476RPC.dts [new file with mode: 0644]
target/linux/ramips/dts/EW-7478AC.dts [new file with mode: 0644]
target/linux/ramips/dts/EW-747x.dtsi [new file with mode: 0644]
target/linux/ramips/files-4.14/drivers/net/ethernet/mediatek/mtk_eth_soc.c
target/linux/ramips/image/mt7620.mk

index 35d046cc90324b352c0ac12c2a1ae8a8e94d75cd..658e3512ca27389f914f6f001d301fb2d2afae08 100755 (executable)
@@ -38,6 +38,10 @@ alfa-network,awusfree1|\
 edimax,br-6478ac-v2)
        set_wifi_led "$boardname:blue:wlan"
        ;;
+edimax,ew-7476rpc|\
+edimax,ew-7478ac)
+       ucidef_set_led_switch "lan" "lan" "$boardname:green:lan"  "switch0" "0x20"
+       ;;
 alfa-network,tube-e4g)
        ucidef_set_led_netdev "4g" "4g" "$boardname:green:4g" "wwan0"
        ucidef_set_led_netdev "lan" "lan" "$boardname:blue:lan" "eth0"
index 96e5b7e1ccf824cfcad94b3be749dcae5cd03aff..52204eacbfba2a67732cf1e9a8457c34fce4e3ed 100755 (executable)
@@ -50,6 +50,8 @@ ramips_setup_interfaces()
        broadway|\
        dcs-930|\
        dcs-930l-b1|\
+       edimax,ew-7476rpc|\
+       edimax,ew-7478ac|\
        ht-tm02|\
        kimax,u35wf|\
        linkits7688 | \
diff --git a/target/linux/ramips/dts/EW-7476RPC.dts b/target/linux/ramips/dts/EW-7476RPC.dts
new file mode 100644 (file)
index 0000000..0f35ee0
--- /dev/null
@@ -0,0 +1,47 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+/dts-v1/;
+
+#include "EW-747x.dtsi"
+
+/ {
+       compatible = "edimax,ew-7476rpc", "ralink,mt7620a-soc";
+       model = "Edimax EW-7476RPC";
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power: power {
+                       label = "ew-7476rpc:green:power";
+                       gpios = <&gpio2 27 GPIO_ACTIVE_LOW>;
+               };
+
+               lan {
+                       label = "ew-7476rpc:green:lan";
+                       gpios = <&gpio2 26 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan2g {
+                       label = "ew-7476rpc:blue:wlan2g";
+                       gpios = <&gpio2 30 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1radio";
+               };
+
+               wlan5g {
+                       label = "ew-7476rpc:blue:wlan5g";
+                       gpios = <&gpio2 31 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0radio";
+               };
+
+               wps {
+                       label = "ew-7476rpc:green:wps";
+                       gpios = <&gpio2 28 GPIO_ACTIVE_LOW>;
+               };
+
+               crossband {
+                       label = "ew-7476rpc:green:crossband";
+                       gpios = <&gpio2 29 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
diff --git a/target/linux/ramips/dts/EW-7478AC.dts b/target/linux/ramips/dts/EW-7478AC.dts
new file mode 100644 (file)
index 0000000..b869ff3
--- /dev/null
@@ -0,0 +1,46 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+/dts-v1/;
+
+#include "EW-747x.dtsi"
+
+/ {
+       compatible = "edimax,ew-7478ac", "ralink,mt7620a-soc";
+       model = "Edimax EW-7478ac";
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power: power {
+                       label = "ew-7478ac:green:power";
+                       gpios = <&gpio2 27 GPIO_ACTIVE_LOW>;
+               };
+
+               lan {
+                       label = "ew-7478ac:green:lan";
+                       gpios = <&gpio2 26 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan2g {
+                       label = "ew-7478ac:blue:wlan2g";
+                       gpios = <&gpio2 30 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1radio";
+               };
+
+               wlan5g {
+                       label = "ew-7478ac:blue:wlan5g";
+                       gpios = <&gpio2 31 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0radio";
+               };
+
+               wps {
+                       label = "ew-7478ac:green:wps";
+                       gpios = <&gpio2 28 GPIO_ACTIVE_LOW>;
+               };
+
+               crossband {
+                       label = "ew-7478ac:green:crossband";
+                       gpios = <&gpio2 29 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
diff --git a/target/linux/ramips/dts/EW-747x.dtsi b/target/linux/ramips/dts/EW-747x.dtsi
new file mode 100644 (file)
index 0000000..b7d8087
--- /dev/null
@@ -0,0 +1,192 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+/dts-v1/;
+
+#include "mt7620a.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "ralink,mt7620a-soc";
+
+       aliases {
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+               led-running = &led_power;
+               led-upgrade = &led_power;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset_wps {
+                       label = "reset_wps";
+                       gpios = <&gpio2 20 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               switch_high {
+                       label = "switch high";
+                       gpios = <&gpio2 22 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_0>;
+                       linux,input-type = <EV_SW>;
+               };
+
+               switch_off {
+                       label = "switch off";
+                       gpios = <&gpio2 23 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_1>;
+                       linux,input-type = <EV_SW>;
+               };
+       };
+};
+
+&gpio1 {
+       status = "okay";
+};
+
+&gpio2 {
+       status = "okay";
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               label = "cimage";
+                               reg = <0x50000 0x20000>;
+                               read-only;
+                       };
+
+                       partition@70000 {
+                               compatible = "edimax,uimage";
+                               label = "firmware";
+                               reg = <0x00070000 0x00790000>;
+                       };
+               };
+       };
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "i2c", "uartf", "nd_sd", "rgmii2";
+                       ralink,function = "gpio";
+               };
+       };
+
+       phy_reset_pins: phy-reset {
+               gpio {
+                       ralink,group = "spi refclk";
+                       ralink,function = "gpio";
+               };
+       };
+};
+
+&ethernet {
+
+       status = "okay";
+       mtd-mac-address = <&factory 0x4>;
+
+       pinctrl-names = "default";
+       pinctrl-0 = <&rgmii1_pins &mdio_pins &phy_reset_pins>;
+
+       mediatek,portmap = "l";
+       mediatek,mdio-mode = <1>;
+
+       phy-reset-gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
+       phy-reset-duration = <30>;
+
+       port@5 {
+               status = "okay";
+               mediatek,fixed-link = <1000 1 1 1>;
+               phy-mode = "rgmii";
+       };
+
+       mdio-bus {
+               status = "okay";
+
+               phy0: ethernet-phy@0 {
+                       status = "disabled";
+                       reg = <0>;
+                       phy-mode = "rgmii";
+               };
+
+               phy1: ethernet-phy@1 {
+                       status = "disabled";
+                       reg = <1>;
+                       phy-mode = "rgmii";
+               };
+
+               phy2: ethernet-phy@2 {
+                       status = "disabled";
+                       reg = <2>;
+                       phy-mode = "rgmii";
+               };
+
+               phy3: ethernet-phy@3 {
+                       status = "disabled";
+                       reg = <3>;
+                       phy-mode = "rgmii";
+               };
+
+               phy4: ethernet-phy@4 {
+                       status = "disabled";
+                       reg = <4>;
+                       phy-mode = "rgmii";
+               };
+       };
+};
+
+&gsw {
+       mediatek,port5 = "gmac";
+};
+
+&wmac {
+       ralink,mtd-eeprom = <&factory 0>;
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               mediatek,2ghz = <0>;
+       };
+};
index b2c3d32c5549b6fd8ea4c76dc224b9b4b41130d8..65aa7f32606518a1ed6e497559f17113115cbe86 100644 (file)
@@ -32,6 +32,9 @@
 #include <linux/bug.h>
 #include <linux/netfilter.h>
 #include <net/netfilter/nf_flow_table.h>
+#include <linux/of_gpio.h>
+#include <linux/gpio.h>
+#include <linux/gpio/consumer.h>
 
 #include <asm/mach-ralink/ralink_regs.h>
 
@@ -1333,6 +1336,35 @@ static int fe_stop(struct net_device *dev)
        return 0;
 }
 
+static void fe_reset_phy(struct fe_priv *priv)
+{
+       int err, msec = 30;
+       struct gpio_desc *phy_reset;
+
+       phy_reset = devm_gpiod_get_optional(priv->dev, "phy-reset",
+                                           GPIOD_OUT_HIGH);
+       if (!phy_reset)
+               return;
+
+       if (IS_ERR(phy_reset)) {
+               dev_err(priv->dev, "Error acquiring reset gpio pins: %ld\n",
+                       PTR_ERR(phy_reset));
+               return;
+       }
+
+       err = of_property_read_u32(priv->dev->of_node, "phy-reset-duration",
+                                  &msec);
+       if (!err && msec > 1000)
+               msec = 30;
+
+       if (msec > 20)
+               msleep(msec);
+       else
+               usleep_range(msec * 1000, msec * 1000 + 1000);
+
+       gpiod_set_value(phy_reset, 0);
+}
+
 static int __init fe_init(struct net_device *dev)
 {
        struct fe_priv *priv = netdev_priv(dev);
@@ -1348,6 +1380,8 @@ static int __init fe_init(struct net_device *dev)
                        return -ENODEV;
                }
 
+       fe_reset_phy(priv);
+
        mac_addr = of_get_mac_address(priv->dev->of_node);
        if (mac_addr)
                ether_addr_copy(dev->dev_addr, mac_addr);
index 8d35402561dd980abbc8b12e01e391a32cc35ef8..721cd7f43d8dc028570a49fee67d5392b725909d 100644 (file)
@@ -618,6 +618,30 @@ define Device/edimax_br-6478ac-v2
 endef
 TARGET_DEVICES += edimax_br-6478ac-v2
 
+define Device/edimax_ew-7476rpc
+  DTS := EW-7476RPC
+  DEVICE_TITLE := Edimax EW-7476RPC
+  BLOCKSIZE := 4k
+  IMAGE_SIZE := 7744k
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+        edimax-header -s CSYS -m RN79 -f 0x70000 -S 0x01100000 | pad-rootfs | \
+        append-metadata | check-size $$$$(IMAGE_SIZE)
+  DEVICE_PACKAGES := kmod-mt76x2 kmod-phy-realtek
+endef
+TARGET_DEVICES += edimax_ew-7476rpc
+
+define Device/edimax_ew-7478ac
+  DTS := EW-7478AC
+  DEVICE_TITLE := Edimax EW-7478AC
+  BLOCKSIZE := 4k
+  IMAGE_SIZE := 7744k
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+        edimax-header -s CSYS -m RN70 -f 0x70000 -S 0x01100000 | pad-rootfs | \
+        append-metadata | check-size $$$$(IMAGE_SIZE)
+  DEVICE_PACKAGES := kmod-mt76x2 kmod-phy-realtek
+endef
+TARGET_DEVICES += edimax_ew-7478ac
+
 define Device/tplink_c2-v1
   $(Device/Archer)
   DTS := ArcherC2-v1