trace-cmd: disable AUDIT (libaudit library)
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Fri, 2 Oct 2020 12:17:48 +0000 (14:17 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 11 Oct 2020 14:16:24 +0000 (16:16 +0200)
If you compile first libaudit library and then trace-cmd package,
compilations fails with:

Package trace-cmd is missing dependencies for the following libraries:
libaudit.so.1

If you enable libaudit for trace-cmd, it will show system name calls while using command profile.
Try to be slim as much as possible - libaudit .ipk has 42,4 kB.

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
package/devel/trace-cmd/Makefile

index 25831d8b1b61e4d3ee75c9e9e674bdc510686cf3..d1f73ae9bbb1e5e57a5698bd69de2c2b1f31dbcb 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=trace-cmd
 PKG_VERSION:=v2.6.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git/snapshot/
@@ -31,6 +31,7 @@ endef
 
 MAKE_FLAGS += \
        NO_PYTHON=1 \
+       NO_AUDIT=1 \
        prefix=/usr
 
 PLUGINS_DIR := $(PKG_INSTALL_DIR)/usr/lib/trace-cmd/plugins