ramips: remove kmod-mt7663-firmware-sta from device packages
authorFelix Fietkau <nbd@nbd.name>
Sun, 17 Oct 2021 14:05:34 +0000 (16:05 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sun, 17 Oct 2021 14:07:03 +0000 (16:07 +0200)
This firmware should only be used for mobile devices (e.g. laptops), where
AP mode functionality is typically not used. This firmware supports a lot
of power saving offload functionality at the expense of AP mode support.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/ramips/image/mt7621.mk

index ecb102467bc17163de210d4ba2a56530291f5d3e..c81e79c900a1d31bead408f990e4b1a2f6958fd7 100644 (file)
@@ -825,7 +825,7 @@ define Device/linksys_e5600
   DEVICE_VENDOR := Linksys
   DEVICE_MODEL := E5600
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap \
-       kmod-mt7663-firmware-sta uboot-envtools
+       uboot-envtools
   UBINIZE_OPTS := -E 5
   IMAGES += factory.bin
   IMAGE/sysupgrade.bin := sysupgrade-tar | check-size | append-metadata
@@ -1316,7 +1316,7 @@ define Device/tplink_archer-a6-v3
   DEVICE_MODEL := Archer A6
   DEVICE_VARIANT := V3
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e \
-       kmod-mt7663-firmware-ap kmod-mt7663-firmware-sta
+       kmod-mt7663-firmware-ap
   TPLINK_BOARD_ID := ARCHER-A6-V3
   KERNEL := $(KERNEL_DTB) | uImage lzma
   IMAGE_SIZE := 15744k
@@ -1329,7 +1329,7 @@ define Device/tplink_archer-c6-v3
   DEVICE_MODEL := Archer C6
   DEVICE_VARIANT := V3
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e \
-       kmod-mt7663-firmware-ap kmod-mt7663-firmware-sta
+       kmod-mt7663-firmware-ap
   TPLINK_BOARD_ID := ARCHER-C6-V3
   KERNEL := $(KERNEL_DTB) | uImage lzma
   IMAGE_SIZE := 15744k