bcm53xx: image: build UBI partition image
authorRafał Miłecki <zajec5@gmail.com>
Thu, 16 Oct 2014 20:48:56 +0000 (20:48 +0000)
committerRafał Miłecki <zajec5@gmail.com>
Thu, 16 Oct 2014 20:48:56 +0000 (20:48 +0000)
This could be used on NAND devices once we get UBI working.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
SVN-Revision: 42938

target/linux/bcm53xx/image/Makefile
target/linux/bcm53xx/image/ubinize.cfg [new file with mode: 0644]

index 576de80709256d0ee1524b09a8f35ce5a4ac9de0..9dd2a9c9988a9c52c9743a734b1618abf3808274 100644 (file)
@@ -11,6 +11,8 @@ define Image/Prepare
        rm -f $(KDIR)/fs_mark
        echo -ne '\xde\xad\xc0\xde' > $(KDIR)/fs_mark
        $(call prepare_generic_squashfs,$(KDIR)/fs_mark)
+
+       $(CP) ./ubinize.cfg $(KDIR)
 endef
 
 define trx2ndpart/serial
@@ -73,6 +75,8 @@ endef
 
 # $(1): filesystem type (e.g. squashfs, initramfs).
 define Image/Build
+       ( cd $(KDIR); $(STAGING_DIR_HOST)/bin/ubinize -p 128KiB -m 2048 -o $(KDIR)/root-block-0x20000-min-0x800.ubi ubinize.cfg )
+
        $(call Image/Build/AsusTrx,$(1),bcm47081-asus-rt-n18u,serial,RT-N18U)
 
        $(call Image/Build/Chk,$(1),bcm4708-netgear-r6250,serial,U12H245T00_NETGEAR,1)
diff --git a/target/linux/bcm53xx/image/ubinize.cfg b/target/linux/bcm53xx/image/ubinize.cfg
new file mode 100644 (file)
index 0000000..a4f2f09
--- /dev/null
@@ -0,0 +1,24 @@
+[rootfs]
+# Volume mode (other option is static)
+mode=ubi
+# Source image
+image=root.squashfs
+# Volume ID in UBI image
+vol_id=0
+# Allow for dynamic resize
+vol_type=dynamic
+# Volume name
+vol_name=rootfs
+
+[rootfs_data]
+# Volume mode (other option is static)
+mode=ubi
+# Volume ID in UBI image
+vol_id=1
+# Allow for dynamic resize
+vol_type=dynamic
+# Volume name
+vol_name=rootfs_data
+# Autoresize volume at first mount
+vol_flags=autoresize
+vol_size=1MiB