ramips: fix broken UniFi 6 Lite image
authorDavid Bauer <mail@david-bauer.net>
Wed, 17 Mar 2021 23:54:25 +0000 (00:54 +0100)
committerDavid Bauer <mail@david-bauer.net>
Wed, 17 Mar 2021 23:54:25 +0000 (00:54 +0100)
Ubiquiti's own bootloader expects the configuration mode to be present
with a "@" instead of a "-" for the sperator character. Otherwise
booting of the image fails.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ramips/image/mt7621.mk

index 396b112b760ec08e96b987e8bbac17db712d82e6..21d192fc0b2fd11efbac0ea3a58ddc92327e8636 100644 (file)
@@ -1193,6 +1193,7 @@ define Device/ubnt_unifi-6-lite
   $(Device/dsa-migration)
   DEVICE_VENDOR := Ubiquiti
   DEVICE_MODEL := UniFi 6 Lite
+  DEVICE_DTS_CONFIG := config@1
   DEVICE_PACKAGES += kmod-mt7603 kmod-mt7915e
   KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
   IMAGE_SIZE := 15424k