ramips: provide default BLOCKSIZE for Device/seama
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 29 Aug 2021 22:18:53 +0000 (00:18 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 29 Aug 2021 22:37:47 +0000 (00:37 +0200)
The Device/seama shared definition requires BLOCKSIZE, so it should
have a default value for this variable.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ramips/image/Makefile
target/linux/ramips/image/mt7621.mk
target/linux/ramips/image/rt3883.mk

index cd2c425cefaaa9f934c726f5660b9075967bfa75..3671caef9dc6effe62d50ccd04ed5155b180350f 100644 (file)
@@ -182,6 +182,7 @@ define Device/netgear_sercomm_nor
 endef
 
 define Device/seama
+  BLOCKSIZE := 64k
   SEAMA_MTDBLOCK := 2
   IMAGES += factory.bin
 
index ea0c3fc619031c6c7acabdb50a5d3b7a2e100858..c115d04bd67b62d7708e0c5f5a952fd36955ed1b 100644 (file)
@@ -360,7 +360,6 @@ TARGET_DEVICES += dlink_dir-853-r1
 define Device/dlink_dir-860l-b1
   $(Device/dsa-migration)
   $(Device/seama)
-  BLOCKSIZE := 64k
   SEAMA_SIGNATURE := wrgac13_dlink.2013gui_dir860lb
   LOADER_TYPE := bin
   KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | relocate-kernel | \
index 148bfbbe4458dd5e6c055bb7ab3dd3f7a6f4e123..db4ffc83dfbcf8c8aa6b740f0b32567ec4ece635 100644 (file)
@@ -97,7 +97,6 @@ TARGET_DEVICES += omnima_hpm
 define Device/samsung_cy-swr1100
   $(Device/seama)
   SOC := rt3662
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 7872k
   KERNEL := $(KERNEL_DTB)
   SEAMA_SIGNATURE := wrgnd10_samsung_ss815