ramips: mt7621: add support for Xiaomi Mi Router 4
authorDmytro Oz <sequentiality@gmail.com>
Mon, 14 Dec 2020 19:07:32 +0000 (21:07 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 21 Jan 2021 21:53:19 +0000 (22:53 +0100)
Xiaomi Mi Router 4 is the same as Xiaomi Mi Router 3G, except for
the RAM (256Mib→128Mib), LEDs and gpio (MiNet button).

Specifications:

Power: 12 VDC, 1 A
Connector type: barrel
CPU1: MediaTek MT7621A (880 MHz, 4 cores)
FLA1: 128 MiB (ESMT F59L1G81MA)
RAM1: 128 MiB (ESMT M15T1G1664A)
WI1 chip1: MediaTek MT7603EN
WI1 802dot11 protocols: bgn
WI1 MIMO config: 2x2:2
WI1 antenna connector: U.FL
WI2 chip1: MediaTek MT7612EN
WI2 802dot11 protocols: an+ac
WI2 MIMO config: 2x2:2
WI2 antenna connector: U.FL
ETH chip1: MediaTek MT7621A
Switch: MediaTek MT7621A

UART Serial
[o] TX
[o] GND
[o] RX
[ ] VCC - Do not connect it

MAC addresses as verified by OEM firmware:

use   address   source
LAN   *:c2      factory 0xe000 (label)
WAN   *:c3      factory 0xe006
2g    *:c4      factory 0x0000
5g    *:c5      factory 0x8000

Flashing instructions:

1.Create a simple http server (nginx etc)
2.set uart enable
To enable writing to the console, you must reset to factory settings
Then you see uboot boot, press the keyboard 4 button (enter uboot command line)
If it is not successful, repeat the above operation of restoring the factory settings.
After entering the uboot command line, type:

setenv uart_en 1
saveenv
boot

3.use shell in uart
cd /tmp
wget http://"your_computer_ip:80"/openwrt-ramips-mt7621-xiaomi_mir4-squashfs-kernel1.bin
wget http://"your_computer_ip:80"/openwrt-ramips-mt7621-xiaomi_mir4-squashfs-rootfs0.bin
mtd write openwrt-ramips-mt7621-xiaomi_mir4-squashfs-kernel1.bin kernel1
mtd write openwrt-ramips-mt7621-xiaomi_mir4-squashfs-rootfs0.bin rootfs0
nvram set flag_try_sys1_failed=1
nvram commit
reboot
4.login to the router http://192.168.1.1/

Installation via Software exploit
Find the instructions in the https://github.com/acecilia/OpenWRTInvasion

Signed-off-by: Dmytro Oz <sequentiality@gmail.com>
[commit message facelift, rebase onto shared DTSI/common device
definition, bump uboot-envtools]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/boot/uboot-envtools/files/ramips
target/linux/ramips/dts/mt7621_xiaomi_mi-router-4.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/02_network
target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh

index 0568f1fa692426c64b6c9cfcba158b02ce6db635..597c8f6ca6f2390ab04369017695476c440bb2ea 100644 (file)
@@ -48,6 +48,7 @@ linksys,ea7300-v2|\
 linksys,ea7500-v2|\
 xiaomi,mi-router-3g|\
 xiaomi,mi-router-3-pro|\
+xiaomi,mi-router-4|\
 xiaomi,mi-router-ac2100|\
 xiaomi,redmi-router-ac2100)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x1000" "0x20000"
diff --git a/target/linux/ramips/dts/mt7621_xiaomi_mi-router-4.dts b/target/linux/ramips/dts/mt7621_xiaomi_mi-router-4.dts
new file mode 100644 (file)
index 0000000..f8fc01e
--- /dev/null
@@ -0,0 +1,96 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_xiaomi_nand_128m.dtsi"
+
+/ {
+       compatible = "xiaomi,mi-router-4", "mediatek,mt7621-soc";
+       model = "Xiaomi Mi Router 4";
+
+       aliases {
+               led-boot = &led_status_yellow;
+               led-failsafe = &led_status_red;
+               led-running = &led_status_blue;
+               led-upgrade = &led_status_yellow;
+               label-mac-device = &gmac0;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status_red: status_red {
+                       label = "red:status";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+               };
+
+               led_status_blue: status_blue {
+                       label = "blue:status";
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+               };
+
+               led_status_yellow: status_yellow {
+                       label = "yellow:status";
+                       gpios = <&gpio 10 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&keys {
+       minet {
+               label = "minet";
+               gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+               linux,code = <KEY_WPS_BUTTON>;
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "pci14c3,7603";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0000>;
+               ieee80211-freq-limit = <2400000 2500000>;
+       };
+};
+
+&pcie1 {
+       wifi@0,0 {
+               compatible = "pci14c3,7662";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&gmac0 {
+       mtd-mac-address = <&factory 0xe000>;
+};
+
+&switch0 {
+       ports {
+               port@1 {
+                       status = "okay";
+                       label = "lan1";
+               };
+
+               port@2 {
+                       status = "okay";
+                       label = "lan2";
+               };
+
+               port@4 {
+                       status = "okay";
+                       label = "wan";
+                       mtd-mac-address = <&factory 0xe006>;
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "jtag", "uart2", "uart3", "wdt";
+               function = "gpio";
+       };
+};
index ff39cbf39a6df20b8fc0167cde0dd4b974c588b3..005a9bdc55d86154ec51087159f7bb2ab41f6251 100644 (file)
@@ -1277,6 +1277,14 @@ define Device/xiaomi_mi-router-3-pro
 endef
 TARGET_DEVICES += xiaomi_mi-router-3-pro
 
+define Device/xiaomi_mi-router-4
+  $(Device/xiaomi_nand_separate)
+  DEVICE_MODEL := Mi Router 4
+  IMAGE_SIZE := 124416k
+  DEVICE_PACKAGES += kmod-mt7603 kmod-mt76x2
+endef
+TARGET_DEVICES += xiaomi_mi-router-4
+
 define Device/xiaomi_mi-router-4a-gigabit
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)
index 83c4162e2ffe8800d473c2f958907ee3e3bc2d18..154f218bfecc7e73229b42dccf86b38bdb805794 100755 (executable)
@@ -19,6 +19,7 @@ ramips_setup_interfaces()
        mikrotik,routerboard-m33g|\
        xiaomi,mi-router-3g|\
        xiaomi,mi-router-3g-v2|\
+       xiaomi,mi-router-4|\
        xiaomi,mi-router-4a-gigabit)
                ucidef_set_interfaces_lan_wan "lan1 lan2" "wan"
                ;;
index 99ed36e429111cc19851fc43bcc2963c719e759c..5bb0386253b4964d9244f95fb7af0b5ebd59ee9c 100755 (executable)
@@ -63,6 +63,7 @@ platform_do_upgrade() {
        netis,wf2881|\
        xiaomi,mi-router-3g|\
        xiaomi,mi-router-3-pro|\
+       xiaomi,mi-router-4|\
        xiaomi,mi-router-ac2100|\
        xiaomi,redmi-router-ac2100)
                nand_do_upgrade "$1"