tools/ccache: find libzstd using rpath
authorThomas Nixon <tom@tomn.co.uk>
Sat, 9 Jan 2021 22:04:48 +0000 (22:04 +0000)
committerPaul Spooren <mail@aparcar.org>
Mon, 11 Jan 2021 07:40:23 +0000 (21:40 -1000)
Previously, ccache would end up using the system libzstd, which is not
supposed to be a build requirement.

Signed-off-by: Thomas Nixon <tom@tomn.co.uk>
tools/ccache/Makefile

index e016e0beb3bf44110a8088cd4a3ef667d37461cc..ff0204ae19e6f6d36ea274996f975e38f15cd4d2 100644 (file)
@@ -21,7 +21,10 @@ include $(INCLUDE_DIR)/cmake.mk
 
 CMAKE_HOST_OPTIONS += \
        -DCMAKE_C_COMPILER_LAUNCHER="" \
-       -DCMAKE_CXX_COMPILER_LAUNCHER=""
+       -DCMAKE_CXX_COMPILER_LAUNCHER="" \
+       -DCMAKE_SKIP_RPATH=FALSE \
+       -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOST}/lib" \
+
 
 define Host/Install/ccache
        $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/