kernel: bump version 5.10 to 5.10.18
authorKabuli Chana <newtownBuild@gmail.com>
Tue, 23 Feb 2021 17:29:49 +0000 (10:29 -0700)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 24 Feb 2021 17:45:59 +0000 (18:45 +0100)
update kernel version, refresh current patchset

Signed-off-by: Kabuli Chana <newtownBuild@gmail.com>
[rebase/refresh]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
23 files changed:
include/kernel-version.mk
target/linux/ath79/patches-5.10/0005-usb-add-more-OF-quirk-properties.patch
target/linux/ath79/patches-5.10/0020-MIPS-pci-ar724x-convert-to-OF.patch
target/linux/ath79/patches-5.10/0032-MIPS-ath79-sanitize-symbols.patch
target/linux/ath79/patches-5.10/0036-GPIO-add-named-gpio-exports.patch
target/linux/ath79/patches-5.10/004-register_gpio_driver_earlier.patch
target/linux/ath79/patches-5.10/0062-MIPS-pci-ar724x-add-QCA9550-reset-sequence.patch
target/linux/ath79/patches-5.10/410-spi-ath79-Implement-the-spi_mem-interface.patch
target/linux/ath79/patches-5.10/425-at803x-allow-sgmii-aneg-override.patch
target/linux/ath79/patches-5.10/430-drivers-link-spi-before-mtd.patch
target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch
target/linux/ath79/patches-5.10/921-serial-core-add-support-for-boot-console-with-arbitr.patch
target/linux/generic/pending-5.10/203-kallsyms_uncompressed.patch
target/linux/generic/pending-5.10/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/pending-5.10/690-net-add-support-for-threaded-NAPI-polling.patch
target/linux/generic/pending-5.10/840-hwrng-bcm2835-set-quality-to-1000.patch
target/linux/mpc85xx/patches-5.10/102-powerpc-add-cmdline-override.patch
target/linux/mpc85xx/patches-5.10/103-powerpc-85xx-red-15w-rev1.patch
target/linux/mvebu/patches-5.10/100-ARM-dts-turris-omnia-fix-hardware-buffer-management.patch
target/linux/mvebu/patches-5.10/101-ARM-dts-turris-omnia-configure-LED-2--INTn-pin-as-interrupt-pin.patch
target/linux/rockchip/patches-5.10/002-net-usb-r8152-add-LED-configuration-from-OF.patch
target/linux/rockchip/patches-5.10/102-rockchip-enable-LAN-port-on-NanoPi-R2S.patch
target/linux/rockchip/patches-5.10/103-arm64-rockchip-add-OF-node-for-USB-eth-on-NanoPi-R2S.patch

index 79525c7d71bffe5837d5b0252f076606ffa30308..fa70cfde3ed75f0318c67e04006620ac281dc88c 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .99
-LINUX_VERSION-5.10 = .16
+LINUX_VERSION-5.10 = .18
 
 LINUX_KERNEL_HASH-5.4.99 = 5bdad12c69253d30d836dd51e0b2a9a04a6749cc6b4b2412561a1efcb1351a27
-LINUX_KERNEL_HASH-5.10.16 = 536fe3ea273bfcc72b3571d3b3a7ff0a5bcdc16068efd22e42c4f9d03c200a37
+LINUX_KERNEL_HASH-5.10.18 = 3bc1ee2b1bf73b5ba936721953f3f9599fd165cef906cd5163c68d23cb9bb611
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 3c8740311d14c82d04cf472ed55f0e1ba2f14d78..d6d8cb69522225e8a1e799196a6a6c6c6809ad6f 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/usb/host/ehci-platform.c
 +++ b/drivers/usb/host/ehci-platform.c
-@@ -269,6 +269,11 @@ static int ehci_platform_probe(struct pl
+@@ -277,6 +277,11 @@ static int ehci_platform_probe(struct pl
        ehci = hcd_to_ehci(hcd);
  
        if (pdata == &ehci_platform_defaults && dev->dev.of_node) {
index b8a877c63d27cd869650ba114f424aabf92387e0..2772c533928be41e80049dd1d76a1a54befcfc93 100644 (file)
@@ -154,7 +154,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
        irq_set_chained_handler_and_data(apc->irq, ar724x_pci_irq_handler,
                                         apc);
  }
-@@ -391,29 +399,11 @@ static int ar724x_pci_probe(struct platf
+@@ -388,29 +396,11 @@ static int ar724x_pci_probe(struct platf
        if (apc->irq < 0)
                return -EINVAL;
  
@@ -186,7 +186,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  
        /*
         * Do the full PCIE Root Complex Initialization Sequence if the PCIe
-@@ -435,10 +425,16 @@ static int ar724x_pci_probe(struct platf
+@@ -432,10 +422,16 @@ static int ar724x_pci_probe(struct platf
        return 0;
  }
  
index 14dddd5147670a3244db30c3c6a320fed37a9d4b..5a923298cd9e8dddb5f6f3e581ec7c54196d852f 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -217,6 +217,8 @@ config ATH79
+@@ -242,6 +242,8 @@ config ATH79
        select SYS_SUPPORTS_BIG_ENDIAN
        select SYS_SUPPORTS_MIPS16
        select SYS_SUPPORTS_ZBOOT_UART_PROM
@@ -82,12 +82,12 @@ Signed-off-by: John Crispin <john@phrozen.org>
  endif
 --- a/arch/mips/pci/Makefile
 +++ b/arch/mips/pci/Makefile
-@@ -23,7 +23,7 @@ obj-$(CONFIG_BCM63XX)                += pci-bcm63xx.o
+@@ -21,7 +21,7 @@ obj-$(CONFIG_BCM63XX)                += pci-bcm63xx.o
                                        ops-bcm63xx.o
  obj-$(CONFIG_MIPS_ALCHEMY)    += pci-alchemy.o
  obj-$(CONFIG_PCI_AR2315)      += pci-ar2315.o
 -obj-$(CONFIG_SOC_AR71XX)      += pci-ar71xx.o
 +obj-$(CONFIG_PCI_AR71XX)      += pci-ar71xx.o
  obj-$(CONFIG_PCI_AR724X)      += pci-ar724x.o
- obj-$(CONFIG_MIPS_PCI_VIRTIO) += pci-virtio-guest.o
  obj-$(CONFIG_PCI_XTALK_BRIDGE)        += pci-xtalk-bridge.o
+ #
index d4ea379159260064a5898a3c2f2765154baf7b5d..fe34f0b21bc9d597bb67594381e32847079ef9fb 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
  #include "gpiolib.h"
  #include "gpiolib-of.h"
-@@ -915,3 +917,68 @@ void of_gpiochip_remove(struct gpio_chip
+@@ -1039,3 +1041,68 @@ void of_gpiochip_remove(struct gpio_chip
  {
        of_node_put(chip->of_node);
  }
@@ -93,7 +93,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 +module_platform_driver(gpio_export_driver);
 --- a/drivers/gpio/gpiolib-sysfs.c
 +++ b/drivers/gpio/gpiolib-sysfs.c
-@@ -563,7 +563,7 @@ static struct class gpio_class = {
+@@ -564,7 +564,7 @@ static struct class gpio_class = {
   *
   * Returns zero on success, else an error.
   */
@@ -102,7 +102,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  {
        struct gpio_chip        *chip;
        struct gpio_device      *gdev;
-@@ -625,6 +625,8 @@ int gpiod_export(struct gpio_desc *desc,
+@@ -626,6 +626,8 @@ int gpiod_export(struct gpio_desc *desc,
        offset = gpio_chip_hwgpio(desc);
        if (chip->names && chip->names[offset])
                ioname = chip->names[offset];
@@ -111,7 +111,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
        dev = device_create_with_groups(&gpio_class, &gdev->dev,
                                        MKDEV(0, 0), data, gpio_groups,
-@@ -646,6 +648,12 @@ err_unlock:
+@@ -647,6 +649,12 @@ err_unlock:
        gpiod_dbg(desc, "%s: status %d\n", __func__, status);
        return status;
  }
@@ -126,7 +126,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  static int match_export(struct device *dev, const void *desc)
 --- a/include/asm-generic/gpio.h
 +++ b/include/asm-generic/gpio.h
-@@ -127,6 +127,12 @@ static inline int gpio_export(unsigned g
+@@ -125,6 +125,12 @@ static inline int gpio_export(unsigned g
        return gpiod_export(gpio_to_desc(gpio), direction_may_change);
  }
  
@@ -141,7 +141,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  {
 --- a/include/linux/gpio/consumer.h
 +++ b/include/linux/gpio/consumer.h
-@@ -668,6 +668,7 @@ static inline void devm_acpi_dev_remove_
+@@ -713,6 +713,7 @@ static inline void devm_acpi_dev_remove_
  
  #if IS_ENABLED(CONFIG_GPIOLIB) && IS_ENABLED(CONFIG_GPIO_SYSFS)
  
@@ -149,7 +149,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  int gpiod_export(struct gpio_desc *desc, bool direction_may_change);
  int gpiod_export_link(struct device *dev, const char *name,
                      struct gpio_desc *desc);
-@@ -675,6 +676,13 @@ void gpiod_unexport(struct gpio_desc *de
+@@ -720,6 +721,13 @@ void gpiod_unexport(struct gpio_desc *de
  
  #else  /* CONFIG_GPIOLIB && CONFIG_GPIO_SYSFS */
  
index fa4b05f724efadc4a428b81a9b57fe850f90e3e8..4a2a3b741d2c1b3d6c78216e7626b76858a247b9 100644 (file)
@@ -3,7 +3,7 @@ from mach files succeed.
 
 --- a/drivers/gpio/gpio-ath79.c
 +++ b/drivers/gpio/gpio-ath79.c
-@@ -310,7 +310,11 @@ static struct platform_driver ath79_gpio
+@@ -306,7 +306,11 @@ static struct platform_driver ath79_gpio
        .probe = ath79_gpio_probe,
  };
  
index 13955c62a2d9bded91f087afff438f99abd3def2..f596ddb7336f642924d5e9efa1963e688d3be4a9 100644 (file)
@@ -96,7 +96,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  
        /* set PCIE Application Control to ready */
        app = __raw_readl(apc->ctrl_base + AR724X_PCI_REG_APP);
-@@ -399,6 +415,14 @@ static int ar724x_pci_probe(struct platf
+@@ -396,6 +412,14 @@ static int ar724x_pci_probe(struct platf
        if (apc->irq < 0)
                return -EINVAL;
  
@@ -111,7 +111,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
        apc->np = pdev->dev.of_node;
        apc->pci_controller.pci_ops = &ar724x_pci_ops;
        apc->pci_controller.io_resource = &apc->io_res;
-@@ -409,7 +433,7 @@ static int ar724x_pci_probe(struct platf
+@@ -406,7 +430,7 @@ static int ar724x_pci_probe(struct platf
         * Do the full PCIE Root Complex Initialization Sequence if the PCIe
         * host controller is in reset.
         */
@@ -120,7 +120,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
                ar724x_pci_hw_init(apc);
  
        apc->link_up = ar724x_pci_check_link(apc);
-@@ -427,6 +451,7 @@ static int ar724x_pci_probe(struct platf
+@@ -424,6 +448,7 @@ static int ar724x_pci_probe(struct platf
  
  static const struct of_device_id ar724x_pci_ids[] = {
        { .compatible = "qcom,ar7240-pci" },
index 2a6b9857fb5cc2e9327beac4231868f577586609..51a71c6ef2fdd405b8ada92560aa90c8054e8225 100644 (file)
@@ -58,7 +58,7 @@ Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
  static int ath79_spi_probe(struct platform_device *pdev)
  {
        struct spi_master *master;
-@@ -163,6 +197,7 @@ static int ath79_spi_probe(struct platfo
+@@ -164,6 +198,7 @@ static int ath79_spi_probe(struct platfo
                ret = PTR_ERR(sp->base);
                goto err_put_master;
        }
index 396b1ee7a2c6477beaffd1e7165fa660676e6e08..b42102a9661c0886ed4d48bc9b42ff997e82b765 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/at803x.c
 +++ b/drivers/net/phy/at803x.c
-@@ -383,6 +383,13 @@ static int at803x_aneg_done(struct phy_d
+@@ -698,6 +698,13 @@ static int at803x_aneg_done(struct phy_d
        if (!(phy_read(phydev, AT803X_PSSR) & AT803X_PSSR_MR_AN_COMPLETE)) {
                phydev_warn(phydev, "803x_aneg_done: SGMII link is not ok\n");
                aneg_done = 0;
index 4c6558db90ccde7ba45709ea1bf22f07a038300b..7590793dc9765427d57b61aeef74b11f444fe907 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/Makefile
 +++ b/drivers/Makefile
-@@ -80,8 +80,8 @@ obj-y                                += scsi/
+@@ -81,8 +81,8 @@ obj-y                                += scsi/
  obj-y                         += nvme/
  obj-$(CONFIG_ATA)             += ata/
  obj-$(CONFIG_TARGET_CORE)     += target/
index 2440fbbb7373f3136eed87ff5278d20b2f522190..c1cb0dae668156e91608b56b65e76d8d749cc25a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/include/asm/checksum.h
 +++ b/arch/mips/include/asm/checksum.h
-@@ -134,26 +134,30 @@ static inline __sum16 ip_fast_csum(const
+@@ -100,26 +100,30 @@ static inline __sum16 ip_fast_csum(const
        const unsigned int *stop = word + ihl;
        unsigned int csum;
        int carry;
@@ -42,7 +42,7 @@
        } while (word != stop);
  
        return csum_fold(csum);
-@@ -214,73 +218,6 @@ static inline __sum16 ip_compute_csum(co
+@@ -180,73 +184,6 @@ static inline __sum16 ip_compute_csum(co
        return csum_fold(csum_partial(buff, len, 0));
  }
  
  struct ip_auth_hdr {
 --- a/include/uapi/linux/ipv6.h
 +++ b/include/uapi/linux/ipv6.h
-@@ -131,7 +131,7 @@ struct ipv6hdr {
+@@ -132,7 +132,7 @@ struct ipv6hdr {
  
        struct  in6_addr        saddr;
        struct  in6_addr        daddr;
  #define UDP_CORK      1       /* Never send partially complete segments */
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -271,8 +271,8 @@ nf_ct_get_tuple(const struct sk_buff *sk
+@@ -273,8 +273,8 @@ nf_ct_get_tuple(const struct sk_buff *sk
  
        switch (l3num) {
        case NFPROTO_IPV4:
                memcpy(tuple->src.u3.ip6, ap, sizeof(tuple->src.u3.ip6));
 --- a/include/uapi/linux/icmp.h
 +++ b/include/uapi/linux/icmp.h
-@@ -82,7 +82,7 @@ struct icmphdr {
+@@ -83,7 +83,7 @@ struct icmphdr {
        } frag;
        __u8    reserved[4];
    } un;
  #include <linux/uaccess.h>
  #include <linux/ipv6.h>
  #include <linux/icmpv6.h>
-@@ -849,10 +850,10 @@ static void tcp_v6_send_response(const s
+@@ -909,10 +910,10 @@ static void tcp_v6_send_response(const s
        topt = (__be32 *)(t1 + 1);
  
        if (tsecr) {
   */
 --- a/net/ipv6/datagram.c
 +++ b/net/ipv6/datagram.c
-@@ -476,7 +476,7 @@ int ipv6_recv_error(struct sock *sk, str
+@@ -492,7 +492,7 @@ int ipv6_recv_error(struct sock *sk, str
                                ipv6_iface_scope_id(&sin->sin6_addr,
                                                    IP6CB(skb)->iif);
                } else {
                                               &sin->sin6_addr);
                        sin->sin6_scope_id = 0;
                }
-@@ -830,12 +830,12 @@ int ip6_datagram_send_ctl(struct net *ne
+@@ -846,12 +846,12 @@ int ip6_datagram_send_ctl(struct net *ne
                        }
  
                        if (fl6->flowlabel&IPV6_FLOWINFO_MASK) {
                case IPV6_2292HOPOPTS:
 --- a/net/ipv6/exthdrs.c
 +++ b/net/ipv6/exthdrs.c
-@@ -752,7 +752,7 @@ static bool ipv6_hop_jumbo(struct sk_buf
+@@ -949,7 +949,7 @@ static bool ipv6_hop_jumbo(struct sk_buf
                goto drop;
        }
  
                icmpv6_param_prob(skb, ICMPV6_HDR_FIELD, optoff+2);
 --- a/include/linux/types.h
 +++ b/include/linux/types.h
-@@ -225,5 +225,11 @@ struct callback_head {
- typedef void (*rcu_callback_t)(struct rcu_head *head);
- typedef void (*call_rcu_func_t)(struct rcu_head *head, rcu_callback_t func);
+@@ -227,5 +227,11 @@ typedef void (*swap_func_t)(void *a, voi
+ typedef int (*cmp_r_func_t)(const void *a, const void *b, const void *priv);
+ typedef int (*cmp_func_t)(const void *a, const void *b);
  
 +struct net_hdr_word {
 +       u32 words[1];
  #endif /* _LINUX_TYPES_H */
 --- a/net/ipv4/af_inet.c
 +++ b/net/ipv4/af_inet.c
-@@ -1441,8 +1441,8 @@ struct sk_buff *inet_gro_receive(struct
+@@ -1467,8 +1467,8 @@ struct sk_buff *inet_gro_receive(struct
        if (unlikely(ip_fast_csum((u8 *)iph, 5)))
                goto out_unlock;
  
        list_for_each_entry(p, head, list) {
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -460,48 +460,53 @@ static void tcp_options_write(__be32 *pt
+@@ -611,48 +611,53 @@ static void tcp_options_write(__be32 *pt
        u16 options = opts->options;    /* mungable copy */
  
        if (unlikely(OPTION_MD5 & options)) {
        }
  
        if (unlikely(opts->num_sack_blocks)) {
-@@ -509,16 +514,17 @@ static void tcp_options_write(__be32 *pt
+@@ -660,16 +665,17 @@ static void tcp_options_write(__be32 *pt
                        tp->duplicate_sack : tp->selective_acks;
                int this_sack;
  
                }
  
                tp->rx_opt.dsack = 0;
-@@ -531,13 +537,14 @@ static void tcp_options_write(__be32 *pt
+@@ -682,13 +688,14 @@ static void tcp_options_write(__be32 *pt
  
                if (foc->exp) {
                        len = TCPOLEN_EXP_FASTOPEN_BASE + foc->len;
  #define IGMP_HOST_MEMBERSHIP_REPORT   0x12    /* Ditto */
 --- a/net/core/flow_dissector.c
 +++ b/net/core/flow_dissector.c
-@@ -212,7 +212,7 @@ __be32 __skb_flow_get_ports(const struct
+@@ -128,7 +128,7 @@ __be32 __skb_flow_get_ports(const struct
                ports = __skb_header_pointer(skb, thoff + poff,
                                             sizeof(_ports), data, hlen, &_ports);
                if (ports)
        return 0;
 --- a/include/uapi/linux/icmpv6.h
 +++ b/include/uapi/linux/icmpv6.h
-@@ -77,7 +77,7 @@ struct icmp6hdr {
+@@ -78,7 +78,7 @@ struct icmp6hdr {
  #define icmp6_addrconf_other  icmp6_dataun.u_nd_ra.other
  #define icmp6_rt_lifetime     icmp6_dataun.u_nd_ra.rt_lifetime
  #define icmp6_router_pref     icmp6_dataun.u_nd_ra.router_pref
  #define ICMPV6_ROUTER_PREF_LOW                0x3
 --- a/include/net/ndisc.h
 +++ b/include/net/ndisc.h
-@@ -92,7 +92,7 @@ struct ra_msg {
+@@ -93,7 +93,7 @@ struct ra_msg {
          struct icmp6hdr               icmph;
        __be32                  reachable_time;
        __be32                  retrans_timer;
  
  struct rd_msg {
        struct icmp6hdr icmph;
-@@ -371,10 +371,10 @@ static inline u32 ndisc_hashfn(const voi
+@@ -372,10 +372,10 @@ static inline u32 ndisc_hashfn(const voi
  {
        const u32 *p32 = pkey;
  
                        goto next_ht;
 --- a/net/ipv6/ip6_offload.c
 +++ b/net/ipv6/ip6_offload.c
-@@ -240,7 +240,7 @@ INDIRECT_CALLABLE_SCOPE struct sk_buff *
+@@ -238,7 +238,7 @@ INDIRECT_CALLABLE_SCOPE struct sk_buff *
                        continue;
  
                iph2 = (struct ipv6hdr *)(p->data + off);
                 * XXX skbs on the gro_list have all been parsed and pulled
 --- a/include/net/addrconf.h
 +++ b/include/net/addrconf.h
-@@ -47,7 +47,7 @@ struct prefix_info {
+@@ -45,7 +45,7 @@ struct prefix_info {
        __be32                  reserved2;
  
        struct in6_addr         prefix;
                return false;
  
        return true;
-@@ -741,13 +745,13 @@ static inline void ipv6_addr_set_v4mappe
+@@ -746,13 +750,13 @@ static inline void ipv6_addr_set_v4mappe
   */
  static inline int __ipv6_addr_diff32(const void *token1, const void *token2, int addrlen)
  {
                if (xb)
                        return i * 32 + 31 - __fls(ntohl(xb));
        }
-@@ -934,17 +938,18 @@ static inline int ip6_multipath_hash_pol
+@@ -938,17 +942,18 @@ static inline int ip6_multipath_hash_pol
  static inline void ip6_flow_hdr(struct ipv6hdr *hdr, unsigned int tclass,
                                __be32 flowlabel)
  {
  u32 secure_ipv6_port_ephemeral(const __be32 *saddr, const __be32 *daddr,
 --- a/include/uapi/linux/in.h
 +++ b/include/uapi/linux/in.h
-@@ -84,7 +84,7 @@ enum {
+@@ -88,7 +88,7 @@ enum {
  /* Internet address. */
  struct in_addr {
        __be32  s_addr;
                                       | TCPOLEN_TIMESTAMP))
 --- a/net/xfrm/xfrm_input.c
 +++ b/net/xfrm/xfrm_input.c
-@@ -162,8 +162,8 @@ int xfrm_parse_spi(struct sk_buff *skb,
+@@ -165,8 +165,8 @@ int xfrm_parse_spi(struct sk_buff *skb,
        if (!pskb_may_pull(skb, hlen))
                return -EINVAL;
  
  EXPORT_SYMBOL(xfrm_parse_spi);
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3976,14 +3976,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -4074,14 +4074,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
                *sum = csum_fold(csum_partial(diff, sizeof(diff),
 --- a/include/linux/etherdevice.h
 +++ b/include/linux/etherdevice.h
-@@ -489,7 +489,7 @@ static inline bool is_etherdev_addr(cons
+@@ -500,7 +500,7 @@ static inline bool is_etherdev_addr(cons
   * @b: Pointer to Ethernet header
   *
   * Compare two Ethernet headers, returns 0 if equal.
   * aligned OR the platform can handle unaligned access.  This is the
   * case for all packets coming into netif_receive_skb or similar
   * entry points.
-@@ -512,11 +512,12 @@ static inline unsigned long compare_ethe
+@@ -523,11 +523,12 @@ static inline unsigned long compare_ethe
        fold |= *(unsigned long *)(a + 6) ^ *(unsigned long *)(b + 6);
        return fold;
  #else
index dac2064cbbb75aa9f5739f6c959da601a2e567f5..ef4a349ea76a0b53566ea7249603ce62d895d826 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Sungbo Eo <mans0n@gorani.run>
 
 --- a/drivers/tty/serial/serial_core.c
 +++ b/drivers/tty/serial/serial_core.c
-@@ -220,6 +220,8 @@ static int uart_port_startup(struct tty_
+@@ -222,6 +222,8 @@ static int uart_port_startup(struct tty_
        if (retval == 0) {
                if (uart_console(uport) && uport->cons->cflag) {
                        tty->termios.c_cflag = uport->cons->cflag;
@@ -30,7 +30,7 @@ Signed-off-by: Sungbo Eo <mans0n@gorani.run>
                        uport->cons->cflag = 0;
                }
                /*
-@@ -2108,8 +2110,10 @@ uart_set_options(struct uart_port *port,
+@@ -2121,8 +2123,10 @@ uart_set_options(struct uart_port *port,
         * Allow the setting of the UART parameters with a NULL console
         * too:
         */
@@ -44,7 +44,7 @@ Signed-off-by: Sungbo Eo <mans0n@gorani.run>
  }
 --- a/include/linux/console.h
 +++ b/include/linux/console.h
-@@ -153,6 +153,7 @@ struct console {
+@@ -150,6 +150,7 @@ struct console {
        short   flags;
        short   index;
        int     cflag;
index 35d0333ad5eb014541bc704010c930f4c642382d..348a5afa3d1e29699c54923338ec92be55dc7c60 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static int absolute_percpu;
  static int base_relative;
  
-@@ -480,6 +481,9 @@ static void write_src(void)
+@@ -486,6 +487,9 @@ static void write_src(void)
  
        free(markers);
  
@@ -75,7 +75,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        output_label("kallsyms_token_table");
        off = 0;
        for (i = 0; i < 256; i++) {
-@@ -531,6 +535,9 @@ static unsigned char *find_token(unsigne
+@@ -537,6 +541,9 @@ static unsigned char *find_token(unsigne
  {
        int i;
  
@@ -85,7 +85,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        for (i = 0; i < len - 1; i++) {
                if (str[i] == token[0] && str[i+1] == token[1])
                        return &str[i];
-@@ -603,6 +610,9 @@ static void optimize_result(void)
+@@ -609,6 +616,9 @@ static void optimize_result(void)
  {
        int i, best;
  
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        /* using the '\0' symbol last allows compress_symbols to use standard
         * fast string functions */
        for (i = 255; i >= 0; i--) {
-@@ -767,6 +777,8 @@ int main(int argc, char **argv)
+@@ -773,6 +783,8 @@ int main(int argc, char **argv)
                                absolute_percpu = 1;
                        else if (strcmp(argv[i], "--base-relative") == 0)
                                base_relative = 1;
index cd1b30b4af164ad816a234eda73d18125853bc69..6d0c84c494d5bf09e4653d192d0ae0ed5777b9b2 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        __u16                   tc_index;       /* traffic control index */
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -5962,6 +5962,9 @@ static enum gro_result dev_gro_receive(s
+@@ -5965,6 +5965,9 @@ static enum gro_result dev_gro_receive(s
        int same_flow;
        int grow;
  
@@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (netif_elide_gro(skb->dev))
                goto normal;
  
-@@ -7790,6 +7793,48 @@ static void __netdev_adjacent_dev_unlink
+@@ -7793,6 +7796,48 @@ static void __netdev_adjacent_dev_unlink
                                           &upper_dev->adj_list.lower);
  }
  
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *upper_priv, void *upper_info,
-@@ -7841,6 +7886,7 @@ static int __netdev_upper_dev_link(struc
+@@ -7844,6 +7889,7 @@ static int __netdev_upper_dev_link(struc
        if (ret)
                return ret;
  
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        ret = call_netdevice_notifiers_info(NETDEV_CHANGEUPPER,
                                            &changeupper_info.info);
        ret = notifier_to_errno(ret);
-@@ -7937,6 +7983,7 @@ static void __netdev_upper_dev_unlink(st
+@@ -7940,6 +7986,7 @@ static void __netdev_upper_dev_unlink(st
  
        __netdev_adjacent_dev_unlink_neighbour(dev, upper_dev);
  
@@ -107,7 +107,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER,
                                      &changeupper_info.info);
  
-@@ -8723,6 +8770,7 @@ int dev_set_mac_address(struct net_devic
+@@ -8726,6 +8773,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
index 2979934926599add4f2dd7ca7b7041ef8da80934..b2c2d00ec004565c540a27c9fb128975f105eda7 100644 (file)
@@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  static int netif_rx_internal(struct sk_buff *skb);
  static int call_netdevice_notifiers_info(unsigned long val,
-@@ -6404,6 +6405,11 @@ void __napi_schedule(struct napi_struct
+@@ -6407,6 +6408,11 @@ void __napi_schedule(struct napi_struct
  {
        unsigned long flags;
  
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        local_irq_save(flags);
        ____napi_schedule(this_cpu_ptr(&softnet_data), n);
        local_irq_restore(flags);
-@@ -6451,6 +6457,11 @@ EXPORT_SYMBOL(napi_schedule_prep);
+@@ -6454,6 +6460,11 @@ EXPORT_SYMBOL(napi_schedule_prep);
   */
  void __napi_schedule_irqoff(struct napi_struct *n)
  {
@@ -111,7 +111,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        ____napi_schedule(this_cpu_ptr(&softnet_data), n);
  }
  EXPORT_SYMBOL(__napi_schedule_irqoff);
-@@ -6712,6 +6723,86 @@ static void init_gro_hash(struct napi_st
+@@ -6715,6 +6726,86 @@ static void init_gro_hash(struct napi_st
        napi->gro_bitmask = 0;
  }
  
@@ -198,7 +198,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  void netif_napi_add(struct net_device *dev, struct napi_struct *napi,
                    int (*poll)(struct napi_struct *, int), int weight)
  {
-@@ -6735,6 +6826,7 @@ void netif_napi_add(struct net_device *d
+@@ -6738,6 +6829,7 @@ void netif_napi_add(struct net_device *d
  #ifdef CONFIG_NETPOLL
        napi->poll_owner = -1;
  #endif
@@ -206,7 +206,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        set_bit(NAPI_STATE_SCHED, &napi->state);
        set_bit(NAPI_STATE_NPSVC, &napi->state);
        list_add_rcu(&napi->dev_list, &dev->napi_list);
-@@ -6777,6 +6869,7 @@ void __netif_napi_del(struct napi_struct
+@@ -6780,6 +6872,7 @@ void __netif_napi_del(struct napi_struct
        if (!test_and_clear_bit(NAPI_STATE_LISTED, &napi->state))
                return;
  
@@ -214,7 +214,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        napi_hash_del(napi);
        list_del_rcu(&napi->dev_list);
        napi_free_frags(napi);
-@@ -6788,53 +6881,19 @@ EXPORT_SYMBOL(__netif_napi_del);
+@@ -6791,53 +6884,19 @@ EXPORT_SYMBOL(__netif_napi_del);
  
  static int napi_poll(struct napi_struct *n, struct list_head *repoll)
  {
@@ -272,7 +272,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        /* Some drivers may have called napi_schedule
         * prior to exhausting their budget.
         */
-@@ -11288,6 +11347,10 @@ static int __init net_dev_init(void)
+@@ -11291,6 +11350,10 @@ static int __init net_dev_init(void)
                sd->backlog.weight = weight_p;
        }
  
index 247c6d83644955bab05febb58200a0483c233ca3..580f0b1bfaaee3d558edd191cff0cecfd1303602 100644 (file)
@@ -16,11 +16,11 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
 
 --- a/drivers/char/hw_random/bcm2835-rng.c
 +++ b/drivers/char/hw_random/bcm2835-rng.c
-@@ -167,6 +167,7 @@ static int bcm2835_rng_probe(struct plat
+@@ -163,6 +163,7 @@ static int bcm2835_rng_probe(struct plat
        priv->rng.init = bcm2835_rng_init;
        priv->rng.read = bcm2835_rng_read;
        priv->rng.cleanup = bcm2835_rng_cleanup;
 +      priv->rng.quality = 1000;
  
        if (dev_of_node(dev)) {
-               rng_id = of_match_node(bcm2835_rng_of_match, np);
+               rng_id = of_match_node(bcm2835_rng_of_match, dev->of_node);
index 924ce9307e27111e6a68f69013a138c31ed83cac..652e8ee6c3a028a03ff84f03fc7b4296766c1ad0 100644 (file)
@@ -1,8 +1,8 @@
 --- a/arch/powerpc/Kconfig
 +++ b/arch/powerpc/Kconfig
-@@ -885,6 +885,14 @@ config CMDLINE_FORCE
-         This is useful if you cannot or don't want to change the
-         command-line options your boot loader passes to the kernel.
+@@ -932,6 +932,14 @@ config CMDLINE_FORCE
+ endchoice
  
 +config CMDLINE_OVERRIDE
 +    bool "Use alternative cmdline from device tree"
@@ -17,7 +17,7 @@
        help
 --- a/drivers/of/fdt.c
 +++ b/drivers/of/fdt.c
-@@ -1060,6 +1060,17 @@ int __init early_init_dt_scan_chosen(uns
+@@ -1056,6 +1056,17 @@ int __init early_init_dt_scan_chosen(uns
        if (p != NULL && l > 0)
                strlcpy(data, p, min(l, COMMAND_LINE_SIZE));
  
index b84a56659cca1e2e589ebbb2aab1bbc397e2c63b..2900a1bea290d4702954f98ebadddae882d7bd35 100644 (file)
@@ -2,7 +2,7 @@
 +++ b/arch/powerpc/platforms/85xx/Kconfig
 @@ -173,6 +173,16 @@ config XES_MPC85xx
          Manufacturer: Extreme Engineering Solutions, Inc.
-         URL: <http://www.xes-inc.com/>
+         URL: <https://www.xes-inc.com/>
  
 +config RED_15W_REV1
 +      bool "Sophos RED 15w Rev.1"
index 2ebdc06f61adea8ecd5e81d79b823ba98b11a961..a3f41fb5cbbf43628366ec657842f221781177c8 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
 
 --- a/arch/arm/boot/dts/armada-385-turris-omnia.dts
 +++ b/arch/arm/boot/dts/armada-385-turris-omnia.dts
-@@ -32,7 +32,8 @@
+@@ -31,7 +31,8 @@
                ranges = <MBUS_ID(0xf0, 0x01) 0 0xf1000000 0x100000
                          MBUS_ID(0x01, 0x1d) 0 0xfff00000 0x100000
                          MBUS_ID(0x09, 0x19) 0 0xf1100000 0x10000
index c7509950e0f9a37048812dd409555738335b5fae..1fbbe8b5061de226e169a9b6ad6f6fc95f30a25c 100644 (file)
@@ -54,9 +54,9 @@ Please let me know how should I handle this.
 
 --- a/arch/arm/boot/dts/armada-385-turris-omnia.dts
 +++ b/arch/arm/boot/dts/armada-385-turris-omnia.dts
-@@ -390,6 +390,7 @@
-       phy1: ethernet-phy@1 {
-               compatible = "ethernet-phy-ieee802.3-c22";
+@@ -254,6 +254,7 @@
+               status = "okay";
+               compatible = "ethernet-phy-id0141.0DD1", "ethernet-phy-ieee802.3-c22";
                reg = <1>;
 +              marvell,reg-init = <3 18 0 0x4985>;
  
index 53b6413cf34f68acdcf758d8dc33ecb71ae528cd..86cfb4e224c216c4ea766efc0219d0564880aaeb 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  #include <linux/crc32.h>
  #include <linux/if_vlan.h>
  #include <linux/uaccess.h>
-@@ -4363,6 +4364,22 @@ static void rtl_tally_reset(struct r8152
+@@ -5328,6 +5329,22 @@ static void rtl_tally_reset(struct r8152
        ocp_write_word(tp, MCU_TYPE_PLA, PLA_RSTTALLY, ocp_data);
  }
  
@@ -45,7 +45,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  static void r8152b_init(struct r8152 *tp)
  {
        u32 ocp_data;
-@@ -4404,6 +4421,8 @@ static void r8152b_init(struct r8152 *tp
+@@ -5369,6 +5386,8 @@ static void r8152b_init(struct r8152 *tp
        ocp_data = ocp_read_word(tp, MCU_TYPE_USB, USB_USB_CTRL);
        ocp_data &= ~(RX_AGG_DISABLE | RX_ZERO_EN);
        ocp_write_word(tp, MCU_TYPE_USB, USB_USB_CTRL, ocp_data);
@@ -54,7 +54,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  }
  
  static void r8153_init(struct r8152 *tp)
-@@ -4533,6 +4552,8 @@ static void r8153_init(struct r8152 *tp)
+@@ -5509,6 +5528,8 @@ static void r8153_init(struct r8152 *tp)
                tp->coalesce = COALESCE_SLOW;
                break;
        }
@@ -63,7 +63,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  }
  
  static void r8153b_init(struct r8152 *tp)
-@@ -4609,6 +4630,8 @@ static void r8153b_init(struct r8152 *tp
+@@ -5595,6 +5616,8 @@ static void r8153b_init(struct r8152 *tp
        rtl_tally_reset(tp);
  
        tp->coalesce = 15000;   /* 15 us */
index 20d18597dba7539e3c3f70d21a57b4414db4db16..48e8d472c85a76a834166054402c58ef747e2276 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
        leds {
                compatible = "gpio-leds";
                pinctrl-0 = <&lan_led_pin>,  <&sys_led_pin>, <&wan_led_pin>;
-@@ -267,6 +279,12 @@
+@@ -271,6 +283,12 @@
                        };
                };
        };
@@ -45,7 +45,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  };
  
  &io_domains {
-@@ -373,3 +391,12 @@
+@@ -377,3 +395,12 @@
  &usb_host0_ohci {
        status = "okay";
  };
index 473c265016a1b51f2f4cd5ccd9760bfaf0b6226c..dfc71a2701e4cbd33e15b84d26912b5d024be373 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 
 --- a/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts
 +++ b/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts
-@@ -399,4 +399,11 @@
+@@ -403,4 +403,11 @@
  &usbdrd_dwc3 {
        dr_mode = "host";
        status = "okay";