ramips: improve BDCOM WAP2100-SK support
authorMathias Kresin <dev@kresin.me>
Mon, 26 Nov 2018 12:26:06 +0000 (13:26 +0100)
committerMathias Kresin <dev@kresin.me>
Mon, 26 Nov 2018 14:54:22 +0000 (15:54 +0100)
Use the generic board detection instead of the target specific one as
all recent additions are doing.

Setup the USB led via devicetree (a58535771f11) and include the required
driver by default. Merge the led userspace setting with an existing
identical case.

Use the wps led for boot status indication.

Move the partitions into a partition table node (6031ab345df8) and drop
needless labels. Drop misplaced cells properties (53624c1702e6).

Cleanup the pinmux and only switch pins to gpio functions which a
referenced as gpio in the dts.

Match the maximum image size with the size of the firmware partition.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/BDCOM-WAP2100-SK.dts
target/linux/ramips/image/mt7620.mk

index 6d4bca8029ed91071b0df50a415baff9abc371ba..fb288de09bb96c9d640b877f82a3d0e795841649 100755 (executable)
@@ -56,6 +56,10 @@ asl26555-16M)
        ucidef_set_led_netdev "eth" "ETH" "asl26555:green:eth" "eth0"
        set_wifi_led "asl26555:green:wlan"
        ;;
+bdcom,wap2100-sk|\
+hiwifi,hc5861b)
+       set_wifi_led "$boardname:green:wlan2g"
+       ;;
 broadway)
        set_wifi_led "$boardname:red:wps_active"
        ;;
@@ -172,9 +176,6 @@ hg255d)
        set_wifi_led "$boardname:green:wlan"
        ucidef_set_led_netdev "internet" "internet" "$boardname:green:internet" "eth0.2"
        ;;
-hiwifi,hc5861b)
-       set_wifi_led "$boardname:green:wlan2g"
-       ;;
 hpm)
        ucidef_set_led_netdev "eth" "ETH" "$boardname:green:eth" "eth0"
        set_wifi_led "$boardname:green:wifi"
@@ -369,10 +370,6 @@ vocore-16M)
 w502u)
        set_wifi_led "rt2800pci-phy0::radio"
        ;;
-wap2100-sk)
-       set_usb_led "$boardname:green:usb"
-       set_wifi_led "$boardname:green:wlan2g"
-       ;;
 we1026-5g-16m)
        ucidef_set_led_netdev "lan" "LAN" "we1026-5g:green:lan" "eth0"
        set_wifi_led "we1026-5g:green:wifi"
index 12d7c86e2b5b4428736524bfb0f179e4d6654ffb..7bb1d324840b5f4504f0bc3b0fa927eb79a4aaf5 100755 (executable)
@@ -198,6 +198,7 @@ ramips_setup_interfaces()
        atp-52b|\
        awm002-evb-4M|\
        awm002-evb-8M|\
+       bdcom,wap2100-sk|\
        c20i|\
        dir-645|\
        gl-mt300a|\
@@ -224,7 +225,6 @@ ramips_setup_interfaces()
        ubnt-erx|\
        ubnt-erx-sfp|\
        ur-326n4g|\
-       wap2100-sk|\
        wrtnode|\
        wrtnode2p | \
        wrtnode2r | \
index ba6a13b65becf4aa55fbd752b0a4ba321ed99534..5741cbd2ee13f309dc5cc93f1d48f5a97e0da970 100755 (executable)
@@ -553,9 +553,6 @@ ramips_board_detect() {
        *"W502U")
                name="w502u"
                ;;
-       *"WAP2100-SK")
-               name="wap2100-sk"
-               ;;
        *"WCR-1166DS")
                name="wcr-1166ds"
                ;;
index cb6e5c1b5a0beaf1a148577bdca16fd732ff7c85..e4ddc0eec4a0183b02e8c4663fb14ca17c7b8b5a 100755 (executable)
@@ -31,6 +31,7 @@ platform_check_image() {
        awm002-evb-4M|\
        awm002-evb-8M|\
        bc2|\
+       bdcom,wap2100-sk|\
        bocco|\
        broadway|\
        c108|\
@@ -186,7 +187,6 @@ platform_check_image() {
        widora,neo-32m|\
        mqmaker,witi-256m|\
        mqmaker,witi-512m|\
-       wap2100-sk|\
        we1026-5g-16m|\
        wizfi630a|\
        wl-330n|\
index 7f9cbe74bd360024b1d89a878e16b960db395adb..62a87c844465e0d09476ba3f962a6b9fa1925b9a 100644 (file)
@@ -6,9 +6,14 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       compatible = "bdcom,bdcom-wap2100-sk", "ralink,mt7620a-soc";
+       compatible = "bdcom,wap2100-sk", "ralink,mt7620a-soc";
        model = "BDCOM WAP2100-SK";
 
+       aliases {
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+       };
+
        chosen {
                bootargs = "console=ttyS0,115200";
        };
                usb {
                        label = "wap2100-sk:green:usb";
                        gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+                       trigger-sources = <&ohci_port1>, <&ehci_port1>;
+                       linux,default-trigger = "usbport";
                };
 
-               wps {
+               led_power: wps {
                        label = "wap2100-sk:green:wps";
                        gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
                };
@@ -34,8 +41,6 @@
 
        gpio-keys-polled {
                compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
                poll-interval = <20>;
 
                wps {
 &spi0 {
        status = "okay";
 
-       en25q128@0 {
-               #address-cells = <1>;
-               #size-cells = <1>;
+       flash@0 {
                compatible = "jedec,spi-nor";
                reg = <0>;
                spi-max-frequency = <10000000>;
 
-               partition@0 {
-                       label = "u-boot";
-                       reg = <0x0 0x30000>;
-                       read-only;
-               };
-
-               partition@30000 {
-                       label = "u-boot-env";
-                       reg = <0x30000 0x10000>;
-                       read-only;
-               };
-
-               factory: partition@40000 {
-                       label = "factory";
-                       reg = <0x40000 0x10000>;
-                       read-only;
-               };
-
-               firmware: partition@50000 {
-                       label = "firmware";
-                       reg = <0x50000 0xf70000>;
+               partitions {
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               label = "firmware";
+                               reg = <0x50000 0xf70000>;
+                       };
                };
        };
 };
 &pinctrl {
        state_default: pinctrl0 {
                default {
-                       ralink,group = "wdt", "mdio", "spi refclk", "uartf", "wled";
+                       ralink,group = "spi refclk", "uartf", "wled";
                        ralink,function = "gpio";
                };
        };
index 5e3d37b5c84a0373116eef8863a9aab812616bc2..bf04a75ea16554e059fd094bb0f557fe36a3c0ef 100644 (file)
@@ -80,14 +80,13 @@ define Device/ArcherMR200
 endef
 TARGET_DEVICES += ArcherMR200
 
-define Device/BDCOM-WAP2100-SK
+define Device/bdcom_wap2100-sk
   DTS := BDCOM-WAP2100-SK
-  IMAGE_SIZE := $(ralink_default_fw_size_16M)
-  SUPPORTED_DEVICES += wap2100-sk
+  IMAGE_SIZE := 15808k
   DEVICE_TITLE := BDCOM WAP2100-SK (ZTE ZXECS EBG3130)
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-sdhci-mt7620
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-sdhci-mt7620 kmod-usb-ledtrig-usbport
 endef
-TARGET_DEVICES += BDCOM-WAP2100-SK
+TARGET_DEVICES += bdcom_wap2100-sk
 
 define Device/bocco
   DTS := BOCCO