treewide: add sysupgrade comment for early DSA-adopters
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 8 Aug 2020 18:53:38 +0000 (20:53 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 8 Aug 2020 18:56:12 +0000 (20:56 +0200)
Add a specific comment for early DSA-adopters that they can keep
their config when prompted due to compat-version increase.

This is a temporary solution, the patch should be simply reverted
before any release.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/kirkwood/image/Makefile
target/linux/mvebu/image/cortexa9.mk
target/linux/ramips/image/mt7621.mk

index 46aef31bee633f227437c26db5387534b9564004..c6d1c335ca4826e8eba92e4a2c62ea156ae6b49d 100644 (file)
@@ -12,7 +12,8 @@ KERNEL_LOADADDR:=0x8000
 
 define Device/dsa-migration
   DEVICE_COMPAT_VERSION := 1.1
-  DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
+  DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA \
+       (early adopters with DSA already set up may just force-flash keeping existing config)
 endef
 
 define Device/Default
index 245e8a2d698147de01d5e091c03f6b35be1f642f..08ad4f8c8a3fdf09689034168b5fa8f69405c5a4 100644 (file)
@@ -8,7 +8,8 @@
 
 define Device/dsa-migration
   DEVICE_COMPAT_VERSION := 1.1
-  DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
+  DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA \
+       (early adopters with DSA already set up may just force-flash keeping existing config)
 endef
 
 define Device/buffalo_ls421de
index 34f0ee7e3c8e7b4e307fb4ac17a780ccca280c65..c922303c54dbf3de3ad9fbdef17dc3c0f7e35850 100644 (file)
@@ -107,7 +107,8 @@ endef
 
 define Device/dsa-migration
   DEVICE_COMPAT_VERSION := 1.1
-  DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
+  DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA \
+       (early adopters with DSA already set up may just force-flash keeping existing config)
 endef
 
 define Device/adslr_g7