add support for HomeStation ADB P.DG A4001N.
authorJonas Gorski <jogo@openwrt.org>
Tue, 23 Oct 2012 10:57:39 +0000 (10:57 +0000)
committerJonas Gorski <jogo@openwrt.org>
Tue, 23 Oct 2012 10:57:39 +0000 (10:57 +0000)
Router: HomeStation ADB P.DG A4001N.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
[jogo: fix subject, indentation in patch]
Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
SVN-Revision: 33893

target/linux/brcm63xx/base-files/etc/uci-defaults/brcm63xx_fixcrc.sh
target/linux/brcm63xx/base-files/etc/uci-defaults/network
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.3/530-board_963281T_TEF.patch [new file with mode: 0644]
target/linux/brcm63xx/patches-3.3/550-alice_gate2_leds.patch
target/linux/brcm63xx/patches-3.3/551-96348gw_a_leds.patch
target/linux/brcm63xx/patches-3.3/552-board_96348gw-10_reset_button.patch
target/linux/brcm63xx/patches-3.3/801-ssb_export_fallback_sprom.patch

index f5b6d440e64d8a7a514016ef5799255792a2bc9a..13b48b0cc4b3d26481a49c49c88c9740c51a348e 100755 (executable)
@@ -15,6 +15,7 @@ brcm63xx_detect
 case "$board_name" in
        96328avng |\
        963281TAN |\
+       963281T_TEF |\
        "CPVA502+" |\
        AW4339U |\
        CPVA642 |\
index 24c8f017046eb9806ea4809e5160389932b1015b..1eb57de8e1fa5d5021efef7e84ff598dd55c83d1 100755 (executable)
@@ -16,6 +16,7 @@ case "$board_name" in
 
 96328avng |\
 963281TAN |\
+963281T_TEF |\
 96348A-122 |\
 96358-502V |\
 CT6373-1 |\
index 11774770df4e3d152d80b312eabacea201034134..29a541f4b61406b8bda230266d9f743492ee147f 100755 (executable)
@@ -26,6 +26,11 @@ brcm63xx_detect() {
                status_led="963281TAN::power"
                ifname=eth0
                ;;
+       963281T_TEF)
+               brcm63xx_has_reset_button="true"
+               status_led="963281T_TEF:green:power"
+               ifname=eth0
+               ;;
        96348GW)
                status_led="power"
                brcm63xx_has_reset_button="true"
index 91f7809f09595afee61ec046a0ff0e6be6c99c08..480116f6d8effb1867cab9271470e1dedaba22e6 100644 (file)
@@ -151,6 +151,7 @@ define Image/Build
        $(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-4M-flash-generic,,--pad 2)
        $(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-8M-flash-generic,,--pad 4)
        $(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-16M-flash-generic,,--pad 8)
+       $(call Image/Build/CFE,$(1),963281T_TEF,6328,963281T_TEF-generic,,--pad 8)
        $(call Image/Build/CFE,$(1),96345GW2,6345,96345GW2-generic)
        $(call Image/Build/CFE,$(1),96345GW2,6345,96348GW2-bc221,,--layoutver 5)
        $(call Image/Build/CFE,$(1),96345GW2,6345,92345GW2-rev,OpenWRT-$(REVISION))
diff --git a/target/linux/brcm63xx/patches-3.3/530-board_963281T_TEF.patch b/target/linux/brcm63xx/patches-3.3/530-board_963281T_TEF.patch
new file mode 100644 (file)
index 0000000..49e3c7c
--- /dev/null
@@ -0,0 +1,136 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -206,6 +206,125 @@ static struct board_info __initdata boar
+       },
+ };
++static struct board_info __initdata board_963281T_TEF = {
++      .name                                   = "963281T_TEF",
++      .expected_cpu_id                        = 0x6328,
++
++      .has_uart0                              = 1,
++      .has_pci                                = 1,
++      .has_ohci0                              = 1,
++      .has_ehci0                              = 1,
++      .has_enetsw                             = 1,
++
++      .enetsw = {
++              .used_ports = {
++                      [0] = {
++                              .used           = 1,
++                              .phy_id         = 1,
++                              .name           = "Port 1",
++                      },
++                      [1] = {
++                              .used           = 1,
++                              .phy_id         = 2,
++                              .name           = "Port 2",
++                      },
++                      [2] = {
++                              .used           = 1,
++                              .phy_id         = 3,
++                              .name           = "Port 3",
++                      },
++                      [3] = {
++                              .used           = 1,
++                              .phy_id         = 4,
++                              .name           = "Port 4",
++                      },
++              },
++      },
++
++      .leds = {
++              {
++                      .name                   = "963281T_TEF:green:power",
++                      .gpio                   = 4,
++                      .active_low             = 1,
++                      .default_trigger        = "default-on",
++              },
++              {
++                      .name                   = "963281T_TEF:red:power",
++                      .gpio                   = 8,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "963281T_TEF:green:inet",
++                      .gpio                   = 11,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "963281T_TEF:red:inet",
++                      .gpio                   = 2,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "963281T_TEF:green:ppp",
++                      .gpio                   = 3,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "963281T_TEF:red:ppp",
++                      .gpio                   = 5,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "963281T_TEF:green:3g",
++                      .gpio                   = 6,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "963281T_TEF:red:3g",
++                      .gpio                   = 7,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "963281T_TEF:green:wlan",
++                      .gpio                   = 9,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "963281T_TEF:red:wlan",
++                      .gpio                   = 10,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "963281T_TEF:green:eth",
++                      .gpio                   = 31,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "963281T_TEF:red:eth",
++                      .gpio                   = 20,
++                      .active_low             = 1,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc                   = "reset",
++                      .gpio                   = 23,
++                      .active_low             = 1,
++                      .type                   = EV_KEY,
++                      .code                   = KEY_RESTART,
++                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++              },
++              {
++                      .desc                   = "wlan",
++                      .gpio                   = 24,
++                      .active_low             = 1,
++                      .type                   = EV_KEY,
++                      .code                   = KEY_WLAN,
++                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++              },
++      },
++};
++
+ static struct board_info __initdata board_dsl_274xb_f1 = {
+       .name                           = "AW4339U",
+       .expected_cpu_id                = 0x6328,
+@@ -2873,6 +2992,7 @@ static const struct board_info __initdat
+ #ifdef CONFIG_BCM63XX_CPU_6328
+       &board_96328avng,
+       &board_963281TAN,
++      &board_963281T_TEF,
+       &board_dsl_274xb_f1,
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6338
index 002b73b065da511920824471cbc0dadf836393fd..edda87503168a36ba4a5a22829e6070f66320e09 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1661,6 +1661,99 @@ static struct board_info __initdata boar
+@@ -1780,6 +1780,99 @@ static struct board_info __initdata boar
  
        .has_ohci0 = 1,
        .has_ehci0 = 1,
index 333e4952b8f8c0481edfc950fb6e1a85a6483c26..adb362c4504e2b1cdc4bcaa38edd9d47e2b8bcb2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1118,6 +1118,19 @@ static struct board_info __initdata boar
+@@ -1237,6 +1237,19 @@ static struct board_info __initdata boar
        },
  
        .has_ohci0 = 1,
index 3c0fe8b9dc1adde87dd5312b4a39cb222d04ffbd..242e15e100d4b4abe346e80675d61dd6e2ee34cb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -586,6 +586,17 @@ static struct board_info __initdata boar
+@@ -705,6 +705,17 @@ static struct board_info __initdata boar
                        .active_low     = 1,
                },
        },
index e6a565068376b358913247f38b7f11b9a9cf5032..f9c9b54a7628b32e39bb765a395f90e3c8e14c9a 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
  #include <linux/spi/74x164.h>
-@@ -3057,7 +3058,7 @@ static const struct board_info __initdat
+@@ -3177,7 +3178,7 @@ static const struct board_info __initdat
   * bcm4318 WLAN work
   */
  #ifdef CONFIG_SSB_PCIHOST
@@ -17,7 +17,7 @@
        .revision               = 0x02,
        .board_rev              = 0x17,
        .country_code           = 0x0,
-@@ -3077,6 +3078,7 @@ static struct ssb_sprom bcm63xx_sprom =
+@@ -3197,6 +3198,7 @@ static struct ssb_sprom bcm63xx_sprom =
        .boardflags_lo          = 0x2848,
        .boardflags_hi          = 0x0000,
  };