treewide: mark devices as BROKEN instead of commenting out
authorPetr Štetiar <ynezz@true.cz>
Tue, 28 Jul 2020 18:47:35 +0000 (20:47 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 30 Jul 2020 19:49:22 +0000 (21:49 +0200)
This adds the newly introduced BROKEN flag to a bunch of devices
that previously just had TARGET_DEVICES commented out. By this, we
can select them in make menuconfig when BROKEN developer config option
is selected, instead of having to edit the code.

In contrast to DEFAULT := n, this is meant to cover devices that
don't boot or don't compile at all.

ath25: np25g, wpe53g
  both disabled during kernel bump 3.18->4.4 without reason given
  f89a20a89aeb ("ath25: update kernel from 3.18 to 4.4")

bcm53xx: linksys-ea6300-v1, linksys-ea9200, linksys-ea9500
  broken due to insufficient/broken TRX support
  55ff15cfd509 ("bcm53xx: disable building Linksys EA6300 V1 image")
  cd0f9900a4cd ("bcm53xx: parepare for building more Linksys images")

bcm63xx: tplink-archer-c5-v2, tplink-archer-c9-v1
  disabled when kernel 5.4 support was added, probably broken
  50c6938b95a0 ("bcm53xx: add v5.4 support")

Signed-off-by: Petr Štetiar <ynezz@true.cz>
[limit to subset of devices, use BROKEN, adjust commit message/title]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath25/image/Makefile
target/linux/bcm53xx/image/Makefile

index e1ebb159cda6026f350274a0fb250097b3e4137f..8066ba61a877643670bcce365e486c0d39fbf017 100644 (file)
@@ -99,15 +99,17 @@ define Device/np25g
   DEVICE_MODEL := NP25G
   KERNEL := kernel-bin | gzip-kernel
   IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkmylofw np25g
+  BROKEN := y
 endef
-#TARGET_DEVICES += np25g
+TARGET_DEVICES += np25g
 
 define Device/wpe53g
   DEVICE_VENDOR := Compex
   DEVICE_MODEL := WPE53G
   KERNEL := kernel-bin | gzip-kernel
   IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkmylofw wpe53g
+  BROKEN := y
 endef
-#TARGET_DEVICES += wpe53g
+TARGET_DEVICES += wpe53g
 
 $(eval $(call BuildImage))
index 5d4ae08513072d29ff62bd25ac72b36907014330..a117e02a45bb1508d3812e62e46263b9d6e7e047 100644 (file)
@@ -250,8 +250,9 @@ define Device/linksys-ea6300-v1
   DEVICE_MODEL := EA6300
   DEVICE_VARIANT := v1
   DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
+  BROKEN := y
 endef
-TARGET_DEVICES += linksys-ea6300-v1
+TARGET_DEVICES += linksys-ea6300-v1
 
 define Device/linksys-ea6500-v2
   DEVICE_VENDOR := Linksys
@@ -266,16 +267,18 @@ define Device/linksys-ea9200
   DEVICE_MODEL := EA9200
   DEVICE_VARIANT := v1
   DEVICE_PACKAGES := $(BRCMFMAC_43602A1) $(USB3_PACKAGES)
+  BROKEN := y
 endef
-TARGET_DEVICES += linksys-ea9200
+TARGET_DEVICES += linksys-ea9200
 
 define Device/linksys-ea9500
   DEVICE_VENDOR := Linksys
   DEVICE_MODEL := EA9500
   DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
   DEVICE_DTS := bcm47094-linksys-panamera
+  BROKEN := y
 endef
-TARGET_DEVICES += linksys-ea9500
+TARGET_DEVICES += linksys-ea9500
 
 define Device/luxul
   DEVICE_VENDOR := Luxul
@@ -410,8 +413,9 @@ define Device/tplink-archer-c5-v2
   IMAGES := bin
   IMAGE/bin := append-rootfs | bcm53xx-tplink-safeloader
   TPLINK_BOARD := ARCHER-C5-V2
+  BROKEN := y
 endef
-#TARGET_DEVICES += tplink-archer-c5-v2
+TARGET_DEVICES += tplink-archer-c5-v2
 
 define Device/tplink-archer-c9-v1
   DEVICE_VENDOR := TP-LINK
@@ -421,7 +425,8 @@ define Device/tplink-archer-c9-v1
   IMAGES := bin
   IMAGE/bin := append-rootfs | bcm53xx-tplink-safeloader
   TPLINK_BOARD := ARCHERC9
+  BROKEN := y
 endef
-#TARGET_DEVICES += tplink-archer-c9-v1
+TARGET_DEVICES += tplink-archer-c9-v1
 
 $(eval $(call BuildImage))