gpio-cdev: move kmod-leds-uleds dependency to MX100
authorChristian Lamparter <chunkeey@gmail.com>
Sun, 27 Mar 2022 13:04:29 +0000 (15:04 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 27 Mar 2022 13:39:27 +0000 (15:39 +0200)
The inclusion of the kmod-leds-uleds into the userspace
nu801 package causes a circular dependency inside the
buildsystem... which causes it to be picked regardless
of other DEPENDS values.

In case of the mx100, this could be solved by moving the
kmod-leds-uled dependency to the kmod-meraki-mx100.

Bonus: drop @!LINUX_5_4 from kmod-meraki-mx100
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/system/gpio-cdev/nu801/Makefile
target/linux/x86/modules.mk

index ff6d36f2b49d991292c4014723598e8ad0b674ee..1ac5c6d51002c9ba702b085e6aadaad0c828c8eb 100644 (file)
@@ -20,7 +20,7 @@ define Package/nu801
   SECTION:=utils
   CATEGORY:=Utilities
   SUBMENU:=Userspace GPIO Drivers
-  DEPENDS:=@TARGET_x86 +kmod-leds-uleds
+  DEPENDS:=@TARGET_x86
   KCONFIG:=CONFIG_GPIO_CDEV=y
   TITLE:=NU801 LED Driver
 endef
index 0071ebda41215b5e39faade0eb1fae298b4e4b58..f3226e3a6090ca0e0209d839e626b8f3385dff43 100644 (file)
@@ -87,8 +87,8 @@ $(eval $(call KernelPackage,pcengines-apuv2))
 define KernelPackage/meraki-mx100
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Cisco Meraki MX100 Platform Driver
-  DEPENDS:=@TARGET_x86 @!LINUX_5_4 +kmod-tg3 +kmod-gpio-button-hotplug +kmod-leds-gpio \
-    +kmod-usb-ledtrig-usbport +nu801 +kmod-itco-wdt
+  DEPENDS:=@TARGET_x86 +kmod-tg3 +kmod-gpio-button-hotplug +kmod-leds-gpio \
+    +kmod-usb-ledtrig-usbport +nu801 +kmod-itco-wdt +kmod-leds-uleds
   KCONFIG:=CONFIG_MERAKI_MX100
   FILES:=$(LINUX_DIR)/drivers/platform/x86/meraki-mx100.ko
   AUTOLOAD:=$(call AutoLoad,60,meraki-mx100,1)