ramips: mt7621: replace missing custom-initramfs-uimage
authorSander Vanheule <sander@svanheule.net>
Thu, 26 Nov 2020 08:01:26 +0000 (09:01 +0100)
committerPetr Štetiar <ynezz@true.cz>
Thu, 26 Nov 2020 08:12:57 +0000 (09:12 +0100)
custom-initramfs-uimage was replaced by calls to uImage, but apparently
mtc_wr1201 was missed in the transistion. Use uImage for this device
too.

Fixes: 9f574b1b875c "ramips: mt7621: drop custom uImage function"
Signed-off-by: Sander Vanheule <sander@svanheule.net>
target/linux/ramips/image/mt7621.mk

index d3b96f5f4be7e1acbf202ce076c14c80d88f9915..ce9a3ae3d23f4004c64b13d55f1fad919bc82154 100644 (file)
@@ -758,7 +758,7 @@ define Device/mtc_wr1201
   IMAGE_SIZE := 16000k
   DEVICE_VENDOR := MTC
   DEVICE_MODEL := Wireless Router WR1201
-  KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage WR1201_8_128
+  KERNEL_INITRAMFS := $(KERNEL_DTB) | uImage lzma -n 'WR1201_8_128'
   DEVICE_PACKAGES := kmod-sdhci-mt7620 kmod-mt76x2 kmod-usb3 \
        kmod-usb-ledtrig-usbport
 endef