ath79: image: drop 'BOARDNAME' from devices recipes
authorPiotr Dymacz <pepe2k@gmail.com>
Sun, 20 Feb 2022 11:43:38 +0000 (12:43 +0100)
committerPiotr Dymacz <pepe2k@gmail.com>
Mon, 21 Feb 2022 18:16:30 +0000 (19:16 +0100)
The 'BOARDNAME' variable is part of target configuration and shouldn't
be part of a device's image recipe.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
target/linux/ath79/image/generic-tp-link.mk

index 2880dbda1df87d0151971232c2201adb8b49af96..c47fcd00393cc01fd687e4b73da52cc101631477 100644 (file)
@@ -9,7 +9,6 @@ define Device/tplink_archer-a7-v5
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct \
        ath10k-firmware-qca988x-ct
   TPLINK_BOARD_ID := ARCHER-A7-V5
-  BOARDNAME := ARCHER-A7-V5
 endef
 TARGET_DEVICES += tplink_archer-a7-v5
 
@@ -181,7 +180,6 @@ define Device/tplink_archer-c7-v4
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct \
        ath10k-firmware-qca988x-ct
   TPLINK_BOARD_ID := ARCHER-C7-V4
-  BOARDNAME := ARCHER-C7-V4
   SUPPORTED_DEVICES += archer-c7-v4
 endef
 TARGET_DEVICES += tplink_archer-c7-v4
@@ -195,7 +193,6 @@ define Device/tplink_archer-c7-v5
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct \
        ath10k-firmware-qca988x-ct
   TPLINK_BOARD_ID := ARCHER-C7-V5
-  BOARDNAME := ARCHER-C7-V5
   SUPPORTED_DEVICES += archer-c7-v5
 endef
 TARGET_DEVICES += tplink_archer-c7-v5
@@ -207,7 +204,6 @@ define Device/tplink_archer-d50-v1
   DEVICE_VARIANT := v1
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport \
        kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
-  BOARDNAME := ARCHER-D50-V1
   IMAGE_SIZE := 7808k
   TPLINK_HWID := 0xC1200001
   TPLINK_HWREV := 0x00000046