ath79: add support for Sophos AP15
authorManuel Niekamp <m.niekamp@richter-leiterplatten.de>
Wed, 22 Jun 2022 20:56:29 +0000 (22:56 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 6 Aug 2022 18:33:59 +0000 (20:33 +0200)
The Sophos AP15 seems to be very close to Sophos AP55/AP100.

Based on:
commit 6f1efb289837 ("ath79: add support for Sophos AP100/AP55 family")
author    Andrew Powers-Holmes <andrew@omnom.net>
          Fri, 3 Sep 2021 15:53:57 +0200 (23:53 +1000)
committer Hauke Mehrtens <hauke@hauke-m.de>
          Sat, 16 Apr 2022 16:59:29 +0200 (16:59 +0200)

Unique to AP15:
 - Green and yellow LED
 - 2T2R 2.4GHz 802.11b/g/n via SoC WMAC
 - No buttons
 - No piezo beeper
 - No 5.8GHz

Flashing instructions:
 - Derived from UART method described in referenced commit, methods
   described there should work too.
 - Set up a TFTP server; IP address has to be 192.168.99.8/24
 - Copy the firmware (initramfs-kernel) to your TFTP server directory
   renaming it to e.g. boot.bin
 - Open AP's enclosure and locate UART header (there is a video online)
 - Terminal connection parameters are 115200 8/N/1
 - Connect TFTP server and AP via ethernet
 - Power up AP and cancel autoboot when prompted
 - Prompt shows 'ath> '
 - Commands used to boot:
    ath> tftpboot 0x81000000 boot.bin
    ath> bootm 0x81000000
 - Device should boot OpenWRT
 - IP address after boot is 192.168.1.1/24
 - Connect to device via browser
 - Permanently flash using the web ui (flashing sysupgrade image)
 - (BTW: the AP55 images seem to work too, only LEDs are not working)

Testing done:
 - To be honest: Currently not so much testing done.
 - Flashed onto two devices
 - Devices are booting
 - MAC addresses are correct
 - LEDs are working
 - Scanning for WLANs is working

Big thanks to all the people working on this great project!
(Sorry about my english, it is not my native language)

Signed-off-by: Manuel Niekamp <m.niekamp@richter-leiterplatten.de>
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/qca9558_sophos_ap15.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/image/generic.mk

index e1a442349769648fe35eb4a09540b54aa702e5aa..a435e06a0d1f0cd53afdce68d0384d9aa8937f65 100644 (file)
@@ -126,6 +126,7 @@ plasmacloud,pa300e)
 qihoo,c301)
        ubootenv_add_uci_config "/dev/mtd9" "0x0" "0x10000" "0x10000"
        ;;
+sophos,ap15|\
 sophos,ap55|\
 sophos,ap55c|\
 sophos,ap100|\
diff --git a/target/linux/ath79/dts/qca9558_sophos_ap15.dts b/target/linux/ath79/dts/qca9558_sophos_ap15.dts
new file mode 100644 (file)
index 0000000..bb4b058
--- /dev/null
@@ -0,0 +1,138 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca955x.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "sophos,ap15", "qca,qca9558";
+       model = "Sophos AP15";
+
+       aliases {
+               led-boot = &led_status_green;
+               led-failsafe = &led_status_yellow;
+               led-running = &led_status_green;
+               led-upgrade = &led_status_yellow;
+               label-mac-device = &eth0;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status_green: status_green {
+                       label = "green:status";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               led_status_yellow: status_yellow {
+                       label = "yellow:status";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&pcie0 {
+       status = "okay";
+};
+
+&spi {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                       };
+
+                       art: partition@50000 {
+                               label = "art";
+                               reg = <0x050000 0x010000>;
+                               read-only;
+                       };
+
+                       config: partition@60000 {
+                               label = "config";
+                               reg = <0x060000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@70000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x070000 0xf90000>;
+                       };
+               };
+       };
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <0x10>;
+
+       phy4: ethernet-phy@4 {
+               reg = <4>;
+               eee-broken-100tx;
+               eee-broken-1000t;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       pll-data = <0xa6000000 0xa0000101 0xa0001313>;
+
+       nvmem-cells = <&macaddr_config_201a>;
+       nvmem-cell-names = "mac-address";
+
+       phy-mode = "rgmii-id";
+       phy-handle = <&phy4>;
+
+       gmac_config: gmac-config {
+               device = <&gmac>;
+
+               rgmii-enabled = <1>;
+
+               rxdv-delay = <3>;
+               rxd-delay = <3>;
+               txen-delay = <3>;
+               txd-delay = <3>;
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+};
+
+&config {
+       compatible = "nvmem-cells";
+       #address-cells = <1>;
+       #size-cells = <1>;
+
+       macaddr_config_201a: macaddr@201a {
+               reg = <0x201a 0x6>;
+       };
+};
index 84221da80d25edf158884cd822410b84d93e7fcd..f10737f2fbd66708d0d5092663c77f7ec3c6baaf 100644 (file)
@@ -65,6 +65,7 @@ ath79_setup_interfaces()
        pisen,wmb001n|\
        pisen,wmm003n|\
        siemens,ws-ap3610|\
+       sophos,ap15|\
        sophos,ap55|\
        sophos,ap55c|\
        sophos,ap100|\
index 56e42f1e31dcc397a126e3febcfe73879de8fde2..0aa3e006f6db99a7336d163990cc2509c6b34b21 100644 (file)
@@ -30,6 +30,7 @@ case "$FIRMWARE" in
        qxwlan,e1700ac-v2-16m|\
        qxwlan,e600gac-v2-8m|\
        qxwlan,e600gac-v2-16m|\
+       sophos,ap15|\
        sophos,ap55|\
        sophos,ap55c|\
        sophos,ap100|\
index 7442a0f68cbeb3108d44ca8908198681e8fb8e08..4aa6ed6480f45e5f6b60226a7f65c4c625cc3f52 100644 (file)
@@ -2417,6 +2417,15 @@ define Device/sitecom_wlr-8100
 endef
 TARGET_DEVICES += sitecom_wlr-8100
 
+define Device/sophos_ap15
+  SOC := qca9558
+  DEVICE_VENDOR := Sophos
+  DEVICE_MODEL := AP15
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += sophos_ap15
+
 define Device/sophos_ap55
   SOC := qca9558
   DEVICE_VENDOR := Sophos