ramips: define loadaddr for U6 Lite DTB
authorDavid Bauer <mail@david-bauer.net>
Sun, 6 Nov 2022 23:42:57 +0000 (00:42 +0100)
committerDavid Bauer <mail@david-bauer.net>
Tue, 8 Nov 2022 11:16:43 +0000 (12:16 +0100)
The Ubiquiti UniFi 6 Lite does not correctly align the FDT by always
setting fdt_high to 0xffffffff when invoking the bootubnt command.

Work around this issue by loading the DTB to a valid,aligned address, so
the bootloader does not have to relocate the FDT automatically.

Note: The device does read the kernel before invoking bootm on the FIT
image to 0x86000000.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ramips/image/mt7621.mk

index 35817d03176a54e868c09b79f4b752f01c287863..222809dbbe0a2aa92385b63ca0d20673ad880c02 100644 (file)
@@ -2016,6 +2016,7 @@ define Device/ubnt_unifi-6-lite
   DEVICE_VENDOR := Ubiquiti
   DEVICE_MODEL := UniFi 6 Lite
   DEVICE_DTS_CONFIG := config@1
+  DEVICE_DTS_LOADADDR := 0x87000000
   DEVICE_PACKAGES += kmod-mt7603 kmod-mt7915e
   KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
   IMAGE_SIZE := 15424k