ramips: add support for Z-ROUTER ZR-2660
authorMikhail Zhilkin <csharper2005@gmail.com>
Sat, 2 Mar 2024 19:58:40 +0000 (19:58 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 12 Mar 2024 22:57:41 +0000 (23:57 +0100)
This commit adds support for Z-ROUTER ZR-2660 (also known as Routerich
AX1800) wireless WiFi 6 router.

Specification
-------------
- SoC       : MediaTek MT7621AT, MIPS, 880 MHz
- RAM       : 256 MiB
- Flash     : NAND 128 MiB (AMD/Spansion S34ML01G2)
- WLAN      :
  - 2.4 GHz : MediaTek MT7905D/MT7975 (14c3:7916), b/g/n/ax, MIMO 2x2
  - 5 GHz   : MediaTek MT7915E (14c3:7915), a/n/ac/ax, MIMO 2x2
- Ethernet  : 10/100/1000 Mbps x4 (1x WAN, 3x LAN)
- USB       : 1x 2.0
- UART      : 3.3V, 115200n8, pins are silkscreened on the pcb
- Buttons   : 1x Reset
- LEDs      : 1x WiFi 2.4 GHz (green)
              1x WiFi 5 GHz (green)
              1x LAN (green)
              1x WAN (green)
              1x WAN no-internet (red)
- Power     : 12 VDC, 1 A

Installation
------------
1. Run tftp server on your PC (IP: 192.168.2.2) and put OpenWrt initramfs
   image (initramfs.bin) to the tftp root dir
2. Open the following link in the browser to enable telnet:
http://192.168.2.1/cgi-bin/telnet_ssh
3. Connect to the router (default IP: 192.168.2.1) using telnet shell
   (credentials - user:admin)
4. Run the following commands in the telnet shell (this will install
   OpenWrt initramfs image on nand flash):
cd /tmp
tftp -g -r initramfs.bin 192.168.2.2
mtd write initramfs.bin firmware
mtd erase firmware_backup
reboot
5. Copy OpenWrt sysupgrade image (sysupgrade.bin) to the /tmp dir of the
   router
6. Connect to the router (IP: 192.168.1.1) using ssh shell and run
   sysupgrade command:
sysupgrade -n /tmp/sysupgrade.bin

Return to stock
---------------
1. Copy stock firmware (stock.bin) to the /tmp dir of the router using scp
2. Run following command in the router shell:
cd /tmp
mtd write stock.bin firmware
reboot

Recovery
--------
Connect uart (pins are silkscreened on the pcb), interrupt boot process by
pressing any key, use u-boot menu to flash stock firmware image or OpenWrt
initramfs image.

MAC addresses
-------------
+---------+-------------------+-----------+
|         | MAC               | Algorithm |
+---------+-------------------+-----------+
| LAN     | 24:0f:5e:xx:xx:4c | label     |
| WAN     | 24:0f:5e:xx:xx:4d | label+1   |
| WLAN 2g | 24:0f:5e:xx:xx:4e | label+2   |
| WLAN 5g | 24:0f:5e:xx:xx:4f | label+3   |
+---------+-------------------+-----------+
The WLAN 2.4 MAC was found in 'factory', 0x4
The LAN MAC was found in 'factory', 0xfff4
The WAN MAC was found in 'factory', 0xfffa

Signed-off-by: Mikhail Zhilkin <csharper2005@gmail.com>
target/linux/ramips/dts/mt7621_z-router_zr-2660.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
target/linux/ramips/mt7621/base-files/etc/board.d/02_network
target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh

diff --git a/target/linux/ramips/dts/mt7621_z-router_zr-2660.dts b/target/linux/ramips/dts/mt7621_z-router_zr-2660.dts
new file mode 100644 (file)
index 0000000..34b151b
--- /dev/null
@@ -0,0 +1,211 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/leds/common.h>
+
+/ {
+       compatible = "z-router,zr-2660", "mediatek,mt7621-soc";
+       model = "Z-ROUTER ZR-2660";
+
+       aliases {
+               label-mac-device = &gmac0;
+
+               led-boot = &led_power_green;
+               led-failsafe = &led_power_green;
+               led-running = &led_power_green;
+               led-upgrade = &led_power_green;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               key-0 {
+                       label = "reset";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led-0 {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_WAN;
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+               };
+
+               led-1 {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_WLAN;
+                       function-enumerator = <50>;
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               led-2 {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_LAN;
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+
+               led-3 {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_WLAN;
+                       function-enumerator = <24>;
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               led-4 {
+                       color = <LED_COLOR_ID_RED>;
+                       function = LED_FUNCTION_WAN;
+                       gpios = <&gpio 16 GPIO_ACTIVE_HIGH>;
+               };
+
+               led_power_green: led-5 {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_POWER;
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&gmac0 {
+       nvmem-cells = <&macaddr_factory_3fff4>;
+       nvmem-cell-names = "mac-address";
+};
+
+&gmac1 {
+       status = "okay";
+       label = "wan";
+       phy-handle = <&ethphy4>;
+
+       nvmem-cells = <&macaddr_factory_3fffa>;
+       nvmem-cell-names = "mac-address";
+};
+
+&mdio {
+       ethphy4: ethernet-phy@4 {
+               reg = <4>;
+       };
+};
+
+&nand {
+       status = "okay";
+
+       mediatek,nmbm;
+       mediatek,bmt-max-ratio = <1>;
+       mediatek,bmt-max-reserved-blocks = <64>;
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x80000>;
+                       read-only;
+               };
+
+               partition@80000 {
+                       label = "Config";
+                       reg = <0x80000 0x80000>;
+                       read-only;
+               };
+
+               partition@100000 {
+                       label = "factory";
+                       reg = <0x100000 0x80000>;
+                       read-only;
+
+                       nvmem-layout {
+                               compatible = "fixed-layout";
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               eeprom_factory_0: eeprom@0 {
+                                       reg = <0x0 0xe00>;
+                               };
+
+                               macaddr_factory_3fff4: macaddr@3fff4 {
+                                       reg = <0x3fff4 0x6>;
+                               };
+
+                               macaddr_factory_3fffa: macaddr@3fffa {
+                                       reg = <0x3fffa 0x6>;
+                               };
+                       };
+               };
+
+               partition@180000 {
+                       label = "firmware";
+                       reg = <0x180000 0x7680000>;
+
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "kernel";
+                               reg = <0x0 0x400000>;
+                       };
+
+                       partition@400000 {
+                               label = "ubi";
+                               reg = <0x400000 0x7280000>;
+                       };
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie1 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+
+               mediatek,disable-radar-background;
+
+               nvmem-cells = <&eeprom_factory_0>;
+               nvmem-cell-names = "eeprom";
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "i2c", "jtag", "wdt";
+               function = "gpio";
+       };
+};
+
+&switch0 {
+       ports {
+               port@1 {
+                       status = "okay";
+                       label = "lan1";
+               };
+
+               port@2 {
+                       status = "okay";
+                       label = "lan2";
+               };
+
+               port@3 {
+                       status = "okay";
+                       label = "lan3";
+               };
+       };
+};
index 3b9ee022f61a1d0bf42c894d693f2fb13d5617a8..5fd95463c86a509ed2781ec97f4e60f14cf7e9a6 100644 (file)
@@ -2928,6 +2928,21 @@ define Device/yuncore_g720
 endef
 TARGET_DEVICES += yuncore_g720
 
+define Device/z-router_zr-2660
+  $(Device/dsa-migration)
+  $(Device/nand)
+  DEVICE_VENDOR := Z-ROUTER
+  DEVICE_MODEL := ZR-2660
+  DEVICE_ALT0_VENDOR := Routerich
+  DEVICE_ALT0_MODEL := AX1800
+  IMAGE_SIZE := 90112k
+  KERNEL_LOADADDR := 0x82000000
+  KERNEL := kernel-bin | relocate-kernel $(loadaddr-y) | lzma | \
+       fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+  DEVICE_PACKAGES += kmod-mt7915-firmware kmod-usb3 -uboot-envtools
+endef
+TARGET_DEVICES += z-router_zr-2660
+
 define Device/zbtlink_zbt-we1326
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)
index 81afa45e80c49c6a2099303fc9823462654f6167..3eba20bb79a0104bf391c8d3c627eaea3dad51a7 100644 (file)
@@ -251,6 +251,11 @@ yuncore,ax820)
        ucidef_set_led_netdev "lan" "LAN" "green:lan" "lan"
        ucidef_set_led_netdev "wan" "WAN" "green:wan" "wan"
        ;;
+z-router,zr-2660)
+       ucidef_set_led_netdev "lan" "lan" "green:lan" "br-lan" "link tx rx"
+       ucidef_set_led_netdev "wan" "wan" "green:wan" "wan" "link tx rx"
+       ucidef_set_led_netdev "wan-off" "wan-off" "red:wan" "wan" "link"
+       ;;
 zyxel,lte3301-plus)
        ucidef_set_led_netdev "internet" "internet" "white:internet" "wwan0"
        ;;
index d0481b78e90134d06b54c93c5182ee725a590c3d..d932313cf1686da4066d6ff9f1bb695cb21774b2 100644 (file)
@@ -26,6 +26,7 @@ ramips_setup_interfaces()
        xiaomi,mi-router-cr6608|\
        xiaomi,mi-router-cr6609|\
        xiaomi,redmi-router-ac2100|\
+       z-router,zr-2660|\
        zyxel,wsm20)
                ucidef_set_interfaces_lan_wan "lan1 lan2 lan3" "wan"
                ;;
index 3be4e24e0917f4564b96c9c2cfac2d13dda27f8e..962e1f7019776d7760806c6615d05be77ef3c80a 100644 (file)
@@ -72,7 +72,8 @@ case "$board" in
                        macaddr_setbit_la "$base_mac" > /sys${DEVPATH}/macaddress
                fi
                ;;
-       glinet,gl-mt1300)
+       glinet,gl-mt1300|\
+       z-router,zr-2660)
                [ "$PHYNBR" = "1" ] && \
                        macaddr_add "$(mtd_get_mac_binary factory 0x4)" 1 > /sys${DEVPATH}/macaddress
                ;;
index 61517141453b7384ac10f3c84e8b58e96a68dca9..eba02e6599860ada08d02fd336cf23e9f80a6408 100755 (executable)
@@ -124,6 +124,7 @@ platform_do_upgrade() {
        xiaomi,mi-router-cr6608|\
        xiaomi,mi-router-cr6609|\
        xiaomi,redmi-router-ac2100|\
+       z-router,zr-2660|\
        zyxel,nwa50ax|\
        zyxel,nwa55axe)
                nand_do_upgrade "$1"