ramips: fix lzma-loader for ASIARF boards
authorDaniel Danzberger <daniel@dd-wrt.com>
Fri, 2 Jun 2023 17:36:28 +0000 (19:36 +0200)
committerPetr Štetiar <ynezz@true.cz>
Mon, 5 Jun 2023 08:01:27 +0000 (10:01 +0200)
This fixes a well known "LZMA ERROR 1" error, reported previously on
numerous of similar devices.

Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
target/linux/ramips/image/mt7621.mk

index 9dbcf09eb2b98a76aed94d0c7569e08eb28244f9..340d4ba4a1b3218109e46e2102e045a6341f6629 100644 (file)
@@ -237,6 +237,7 @@ TARGET_DEVICES += arcadyan_we420223-99
 
 define Device/asiarf_ap7621-001
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 16000k
   DEVICE_VENDOR := AsiaRF
   DEVICE_MODEL := AP7621-001
@@ -247,6 +248,7 @@ TARGET_DEVICES += asiarf_ap7621-001
 
 define Device/asiarf_ap7621-nv1
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 16000k
   DEVICE_VENDOR := AsiaRF
   DEVICE_MODEL := AP7621-NV1