ramips: use default lzma dictionary size for better performance
authorShiji Yang <yangshiji66@qq.com>
Thu, 1 Dec 2022 10:49:45 +0000 (18:49 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 7 Jan 2023 15:56:16 +0000 (16:56 +0100)
limit dictionary size patch was introduced to solve the well known
"LZMA ERROR 1 - must RESET board to recover" error.
09b6755946409d8fd8 "ramips: limit dictionary size for lzma compression"

It seems that it has failed recently and we can use lzma loader to fix
this error by adding "$(Device/uimage-lzma-loader)". So just remove it
to use the default parameter -d24 for a higher compression ratio.

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
target/linux/ramips/image/mt7621.mk

index dd49583bf4b7b394bb4135918baeeb0a406f5aad..45ff52be352d525371d903f7bd334deaf092cd2a 100644 (file)
@@ -7,7 +7,6 @@ include ./common-tp-link.mk
 
 DEFAULT_SOC := mt7621
 
-KERNEL_DTB += -d21
 DEVICE_VARS += ELECOM_HWNAME LINKSYS_HWNAME
 
 ifdef CONFIG_LINUX_5_10