ath79: Support for Ubiquiti Rocket 5AC Lite
authorNick Hainke <vincent@systemli.org>
Sun, 25 Apr 2021 20:41:46 +0000 (22:41 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 6 Jun 2021 22:23:51 +0000 (00:23 +0200)
The Ubiquiti Rocket 5AC Lite (R5AC-Lite) is an outdoor router.

Specifications:
 - SoC: Qualcomm Atheros QCA9558
 - RAM: 128 MB
 - Flash: 16 MB SPI
 - Ethernet: 1x 10/100/1000 Mbps
 - WiFi 5 GHz: QCA988x
 - Buttons: 1x (reset)
 - LEDs: 1x power, 1x Ethernet, 4x RSSI

Installation:
- Instructions for XC-type Ubiquiti:
  https://openwrt.org/toh/ubiquiti/common

Signed-off-by: Nick Hainke <vincent@systemli.org>
target/linux/ath79/dts/qca9558_ubnt_rocket-5ac-lite.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/image/generic-ubnt.mk

diff --git a/target/linux/ath79/dts/qca9558_ubnt_rocket-5ac-lite.dts b/target/linux/ath79/dts/qca9558_ubnt_rocket-5ac-lite.dts
new file mode 100644 (file)
index 0000000..e8e2322
--- /dev/null
@@ -0,0 +1,38 @@
+// SPDX-License-Identifier: GPL-2.0-only
+
+#include "qca955x_ubnt_xc.dtsi"
+
+/ {
+       compatible = "ubnt,rocket-5ac-lite", "ubnt,xc", "qca,qca9558";
+       model = "Ubiquiti Rocket 5AC Lite";
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "Reset button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <4>;
+       phy4: ethernet-phy@4 {
+               phy-mode = "sgmii";
+               reg = <4>;
+               at803x-override-sgmii-link-check;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       mtd-mac-address = <&art 0x0>;
+       phy-mode = "sgmii";
+       phy-handle = <&phy4>;
+};
index f07c08697782ce15836cc31a240396eec108f9f7..c1ba7601824327e389f0e96b4804f7119691a105 100644 (file)
@@ -86,6 +86,7 @@ ath79_setup_interfaces()
        ubnt,powerbeam-5ac-500|\
        ubnt,powerbeam-5ac-gen2|\
        ubnt,powerbridge-m|\
+       ubnt,rocket-5ac-lite|\
        ubnt,rocket-m|\
        ubnt,unifiac-lite|\
        ubnt,unifiac-lr|\
index feb9a5186e896d7170251671caaba3d418e5109a..8d070cba2733b482ad9e4e4c7d900eb4865d86d0 100644 (file)
@@ -43,6 +43,7 @@ case "$FIRMWARE" in
        ubnt,nanostation-ac-loco|\
        ubnt,powerbeam-5ac-500|\
        ubnt,powerbeam-5ac-gen2|\
+       ubnt,rocket-5ac-lite|\
        ubnt,unifiac-pro|\
        yuncore,a770)
                caldata_extract "art" 0x5000 0x844
index 733d803d7ab6c42f249f5f1b10ceb7d22e0edac2..f8e1d1e43251365c006cf17417cd997ebf3efa89 100644 (file)
@@ -337,6 +337,15 @@ define Device/ubnt_powerbridge-m
 endef
 TARGET_DEVICES += ubnt_powerbridge-m
 
+define Device/ubnt_rocket-5ac-lite
+  $(Device/ubnt-xc)
+  SOC := qca9558
+  DEVICE_MODEL := Rocket 5AC
+  DEVICE_VARIANT := Lite
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += ubnt_rocket-5ac-lite
+
 define Device/ubnt_rocket-m
   $(Device/ubnt-xm)
   SOC := ar7241