ramips: tplink,mr600v2: fix image generation for sysupgrade image
authorAndreas Böhler <dev@aboehler.at>
Sun, 2 Apr 2023 08:40:47 +0000 (10:40 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 3 Jun 2023 19:14:37 +0000 (21:14 +0200)
The MR600v2 does not find its rootfs if it is neither directly after the
kernel or aligned to an erase block boundary (64k).

This aligns the rootfs to 0x10000 allowing the device to boot again. Based
on investigation by forum user relghuar.

Signed-off-by: Andreas Böhler <dev@aboehler.at>
target/linux/ramips/image/mt7621.mk

index 2697f84bf7684d5ad2b724b4bd93c4e1504112dd..9dbcf09eb2b98a76aed94d0c7569e08eb28244f9 100644 (file)
@@ -2158,6 +2158,9 @@ define Device/tplink_mr600-v2-eu
   TPLINK_FLASHLAYOUT := 16Mltq
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap \
                kmod-usb-net-qmi-wwan uqmi kmod-usb3 -uboot-envtools
+  IMAGE/factory.bin := tplink-v2-image -e -a 0x10000
+  IMAGE/sysupgrade.bin := tplink-v2-image -s -e -a 0x10000 | check-size | \
+       append-metadata
   KERNEL := $(KERNEL_DTB) | uImage lzma
   KERNEL_INITRAMFS := $$(KERNEL) | tplink-v2-header
   TPLINK_BOARD_ID := MR600-V2-EU