ramips: RT1800: fix invalid octal number error
authorMax Qian <public@maxqia.com>
Fri, 15 Sep 2023 04:54:30 +0000 (21:54 -0700)
committerMax Qian <public@maxqia.com>
Sun, 17 Sep 2023 20:52:55 +0000 (13:52 -0700)
This commit removes the padded zeros in the date formatting.
The padded zeros from the date command causes the numbers
to be interpreted as an octal number by printf. Months, days,
and years with the number 08 or 09 raise an error in printf as an
"invalid octal number" and get interpreted as a zero.

Signed-off-by: Max Qian <public@maxqia.com>
target/linux/ramips/image/mt7621.mk

index abcdc08ade3d2534eae09d89cb3b0569246570c2..065a61de28b34acd00981d5839faf7f20a73c342 100644 (file)
@@ -119,7 +119,7 @@ define Build/belkin-header
 
        ( \
                type_fw_date=$$(printf "01%02x%02x%02x" \
-                       $$(date -d "@$(SOURCE_DATE_EPOCH)" "+%y %m %d")); \
+                       $$(date -d "@$(SOURCE_DATE_EPOCH)" "+%-y %-m %-d")); \
                hw_fw_ver=$$(printf "%02x%02x%02x%02x" \
                        $(hw_ver) $$(echo $(fw_ver) | cut -d. -f-3 | tr . ' ')); \
                fw_len_crc=$$(gzip -c $@ | tail -c 8 | od -An -tx8 | tr -d ' \n'); \