ramips: combine USW-Flex dual firmware-partitions
authorDavid Bauer <mail@david-bauer.net>
Thu, 17 Nov 2022 22:02:13 +0000 (23:02 +0100)
committerDavid Bauer <mail@david-bauer.net>
Sat, 7 Jan 2023 00:32:58 +0000 (01:32 +0100)
In order to maximize the available space on USW-Flex boards using a
dual-image partition layout, combine the two OS partitions into a single
partition.

This allows users to access more usable space for additional packages.

Don't limit the usable image size to the size of a single OS partition.
The initial installation has to be done with an older version of OpenWrt
in case the generated image exceeds the space of a single kernel
partition in the future.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ramips/dts/mt7621_ubnt_usw-flex.dts
target/linux/ramips/image/mt7621.mk

index e148242387f3cf951ce32aa8e99855da010c2021..ff328bd858b397b3a6e4ec09710dd9b227a75146 100644 (file)
                        };
 
                        partition@1a0000 {
+                               /* Combine kernel0 / kernel1 */
                                compatible = "denx,fit";
                                label = "firmware";
-                               reg = <0x1a0000 0x730000>;
-                       };
-
-                       partition@8d0000 {
-                               label = "kernel1";
-                               reg = <0x8d0000 0x730000>;
+                               reg = <0x1a0000 0xe60000>;
                        };
                };
        };
index 2fc193634b09b885ed7a1849936cfeba30395312..dd49583bf4b7b394bb4135918baeeb0a406f5aad 100644 (file)
@@ -2130,7 +2130,7 @@ define Device/ubnt_usw-flex
   DEVICE_DTS_CONFIG := config@1
   DEVICE_DTS_LOADADDR := 0x87000000
   KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
-  IMAGE_SIZE := 7360k
+  IMAGE_SIZE := 14720k
 endef
 TARGET_DEVICES += ubnt_usw-flex