ramips: mt7621: enable lzma-loader for ZyXEL WAP6805
authorBjørn Mork <bjorn@mork.no>
Mon, 28 Nov 2022 14:45:12 +0000 (15:45 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 3 Dec 2022 20:04:38 +0000 (21:04 +0100)
Fixing "Uncompressing Kernel Image ... LZMA ERROR 1 - must RESET board
to recover".

Signed-off-by: Bjørn Mork <bjorn@mork.no>
target/linux/ramips/image/mt7621.mk

index 943fc62ecd6ba4ae1fb99f10acf0730cee561acf..82b4731bb50d50f805c585f7907d26c609b07dab 100644 (file)
@@ -2575,6 +2575,7 @@ TARGET_DEVICES += zyxel_nwa55axe
 
 define Device/zyxel_wap6805
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   BLOCKSIZE := 128k
   PAGESIZE := 2048
   KERNEL_SIZE := 4096k
@@ -2583,7 +2584,7 @@ define Device/zyxel_wap6805
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := WAP6805
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt7621-qtn-rgmii
-  KERNEL := $(KERNEL_DTB) | uImage lzma | uimage-padhdr 160
+  KERNEL := $$(KERNEL/lzma-loader) | uImage none | uimage-padhdr 160
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
 endef
 TARGET_DEVICES += zyxel_wap6805