ramips: add missing mt76 packages for Telco Electronics X1
authorShiji Yang <yangshiji66@qq.com>
Mon, 2 Oct 2023 03:42:23 +0000 (11:42 +0800)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 17 Oct 2023 10:07:28 +0000 (12:07 +0200)
Telco Electronics X1 has MT7603E and MT7612E PCIe NICs. They are
driven by kmod-mt7603 and kmod-mt76x2.

Ref: 73e0f52b6e4e ("ramips: add support for Telco Electronics X1")
Signed-off-by: Shiji Yang <yangshiji66@qq.com>
target/linux/ramips/image/mt7621.mk

index 9838810af4341fc62bde4d89ac7884ac077ca80a..dc9e5515a7be5294b1c454651f69d3fa70299020 100644 (file)
@@ -2128,7 +2128,7 @@ define Device/telco-electronics_x1
   IMAGE_SIZE := 16064k
   DEVICE_VENDOR := Telco Electronics
   DEVICE_MODEL := X1
-  DEVICE_PACKAGES := kmod-usb3 kmod-mt76 -uboot-envtools
+  DEVICE_PACKAGES := kmod-usb3 kmod-mt7603 kmod-mt76x2 -uboot-envtools
 endef
 TARGET_DEVICES += telco-electronics_x1