ath79: Add support for OpenMesh A40
authorSven Eckelmann <sven@narfation.org>
Mon, 23 Nov 2020 12:41:34 +0000 (13:41 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 4 Jun 2021 23:17:11 +0000 (01:17 +0200)
Device specifications:
======================

* Qualcomm/Atheros QCA9558 ver 1 rev 0
* 720/600/240 MHz (CPU/DDR/AHB)
* 128 MB of RAM
* 16 MB of SPI NOR flash
  - 2x 7 MB available; but one of the 7 MB regions is the recovery image
* 2T2R 2.4 GHz Wi-Fi (11n)
* 2T2R 5 GHz Wi-Fi (11ac)
* multi-color LED (controlled via red/green/blue GPIOs)
* 1x GPIO-button (reset)
* external h/w watchdog (enabled by default))
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 2x ethernet
  - eth0
    + Label: Ethernet 1
    + AR8035 ethernet PHY (RGMII)
    + 10/100/1000 Mbps Ethernet
    + 802.3af POE
    + used as WAN interface
  - eth1
    + Label: Ethernet 2
    + AR8035 ethernet PHY (SGMII)
    + 10/100/1000 Mbps Ethernet
    + used as LAN interface
* 1x USB
* internal antennas

Flashing instructions:
======================

Various methods can be used to install the actual image on the flash.
Two easy ones are:

ap51-flash
----------

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the image to the u-boot when the device boots up.

initramfs from TFTP
-------------------

The serial console must be used to access the u-boot shell during bootup.
It can then be used to first boot up the initramfs image from a TFTP server
(here with the IP 192.168.1.21):

   setenv serverip 192.168.1.21
   setenv ipaddr 192.168.1.1
   tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr

The actual sysupgrade image can then be transferred (on the LAN port) to the
device via

  scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/

On the device, the sysupgrade must then be started using

  sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin

Signed-off-by: Sven Eckelmann <sven@narfation.org>
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/qca9558_openmesh_a40.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
target/linux/ath79/image/generic.mk

index 1fc484df525188f36bd13c45a8ced330de2dbdbc..91ba587bf8f6532dc31e0b4c9cece7ba74fedd1d 100644 (file)
@@ -48,6 +48,7 @@ netgear,wnr2200-16m|\
 netgear,wnr612-v2|\
 ocedo,koala|\
 ocedo,raccoon|\
+openmesh,a40|\
 openmesh,a60|\
 openmesh,mr600-v1|\
 openmesh,mr600-v2|\
diff --git a/target/linux/ath79/dts/qca9558_openmesh_a40.dts b/target/linux/ath79/dts/qca9558_openmesh_a40.dts
new file mode 100644 (file)
index 0000000..d2b8170
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9558_openmesh_a60.dtsi"
+
+/ {
+       compatible = "openmesh,a40", "qca,qca9558";
+       model = "OpenMesh A40";
+};
index d2b55f0ba6db11f97e32d00e8e77980c49bd3bc8..87aaf0bcad333bd70e33e36933c9080247866664 100644 (file)
@@ -170,6 +170,7 @@ ath79_setup_interfaces()
        comfast,cf-e120a-v3|\
        comfast,cf-e314n-v2|\
        compex,wpj531-16m|\
+       openmesh,a40|\
        openmesh,a60|\
        openmesh,om2p-v4|\
        openmesh,om2p-hs-v4|\
index 1402c5529af1972157e2a9fa4b9a20cb3a4e79d5..a7986a98ecb6f4287dec4f9ea47811d51fb8a46b 100644 (file)
@@ -98,6 +98,7 @@ case "$FIRMWARE" in
                caldata_extract "art" 0x5000 0x844
                ath10k_patch_mac $(mtd_get_mac_binary art 0xc)
                ;;
+       openmesh,a40|\
        openmesh,a60|\
        openmesh,mr1750-v1|\
        openmesh,mr1750-v2)
index 9b6a0cf9bcc29d155661cd7b4de91ec03627344b..20041e4c95619a4938d19402b3ffb1d4de76a27c 100644 (file)
@@ -65,6 +65,7 @@ platform_do_upgrade() {
        jjplus,ja76pf2)
                redboot_fis_do_upgrade "$1" linux
                ;;
+       openmesh,a40|\
        openmesh,a60|\
        openmesh,mr600-v1|\
        openmesh,mr600-v2|\
index 7c26f5dc1f09d7ff64027f9f71b045a6bb16edd0..86aae57266e1ff9c5f557c746efd99b2973027d4 100644 (file)
@@ -1628,6 +1628,16 @@ define Device/openmesh_common_256k
        openmesh-image ce_type=$$$$(OPENMESH_CE_TYPE) | append-metadata
 endef
 
+define Device/openmesh_a40
+  $(Device/openmesh_common_64k)
+  SOC := qca9558
+  DEVICE_MODEL := A40
+  DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct kmod-usb2
+  OPENMESH_CE_TYPE := A60
+  SUPPORTED_DEVICES += a40
+endef
+TARGET_DEVICES += openmesh_a40
+
 define Device/openmesh_a60
   $(Device/openmesh_common_64k)
   SOC := qca9558