ath79: move ubnt-xm 64M RAM boards back to generic
authorFelix Baumann <felix.bau@gmx.de>
Mon, 3 Jul 2023 23:35:43 +0000 (01:35 +0200)
committerNick Hainke <vincent@systemli.org>
Wed, 19 Jul 2023 06:04:08 +0000 (08:04 +0200)
return ubnt_rocket-m and ubnt_powerbridge-m back to ath79-generic
They have enough RAM-ressources to not be considered as tiny.

This reverts the commit f4415f7635164ec07ddc22f56df93555804b5767 partially

Signed-off-by: Felix Baumann <felix.bau@gmx.de>
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/image/generic-ubnt.mk
target/linux/ath79/image/tiny-ubnt.mk
target/linux/ath79/tiny/base-files/etc/board.d/01_leds
target/linux/ath79/tiny/base-files/etc/board.d/02_network
target/linux/ath79/tiny/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom

index 00bcad2bc50bd5f9cbca5b4aceaf2abafa21ad17..4ee347c14157e22ba7b59d0c1fd9d263fd0783a8 100644 (file)
@@ -497,7 +497,9 @@ ubnt,bullet-m-xw|\
 ubnt,nanostation-loco-m-xw|\
 ubnt,nanostation-m-xw|\
 ubnt,powerbeam-m2-xw|\
-ubnt,powerbeam-m5-xw)
+ubnt,powerbeam-m5-xw|\
+ubnt,powerbridge-m|\
+ubnt,rocket-m)
        ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "red:link1" "wlan0" "1" "100"
        ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "orange:link2" "wlan0" "26" "100"
index ddcb69f68c91469b4063f3594457f8c4c47dfde5..1b19d90a05ea4e7b4fb496e6ae1585867c7a294b 100644 (file)
@@ -111,7 +111,9 @@ ath79_setup_interfaces()
        ubnt,powerbeam-5ac-gen2|\
        ubnt,powerbeam-m2-xw|\
        ubnt,powerbeam-m5-xw|\
+       ubnt,powerbridge-m|\
        ubnt,rocket-5ac-lite|\
+       ubnt,rocket-m|\
        ubnt,unifiac-lite|\
        ubnt,unifiac-lr|\
        ubnt,unifiac-mesh|\
@@ -804,6 +806,8 @@ ath79_setup_macs()
                wan_mac=$(mtd_get_mac_text mac 0x18)
                label_mac=$wan_mac
                ;;
+       ubnt,powerbridge-m|\
+       ubnt,rocket-m|\
        ubnt,unifi)
                label_mac=$(cat /sys/class/ieee80211/phy0/macaddress)
                ;;
index 3b089885b31414d28cb9a102f0092393a30b66c2..e5f4870e6fdab6468c8196998830a77a6f708bc7 100644 (file)
@@ -113,6 +113,10 @@ case "$FIRMWARE" in
        tplink,tl-wr842n-v1)
                caldata_extract "art" 0x1000 0x3e0
                ;;
+       ubnt,powerbridge-m|\
+       ubnt,rocket-m)
+               caldata_extract "art" 0x1000 0x1000
+               ;;
        wd,mynet-n600|\
        wd,mynet-n750)
                caldata_extract "art" 0x5000 0x440
index 0f70649d0315035493d95cf0e14b8da17a2dd13d..fa4daa3aaafd2887096a18bc254d56165d9346a8 100644 (file)
@@ -158,6 +158,15 @@ define Device/ubnt_powerbeam-m5-xw
 endef
 TARGET_DEVICES += ubnt_powerbeam-m5-xw
 
+define Device/ubnt_powerbridge-m
+  $(Device/ubnt-xm)
+  SOC := ar7241
+  DEVICE_MODEL := PowerBridge M
+  DEVICE_PACKAGES += rssileds
+  SUPPORTED_DEVICES += bullet-m
+endef
+TARGET_DEVICES += ubnt_powerbridge-m
+
 define Device/ubnt_rocket-5ac-lite
   $(Device/ubnt-xc)
   SOC := qca9558
@@ -167,6 +176,15 @@ define Device/ubnt_rocket-5ac-lite
 endef
 TARGET_DEVICES += ubnt_rocket-5ac-lite
 
+define Device/ubnt_rocket-m
+  $(Device/ubnt-xm)
+  SOC := ar7241
+  DEVICE_MODEL := Rocket M
+  DEVICE_PACKAGES += rssileds
+  SUPPORTED_DEVICES += rocket-m
+endef
+TARGET_DEVICES += ubnt_rocket-m
+
 define Device/ubnt_routerstation_common
   DEVICE_PACKAGES := -kmod-ath9k -wpad-basic-mbedtls -uboot-envtools kmod-usb-ohci \
        kmod-usb2 fconfig
index 07333714418f2a8ff6a65536c19473062816eb84..77940ed875ab74f0a64010098fbccab6261c15de 100644 (file)
@@ -70,21 +70,3 @@ define Device/ubnt_nanostation-loco-m
   DEFAULT := n
 endef
 TARGET_DEVICES += ubnt_nanostation-loco-m
-
-define Device/ubnt_powerbridge-m
-  $(Device/ubnt-xm)
-  SOC := ar7241
-  DEVICE_MODEL := PowerBridge M
-  DEVICE_PACKAGES += rssileds
-  SUPPORTED_DEVICES += bullet-m
-endef
-TARGET_DEVICES += ubnt_powerbridge-m
-
-define Device/ubnt_rocket-m
-  $(Device/ubnt-xm)
-  SOC := ar7241
-  DEVICE_MODEL := Rocket M
-  DEVICE_PACKAGES += rssileds
-  SUPPORTED_DEVICES += rocket-m
-endef
-TARGET_DEVICES += ubnt_rocket-m
index 92c4499580fbea4be04d33b1fb4acea5a51c7be4..07e48ec49f3800df1c0fdc7fbdfbe958ee93dacf 100644 (file)
@@ -116,9 +116,7 @@ ubnt,bullet-m-ar7241|\
 ubnt,nanobridge-m|\
 ubnt,nanostation-loco-m|\
 ubnt,nanostation-m|\
-ubnt,picostation-m|\
-ubnt,powerbridge-m|\
-ubnt,rocket-m)
+ubnt,picostation-m)
        ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "red:link1" "wlan0" "1" "100"
        ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "orange:link2" "wlan0" "26" "100"
index 4f6e2918a45c330116dcb854a3bc94eeed62a93c..836d119867fb98c05be25addd88c4307174c6a21 100644 (file)
@@ -54,9 +54,7 @@ ath79_setup_interfaces()
        ubnt,bullet-m-ar7241|\
        ubnt,nanobridge-m|\
        ubnt,picostation-m|\
-       ubnt,nanostation-loco-m|\
-       ubnt,powerbridge-m|\
-       ubnt,rocket-m)
+       ubnt,nanostation-loco-m)
                ucidef_set_interface_lan "eth0"
                ;;
        engenius,enh202-v1)
@@ -135,9 +133,7 @@ ath79_setup_macs()
        ubnt,nanobridge-m|\
        ubnt,nanostation-loco-m|\
        ubnt,nanostation-m|\
-       ubnt,picostation-m|\
-       ubnt,powerbridge-m|\
-       ubnt,rocket-m)
+       ubnt,picostation-m)
                label_mac=$(cat /sys/class/ieee80211/phy0/macaddress)
                ;;
        tplink,tl-wr941-v2|\
index 792c503ab7dd813e57bf9d8c9e7d184504a6dc3f..d424b9fe2ca80c96fdd4e1781733488021d82b61 100644 (file)
@@ -43,9 +43,7 @@ case "$FIRMWARE" in
        ubnt,nanobridge-m|\
        ubnt,nanostation-loco-m|\
        ubnt,nanostation-m|\
-       ubnt,picostation-m|\
-       ubnt,powerbridge-m|\
-       ubnt,rocket-m)
+       ubnt,picostation-m)
                caldata_extract "art" 0x1000 0x1000
                ;;
        pqi,air-pen)