ramips: add support for D-Link DRA-1360
authorRani Hod <rani.hod@gmail.com>
Mon, 24 Apr 2023 22:26:28 +0000 (01:26 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 27 Aug 2023 17:13:36 +0000 (19:13 +0200)
The DRA-1360 rev A is a wall-plug AC1300 repeater.
Hardware is identical (same FCC ID, black case instead of white)
to D-Link DAP-1620 rev B, which is already supported, but a
different model name, revision, and hardware ID are needed.
Thus, the bulk of the DAP-1620 device tree is extracted to a
common dtsi included by the two models' device trees.

Repeating specs and installation instructions from e4c7703:
(note that the RAM size mentioned there was incorrect, oops)

Specs:
- SoC: MT7621AT (880MHz dual-core MIPS1004Kc)
- Memory: 128 MiB RAM, 16 MiB NOR SPI
- WiFi: MT7615DN 2x2 802.11n + 2x2 802.11ac (DBDC)
- Ethernet: 1 RJ45 port 10/100/1000
- Power/status LED: red+green
- LED RSSI bargraph: 2x green, 1x red+green

Installation:
- Keep reset button pressed during plug-in
- Web Recovery Updater is at 192.168.0.50
  (pings are ignored, it listens only for http)
- Upload factory.bin, confirm flashing
  (seems to work best with Chromium-based browsers)

Revert to OEM firmware:
- tail -c+117 DRA1360A1_FW112B03.bin | \
  openssl aes-256-cbc -d -md md5 -out decrypted.bin \
  -k c471706398cb147c6619f8a04a18d53e9c17ede8
- flash decrypted.bin via D-Link Web Recovery

Signed-off-by: Rani Hod <rani.hod@gmail.com>
target/linux/ramips/dts/mt7621_dlink_dap-1620-b1.dts
target/linux/ramips/dts/mt7621_dlink_dra-1360-a1.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7621_dlink_dxx-1xx0-x1.dtsi [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
target/linux/ramips/mt7621/base-files/etc/board.d/02_network
target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac

index 919e5be4b9cc73e7cd372fa58c9ad98bc01379a8..5005eb1a724d115ebabeab2f112bd27d5e2f1199 100644 (file)
@@ -1,158 +1,8 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
+#include "mt7621_dlink_dxx-1xx0-x1.dtsi"
 
 / {
        compatible = "dlink,dap-1620-b1", "mediatek,mt7621-soc";
        model = "D-Link DAP-1620 B1";
-
-       aliases {
-               label-mac-device = &gmac0;
-
-               led-boot = &led_status_red;
-               led-failsafe = &led_status_green;
-               led-running = &led_status_green;
-               led-upgrade = &led_status_red;
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-                       debounce-interval = <60>;
-               };
-
-               wps {
-                       label = "wps";
-                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_WPS_BUTTON>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led_status_red: status_red {
-                       label = "red:status";
-                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
-               };
-
-               led_status_green: status_green {
-                       label = "green:status";
-                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
-               };
-
-               rssi_low_red {
-                       label = "red:rssilow";
-                       gpios = <&gpio 25 GPIO_ACTIVE_LOW>;
-               };
-
-               rssi_low_green {
-                       label = "green:rssilow";
-                       gpios = <&gpio 24 GPIO_ACTIVE_LOW>;
-               };
-
-               rssi_med_green {
-                       label = "green:rssimed";
-                       gpios = <&gpio 23 GPIO_ACTIVE_LOW>;
-               };
-
-               rssi_high_green {
-                       label = "green:rssihigh";
-                       gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
-               };
-       };
-};
-
-&spi0 {
-       status = "okay";
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <50000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x0 0x30000>;
-                               read-only;
-                       };
-
-                       partition@30000 {
-                               label = "u-boot-env";
-                               reg = <0x30000 0x10000>;
-                               read-only;
-                       };
-
-                       factory: partition@40000 {
-                               label = "factory";
-                               reg = <0x40000 0x10000>;
-                               read-only;
-
-                               compatible = "nvmem-cells";
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-
-                               macaddr_factory_e000: macaddr@e000 {
-                                       reg = <0xe000 0x6>;
-                               };
-                       };
-
-                       partition@50000 {
-                               compatible = "denx,uimage";
-                               label = "firmware";
-                               reg = <0x50000 0xfb0000>;
-                       };
-               };
-       };
-};
-
-&pcie {
-       status = "okay";
-};
-
-&pcie0 {
-       wifi@0,0 {
-               compatible = "mediatek,mt76";
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x0>;
-               /* The correct MAC addresses are set in 10_fix_wifi_mac. */
-       };
 };
-
-&gmac0 {
-       nvmem-cells = <&macaddr_factory_e000>;
-       nvmem-cell-names = "mac-address";
-};
-
-&switch0 {
-       ports {
-               port@0 {
-                       status = "okay";
-                       label = "lan";
-               };
-       };
-};
-
-&ethernet {
-       pinctrl-0 = <&mdio_pins>, <&rgmii1_pins>;
-};
-
-&state_default {
-       gpio {
-               groups = "uart3", "jtag", "wdt";
-               function = "gpio";
-       };
-};
-
diff --git a/target/linux/ramips/dts/mt7621_dlink_dra-1360-a1.dts b/target/linux/ramips/dts/mt7621_dlink_dra-1360-a1.dts
new file mode 100644 (file)
index 0000000..294093b
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_dlink_dxx-1xx0-x1.dtsi"
+
+/ {
+       compatible = "dlink,dra-1360-a1", "mediatek,mt7621-soc";
+       model = "D-Link DRA-1360 A1";
+};
diff --git a/target/linux/ramips/dts/mt7621_dlink_dxx-1xx0-x1.dtsi b/target/linux/ramips/dts/mt7621_dlink_dxx-1xx0-x1.dtsi
new file mode 100644 (file)
index 0000000..8fb6de7
--- /dev/null
@@ -0,0 +1,154 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       aliases {
+               label-mac-device = &gmac0;
+
+               led-boot = &led_status_red;
+               led-failsafe = &led_status_green;
+               led-running = &led_status_green;
+               led-upgrade = &led_status_red;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+                       debounce-interval = <60>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status_red: status_red {
+                       label = "red:status";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+
+               led_status_green: status_green {
+                       label = "green:status";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+               };
+
+               rssi_low_red {
+                       label = "red:rssilow";
+                       gpios = <&gpio 25 GPIO_ACTIVE_LOW>;
+               };
+
+               rssi_low_green {
+                       label = "green:rssilow";
+                       gpios = <&gpio 24 GPIO_ACTIVE_LOW>;
+               };
+
+               rssi_med_green {
+                       label = "green:rssimed";
+                       gpios = <&gpio 23 GPIO_ACTIVE_LOW>;
+               };
+
+               rssi_high_green {
+                       label = "green:rssihigh";
+                       gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <50000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+
+                               compatible = "nvmem-cells";
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               macaddr_factory_e000: macaddr@e000 {
+                                       reg = <0xe000 0x6>;
+                               };
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x50000 0xfb0000>;
+                       };
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0>;
+               /* The correct MAC addresses are set in 10_fix_wifi_mac. */
+       };
+};
+
+&gmac0 {
+       nvmem-cells = <&macaddr_factory_e000>;
+       nvmem-cell-names = "mac-address";
+};
+
+&switch0 {
+       ports {
+               port@0 {
+                       status = "okay";
+                       label = "lan";
+               };
+       };
+};
+
+&ethernet {
+       pinctrl-0 = <&mdio_pins>, <&rgmii1_pins>;
+};
+
+&state_default {
+       gpio {
+               groups = "uart3", "jtag", "wdt";
+               function = "gpio";
+       };
+};
index ad45613a0b4fb1cbf5dc531af8793b617f99f8dd..338cbae5b6a382087a14af21384f65d61d12c80c 100644 (file)
@@ -614,12 +614,9 @@ define Device/cudy_x6-v2
 endef
 TARGET_DEVICES += cudy_x6-v2
 
-define Device/dlink_dap-1620-b1
+define Device/dlink_dxx-1xx0-x1
   DEVICE_VENDOR := D-Link
-  DEVICE_MODEL := DAP-1620
-  DEVICE_VARIANT := B1
   DEVICE_PACKAGES := kmod-mt7615-firmware rssileds
-  DLINK_HWID := MT76XMT7621-RP-PR2475-NA
   IMAGE_SIZE := 16064k
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | \
@@ -628,6 +625,13 @@ define Device/dlink_dap-1620-b1
     append-string $$(DLINK_HWID) | \
     check-size
 endef
+
+define Device/dlink_dap-1620-b1
+  $(Device/dlink_dxx-1xx0-x1)
+  DEVICE_MODEL := DAP-1620
+  DEVICE_VARIANT := B1
+  DLINK_HWID := MT76XMT7621-RP-PR2475-NA
+endef
 TARGET_DEVICES += dlink_dap-1620-b1
 
 define Device/dlink_dap-x1860-a1
@@ -799,6 +803,14 @@ define Device/dlink_dir-882-r1
 endef
 TARGET_DEVICES += dlink_dir-882-r1
 
+define Device/dlink_dra-1360-a1
+  $(Device/dlink_dxx-1xx0-x1)
+  DEVICE_MODEL := DRA-1360
+  DEVICE_VARIANT := A1
+  DLINK_HWID := MT76XMT7621-RP-RA1360-NA
+endef
+TARGET_DEVICES += dlink_dra-1360-a1
+
 define Device/dual-q_h721
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)
index 1de35104c325ad64124c6ccf7a0076032adb4ac8..1e13c04c2f20896814a9f2be79bafdc535925ed8 100644 (file)
@@ -69,7 +69,8 @@ jcg,y2|\
 xzwifi,creativebox-v1)
        ucidef_set_led_netdev "internet" "internet" "blue:internet" "wan"
        ;;
-dlink,dap-1620-b1)
+dlink,dap-1620-b1|\
+dlink,dra-1360-a1)
        ucidef_set_rssimon "wlan1" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "red:rssilow" "wlan1" "1" "40"
        ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "green:rssilow" "wlan1" "21" "100"
index bd4cb508126ac6a1e43ce168ed4b9ceba57a5ede..7bd5e83c5a148e9316a23cdbdff1322fa1c47db8 100644 (file)
@@ -16,6 +16,7 @@ ramips_setup_interfaces()
        asus,rp-ac87|\
        dlink,dap-1620-b1|\
        dlink,dap-x1860-a1|\
+       dlink,dra-1360-a1|\
        edimax,re23s|\
        linksys,re7000|\
        mikrotik,ltap-2hnd|\
index a15b4a225f255a2d46c3d9efc8614a659985f637..96b49ff00ae8b2f9b97d3a5ce632d0580e2a7dc7 100644 (file)
@@ -38,7 +38,8 @@ case "$board" in
                macaddr_setbit_la "$(macaddr_add $hw_mac_addr 0x100000)" > /sys${DEVPATH}/macaddress
                ;;
        dlink,dap-1620-b1|\
-       dlink,dir-853-a1)
+       dlink,dir-853-a1|\
+       dlink,dra-1360-a1)
                lan_mac_addr="$(mtd_get_mac_binary factory 0xe000)"
                [ "$PHYNBR" = "0" ] && \
                        macaddr_add $lan_mac_addr 1 > /sys${DEVPATH}/macaddress