build: fix warnings from grep
authorChris Osgood <chris_github@functionalfuture.com>
Thu, 15 Sep 2022 12:09:38 +0000 (08:09 -0400)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 28 Sep 2022 15:17:48 +0000 (17:17 +0200)
Fixes build warnings when using newer versions of grep.

Signed-off-by: Chris Osgood <chris_github@functionalfuture.com>
Tested-by: Georgi Valkov <gvalkov@gmail.com>
target/sdk/files/Makefile

index f620f0ef01260504753e3c664b9c0a3afc8ab66b..dca8bbe20e78f7d7cf9f4e2c51b81d008e5d706b 100644 (file)
@@ -14,7 +14,7 @@ export TOPDIR LC_ALL LANG SDK
 
 world:
 
-DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep -E '\/usr' -m 1)
+DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep '/usr' -m 1)
 export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
 
 ifneq ($(OPENWRT_BUILD),1)