kernel: add missing kmod+regmap-i2c dependency for NCT7802Y module
authorChristian Lamparter <chunkeey@gmail.com>
Sat, 15 Jan 2022 18:38:33 +0000 (19:38 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 15 Jan 2022 18:55:14 +0000 (19:55 +0100)
x86, mt7623 and others buildbot failed due to:
|Package kmod-hwmon-nct7802 is missing dependencies for the following libraries:
|regmap-core.ko
|regmap-i2c.ko

Fixes: 1ed50b92d157 ("package: kernel: add driver module for NCT7802Y")
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/kernel/linux/modules/hwmon.mk

index 01a510e5715cdaf48ea9e8ff9e2110f59fdb1d13..943b87cd4ce3206aa998df047d5350efd98e469f 100644 (file)
@@ -353,7 +353,7 @@ define KernelPackage/hwmon-nct7802
   KCONFIG:=CONFIG_SENSORS_NCT7802
   FILES:=$(LINUX_DIR)/drivers/hwmon/nct7802.ko
   AUTOLOAD:=$(call AutoProbe,nct7802)
-  $(call AddDepends/hwmon,+kmod-i2c-core)
+  $(call AddDepends/hwmon,+kmod-regmap-i2c)
 endef
 
 define KernelPackage/hwmon-nct7802/description