e2fsprogs: do not symlink tune2fs to findfs
authorMartin Schiller <ms@dev.tdt.de>
Fri, 7 Jul 2023 11:29:45 +0000 (13:29 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 8 Jul 2023 14:51:17 +0000 (16:51 +0200)
commit c0611b45a998 ("e2fsprogs: symlink e2fsck to fsck.ext{2, 3, 4},
and tune2fs to findfs") introduced a symlink from tune2fs to findfs.

This only works when the included private libblkid library is used, but
commit 5b1660a5387b ("utils/e2fsprogs: Update to 1.43.6") disabled the
usage of this private lib and enabled the shared lib support.

Removing this symlink makes it possible to install tune2fs and findfs
package.

Signed-off-by: Martin Schiller <ms@dev.tdt.de>
package/utils/e2fsprogs/Makefile

index 42c297152941e38bd5f7f09568abbcf66dfb7ad8..2657077a16be29958cbc632564f6d97a9b9b5a26 100644 (file)
@@ -267,7 +267,6 @@ endef
 define Package/tune2fs/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tune2fs $(1)/usr/sbin/
-       $(LN) tune2fs $(1)/usr/sbin/findfs
 endef
 
 define Package/resize2fs/install