ath10k-ct: update to version from 2021-09-22
authorAndrew Robbins <andrew@robbinsa.me>
Tue, 5 Oct 2021 15:00:16 +0000 (11:00 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 20 Oct 2021 22:17:36 +0000 (00:17 +0200)
Add in a fix for 160Mhz dfs on 5.10 and higher.
Add support for 5.13 and 5.15 kernels.
Add of_get_mac_address support for 5.15 driver.

Signed-off-by: Andrew Robbins <andrew@robbinsa.me>
package/kernel/ath10k-ct/Makefile
package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
package/kernel/ath10k-ct/patches/203-ath10k-Try-to-get-mac-address-from-dts.patch

index 5681c5c2cdc4d42c892c5d58b556967d3dd988f9..25ea3376f06ccad5f72060a617ea0e52c7894a07 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2021-06-03
-PKG_SOURCE_VERSION:=b44cd7b2e7b0df5995ece18f358d4dfc40834ba1
-PKG_MIRROR_HASH:=59f961ad425eb1a48fa9c391a325cc0f23845daec9d12673445d3077f9756cf0
+PKG_SOURCE_DATE:=2021-09-22
+PKG_SOURCE_VERSION:=e6a7d5b5b834737cd12e357b5efdc2e42d923bf6
+PKG_MIRROR_HASH:=62a1b97089d3561730656ef73beb3cd77231ec636645115cc1bbb3c6c84a6fe3
 
 # Build the 5.10 ath10k-ct driver version.
 # Probably this should match as closely as
index 6205c9b6614ebba73abd8be7da885ae4e722363a..168c6ab462a587f9a0b06cd020f9d293f01ff202 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
        if (ret)
 --- a/ath10k-5.10/mac.c
 +++ b/ath10k-5.10/mac.c
-@@ -11403,7 +11403,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -11405,7 +11405,7 @@ int ath10k_mac_register(struct ath10k *a
        ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;
  
  #ifdef CPTCFG_MAC80211_LEDS
index 3b5d9d45ac9802ce697d3b05dd0ea502fe85a711..8fcdaf8c0f9a2e93fcbcafb4138949f69f95d9b8 100644 (file)
@@ -16,8 +16,6 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
  ath10k-5.10/core.c | 10 ++++++++++
  1 file changed, 10 insertions(+)
 
-diff --git a/ath10k-5.10/core.c b/ath10k-5.10/core.c
-index 5f4e12196..9ed7b9883 100644
 --- a/ath10k-5.10/core.c
 +++ b/ath10k-5.10/core.c
 @@ -8,6 +8,7 @@
@@ -28,7 +26,7 @@ index 5f4e12196..9ed7b9883 100644
  #include <linux/property.h>
  #include <linux/dmi.h>
  #include <linux/ctype.h>
-@@ -3062,6 +3068,8 @@ static int ath10k_core_probe_fw(struct ath10k *ar)
+@@ -3881,6 +3882,8 @@ static int ath10k_core_probe_fw(struct a
  
        device_get_mac_address(ar->dev, ar->mac_addr, sizeof(ar->mac_addr));
  
@@ -37,6 +35,3 @@ index 5f4e12196..9ed7b9883 100644
        ret = ath10k_core_init_firmware_features(ar);
        if (ret) {
                ath10k_err(ar, "fatal problem with firmware features: %d\n",
--- 
-2.27.0
-