ramips: sunvalley - allow larger sysupgrade
authorRussell Morris <rmorris@rkmorris.us>
Fri, 30 Jul 2021 03:19:45 +0000 (22:19 -0500)
committerChuanhong Guo <gch981213@gmail.com>
Tue, 20 Jun 2023 13:23:58 +0000 (21:23 +0800)
Aligned to size of mtd-concat partition (firmware)
  - in this device we have mtd-concat driver that joins multiple flash partitions
  - since sysupgrade works with mtd devices the rootfs partition is already joined
  - we can use a bigger sysupgrade image than factory/TFTP install images
Checked on hardware, no issues seen.
No modifications to images other than sysupgrade (i.e. TFTP / recovery images not touched).

Signed-off-by: Russell Morris <rmorris@rkmorris.us>
target/linux/ramips/image/mt7620.mk

index 7c2ff740f057262ab73a655a00e5726fd22d6a80..bb06e0d6c82ddd04f7ffbae296c09eb45e4ae58f 100644 (file)
@@ -592,6 +592,8 @@ define Device/sunvalley_filehub_common
   IMAGES += kernel.bin rootfs.bin
   IMAGE/kernel.bin := append-loader-okli $(1) | check-size 64k
   IMAGE/rootfs.bin := $$(sysupgrade_bin) | check-size
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
+       check-size 7744k | append-metadata
 endef
 
 define Device/hootoo_ht-tm05