kernel: insmod phy-broadcom module during preinit
authorSteffen Förster <steffen@chemnitz.freifunk.net>
Sun, 8 Jul 2018 20:18:07 +0000 (22:18 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 16 Jul 2018 13:12:18 +0000 (15:12 +0200)
Some HP Thin clients use the broadcom nextreme chip as integrated NIC.
It is connected via PCI express and will only be found automatically if
phy-broadcom is loaded before tg3. This small change makes the thin
client usable for Freifunk with gluon out of the box.

Signed-off-by: Steffen Förster <steffen@chemnitz.freifunk.net>
package/kernel/linux/modules/netdevices.mk

index 647b1894febc43128bd1c6ab90052ec232701b8f..6d05d6fcd0534b19bb478d9ac8aff444d275b7bb 100644 (file)
@@ -169,7 +169,7 @@ define KernelPackage/phy-broadcom
    KCONFIG:=CONFIG_BROADCOM_PHY
    DEPENDS:=+kmod-libphy +kmod-phylib-broadcom
    FILES:=$(LINUX_DIR)/drivers/net/phy/broadcom.ko
-   AUTOLOAD:=$(call AutoLoad,18,broadcom)
+   AUTOLOAD:=$(call AutoLoad,18,broadcom,1)
 endef
 
 define KernelPackage/phy-broadcom/description