dnsmasq: install /etc/hotplug.d/ntp/25-dnsmasqsec world-readable
authorDaniel Golle <daniel@makrotopia.org>
Wed, 28 Oct 2020 01:56:16 +0000 (01:56 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 28 Oct 2020 02:01:04 +0000 (02:01 +0000)
/etc/hotplug.d/ntp/25-dnsmasqsec is being sourced by /sbin/hotplug-call
running as ntpd user. For that to work the file needs to be readable by
that user.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/network/services/dnsmasq/Makefile

index 57f6f0cef971652964ddc3ab1ee72dc319162cf3..cbbbad7b87f7b505eb6405ec4a4f0511d6353832 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=dnsmasq
 PKG_UPSTREAM_VERSION:=2.82
 PKG_VERSION:=$(subst test,~~test,$(subst rc,~rc,$(PKG_UPSTREAM_VERSION)))
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_UPSTREAM_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
@@ -172,7 +172,7 @@ define Package/dnsmasq/install
        $(INSTALL_DIR) $(1)/etc/hotplug.d/neigh
        $(INSTALL_DIR) $(1)/etc/hotplug.d/ntp
        $(INSTALL_DIR) $(1)/etc/hotplug.d/tftp
-       $(INSTALL_CONF) ./files/dnsmasqsec.hotplug $(1)/etc/hotplug.d/ntp/25-dnsmasqsec
+       $(INSTALL_DATA) ./files/dnsmasqsec.hotplug $(1)/etc/hotplug.d/ntp/25-dnsmasqsec
        $(INSTALL_DIR) $(1)/usr/share/dnsmasq
        $(INSTALL_CONF) ./files/dhcpbogushostname.conf $(1)/usr/share/dnsmasq/
        $(INSTALL_CONF) ./files/rfc6761.conf $(1)/usr/share/dnsmasq/