kernel: add kmod-hwmon-lm70 support
authorChristian Lamparter <chunkeey@gmail.com>
Thu, 17 Feb 2022 15:10:42 +0000 (16:10 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 19 Feb 2022 18:34:18 +0000 (19:34 +0100)
package hwmon's lm70.ko. This module supports the
National Semiconductor/TI LM70,LM71,LM74 and
TI TMP121,TMP122,TMP123 and TMP124 chips (all SPI).

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/kernel/linux/modules/hwmon.mk

index 943b87cd4ce3206aa998df047d5350efd98e469f..b75c741ba0a2f35efec0a1dc2851846c65f5f95a 100644 (file)
@@ -213,6 +213,23 @@ endef
 $(eval $(call KernelPackage,hwmon-lm63))
 
 
+define KernelPackage/hwmon-lm70
+  TITLE:=LM70 monitoring support
+  KCONFIG:=CONFIG_SENSORS_LM70 \
+        CONFIG_SPI=y \
+        CONFIG_SPI_MASTER=y
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm70.ko
+  AUTOLOAD:=$(call AutoProbe,lm70)
+  $(call AddDepends/hwmon)
+endef
+
+define KernelPackage/hwmon-lm70/description
+ Kernel module for lm70 and compatible thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm70))
+
+
 define KernelPackage/hwmon-lm75
   TITLE:=LM75 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM75