kernel: bump 5.4 to 5.4.93
authorJohn Audia <graysky@archlinux.us>
Wed, 27 Jan 2021 14:41:12 +0000 (09:41 -0500)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 29 Jan 2021 13:22:09 +0000 (14:22 +0100)
All modification made by update_kernel.sh in a fresh clone without
existing toolchains.

Build system:       x86_64
Build-tested:       ipq806x/R7800, bcm27xx/bcm2711
Run-tested:         ipq806x/R7800
Compile-tested [*]: ath79/{tiny,generic}, ipq40xx, octeon,
                    ramips/mt7621, realtek, x86/64
Run-tested [*]:     ath79/generic, ipq40xx, octeon, ramips/mt7621

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
Tested-by: Stijn Segers <foss@volatilesystems.org> [*]
29 files changed:
include/kernel-version.mk
target/linux/ath79/patches-5.4/910-unaligned_access_hacks.patch
target/linux/bcm27xx/patches-5.4/950-0283-hid-usb-Add-device-quirks-for-Freeway-Airmouse-T3-an.patch
target/linux/bcm63xx/patches-5.4/206-USB-EHCI-allow-limiting-ports-for-ehci-platform.patch
target/linux/generic/hack-5.4/661-use_fq_codel_by_default.patch
target/linux/generic/hack-5.4/721-phy_packets.patch
target/linux/generic/pending-5.4/110-ehci_hcd_ignore_oc.patch
target/linux/generic/pending-5.4/690-net-add-support-for-threaded-NAPI-polling.patch
target/linux/layerscape/patches-5.4/303-core-0001-net-readd-skb_recycle.patch
target/linux/layerscape/patches-5.4/303-core-0002-drivers-base-add-sysfs-entries-for-suppliers-and-con.patch
target/linux/layerscape/patches-5.4/701-net-0238-net-mscc-ocelot-break-apart-ocelot_vlan_port_apply.patch
target/linux/layerscape/patches-5.4/701-net-0243-net-mscc-ocelot-refactor-struct-ocelot_port-out-of-f.patch
target/linux/layerscape/patches-5.4/701-net-0244-net-mscc-ocelot-separate-net_device-related-items-ou.patch
target/linux/layerscape/patches-5.4/701-net-0247-net-mscc-ocelot-move-port-initialization-into-separa.patch
target/linux/layerscape/patches-5.4/701-net-0249-net-mscc-ocelot-initialize-list-of-multicast-address.patch
target/linux/layerscape/patches-5.4/701-net-0251-net-mscc-ocelot-split-assignment-of-the-cpu-port-int.patch
target/linux/layerscape/patches-5.4/701-net-0255-net-mscc-ocelot-move-invariant-configs-out-of-adjust.patch
target/linux/layerscape/patches-5.4/701-net-0256-net-mscc-ocelot-create-a-helper-for-changing-the-por.patch
target/linux/layerscape/patches-5.4/701-net-0258-net-mscc-ocelot-adjust-MTU-on-the-CPU-port-in-NPI-mo.patch
target/linux/layerscape/patches-5.4/701-net-0259-net-mscc-ocelot-separate-the-implementation-of-switc.patch
target/linux/layerscape/patches-5.4/701-net-0260-net-mscc-ocelot-publish-structure-definitions-to-inc.patch
target/linux/layerscape/patches-5.4/701-net-0271-net-mscc-ocelot-use-skb-queue-instead-of-skbs-list.patch
target/linux/layerscape/patches-5.4/701-net-0272-net-mscc-ocelot-tsn-configuration-support.patch
target/linux/layerscape/patches-5.4/701-net-0341-LF-368-net-mscc-ocelot-add-VCAP-IS2-rule-to-trap-PTP.patch
target/linux/layerscape/patches-5.4/701-net-0367-net-mscc-ocelot-Workaround-to-allow-traffic-to-CPU-i.patch
target/linux/layerscape/patches-5.4/820-usb-0014-MLK-17380-3-usb-move-EH-SINGLE_STEP_SET_FEATURE-impl.patch
target/linux/layerscape/patches-5.4/820-usb-0015-MLK-17380-4-usb-host-xhci-add-EH-SINGLE_STEP_SET_FEA.patch
target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch
target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch

index 4a61601ce5819837dce2827e53bb8ab5fb4f7765..06860bc0e990e972fa19454f61ffac35646b1378 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .92
+LINUX_VERSION-5.4 = .93
 
-LINUX_KERNEL_HASH-5.4.92 = c0937ff98824c4b14cfea68a04340e0beb3c00f1cc02984daf2f3bdf542394fd
+LINUX_KERNEL_HASH-5.4.93 = d37449403664cc3b1bac96d0d9a199dbe619885cd899c0ae3108843f42e3d522
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 923eac92f84f50b3b2f24f2675a0df7c040bfd6b..dfc16a7ba119077b65d6bde76abe1c1562357615 100644 (file)
  EXPORT_SYMBOL(xfrm_parse_spi);
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3972,14 +3972,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3973,14 +3973,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
index 2f8964a82d8701d31109ccd8b1f813c9faa77de5..ee886e31a529793d1430dd31f91d3226e6adf1dd 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
  #define USB_VENDOR_ID_BELKIN          0x050d
  #define USB_DEVICE_ID_FLIP_KVM                0x3201
  
-@@ -1253,6 +1256,9 @@
+@@ -1254,6 +1257,9 @@
  #define USB_VENDOR_ID_XAT     0x2505
  #define USB_DEVICE_ID_XAT_CSR 0x0220
  
index 9159b14d3cfeaa1a3e6ec7cf050b55583d0cabe0..2fa5a002124b847e0631074f5ac4381d2f99e5de 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -666,6 +666,10 @@ int ehci_setup(struct usb_hcd *hcd)
+@@ -678,6 +678,10 @@ int ehci_setup(struct usb_hcd *hcd)
  
        /* cache this readonly data; minimize chip reads */
        ehci->hcs_params = ehci_readl(ehci, &ehci->caps->hcs_params);
index ccedf561e2962b63155bcd7d7ba9112eaf382fb7..10197eeb04f62789c82842d2708e3c072ea0f62e 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
          device, it has to decide which ones to send first, which ones to
 --- a/net/sched/sch_api.c
 +++ b/net/sched/sch_api.c
-@@ -2271,7 +2271,7 @@ static int __init pktsched_init(void)
+@@ -2272,7 +2272,7 @@ static int __init pktsched_init(void)
                return err;
        }
  
index dba648f8e654655fb5ddbf5bd72c0e17567f4336..55233369ef831a5db0ef10250396b1682f21a8cb 100644 (file)
@@ -136,7 +136,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  #include <net/protocol.h>
  #include <net/dst.h>
-@@ -545,6 +546,22 @@ skb_fail:
+@@ -549,6 +550,22 @@ skb_fail:
  }
  EXPORT_SYMBOL(__napi_alloc_skb);
  
index 55a4538f657ea561e6b80e511c56da784aa28787..ce583ceac58bd590bb0f4980bbae8d2a1f2967e9 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
 
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -639,7 +639,7 @@ static int ehci_run (struct usb_hcd *hcd
+@@ -651,7 +651,7 @@ static int ehci_run (struct usb_hcd *hcd
                "USB %x.%x started, EHCI %x.%02x%s\n",
                ((ehci->sbrn & 0xf0)>>4), (ehci->sbrn & 0x0f),
                temp >> 8, temp & 0xff,
@@ -28,7 +28,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
                    &ehci->regs->intr_enable); /* Turn On Interrupts */
 --- a/drivers/usb/host/ehci-hub.c
 +++ b/drivers/usb/host/ehci-hub.c
-@@ -640,7 +640,7 @@ ehci_hub_status_data (struct usb_hcd *hc
+@@ -643,7 +643,7 @@ ehci_hub_status_data (struct usb_hcd *hc
         * always set, seem to clear PORT_OCC and PORT_CSC when writing to
         * PORT_POWER; that's surprising, but maybe within-spec.
         */
@@ -37,7 +37,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
                mask = PORT_CSC | PORT_PEC | PORT_OCC;
        else
                mask = PORT_CSC | PORT_PEC;
-@@ -1010,7 +1010,7 @@ int ehci_hub_control(
+@@ -1013,7 +1013,7 @@ int ehci_hub_control(
                if (temp & PORT_PEC)
                        status |= USB_PORT_STAT_C_ENABLE << 16;
  
index dcb3d319d529aa41db40aeeb02b0ac856ccb814e..d80b1ecd0f43682c102b7e96dd0a09414b736850 100644 (file)
@@ -267,7 +267,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        /* Some drivers may have called napi_schedule
         * prior to exhausting their budget.
-@@ -10265,6 +10324,10 @@ static int __init net_dev_init(void)
+@@ -10270,6 +10329,10 @@ static int __init net_dev_init(void)
                sd->backlog.weight = weight_p;
        }
  
index 7b257bb17ca623ecfcb11c6fd41564c54eccdb18..e296df502ebbd426aa9fd69ade562664a3efc902 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Madalin Bucur <madalin.bucur@freescale.com>
  
 --- a/net/core/skbuff.c
 +++ b/net/core/skbuff.c
-@@ -941,6 +941,32 @@ void napi_consume_skb(struct sk_buff *sk
+@@ -945,6 +945,32 @@ void napi_consume_skb(struct sk_buff *sk
  }
  EXPORT_SYMBOL(napi_consume_skb);
  
index 6307ba839c95d5b9895fff771417430c71f57fa0..4cad5e2d136fd35a5068994d8010cbd5c5ec8bde 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Ioana Ciornei <ioana.ciornei@nxp.com>
 +              a specific device.
 --- a/drivers/base/core.c
 +++ b/drivers/base/core.c
-@@ -1318,6 +1318,34 @@ static ssize_t online_store(struct devic
+@@ -1333,6 +1333,34 @@ static ssize_t online_store(struct devic
  }
  static DEVICE_ATTR_RW(online);
  
@@ -67,7 +67,7 @@ Signed-off-by: Ioana Ciornei <ioana.ciornei@nxp.com>
  int device_add_groups(struct device *dev, const struct attribute_group **groups)
  {
        return sysfs_create_groups(&dev->kobj, groups);
-@@ -1489,8 +1517,20 @@ static int device_add_attrs(struct devic
+@@ -1504,8 +1532,20 @@ static int device_add_attrs(struct devic
                        goto err_remove_dev_groups;
        }
  
@@ -88,7 +88,7 @@ Signed-off-by: Ioana Ciornei <ioana.ciornei@nxp.com>
   err_remove_dev_groups:
        device_remove_groups(dev, dev->groups);
   err_remove_type_groups:
-@@ -1508,6 +1548,8 @@ static void device_remove_attrs(struct d
+@@ -1523,6 +1563,8 @@ static void device_remove_attrs(struct d
        struct class *class = dev->class;
        const struct device_type *type = dev->type;
  
index 42ea2851e9f440788d04f6f1358469474682596a..bb34e5db2cf5865f92aab56402d286a670f0dda1 100644 (file)
@@ -287,7 +287,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                }
                if (netif_is_lag_master(info->upper_dev)) {
                        if (info->linking)
-@@ -2011,6 +2034,7 @@ int ocelot_probe_port(struct ocelot *oce
+@@ -2009,6 +2032,7 @@ int ocelot_probe_port(struct ocelot *oce
  {
        struct ocelot_port *ocelot_port;
        struct net_device *dev;
@@ -295,7 +295,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        int err;
  
        dev = alloc_etherdev(sizeof(struct ocelot_port));
-@@ -2046,7 +2070,15 @@ int ocelot_probe_port(struct ocelot *oce
+@@ -2044,7 +2068,15 @@ int ocelot_probe_port(struct ocelot *oce
        }
  
        /* Basic L2 initialization */
index 5acd5650b151e6658fc49f41231bd7e7b0be770e..2e05090c7c29ca86ca8ed4065e218f130490eed6 100644 (file)
@@ -231,7 +231,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                                                      info->upper_dev);
                }
                break;
-@@ -2140,7 +2133,7 @@ int ocelot_probe_port(struct ocelot *oce
+@@ -2138,7 +2131,7 @@ int ocelot_probe_port(struct ocelot *oce
                       REW_PORT_VLAN_CFG, port);
  
        /* Enable vcap lookups */
index 9338120fd4cabc78ebf16b991eb4b004a9a82c7e..f582cb43cd64fa5d716d130bb03bee4a0b90d524 100644 (file)
@@ -707,7 +707,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                }
                if (netif_is_lag_master(info->upper_dev)) {
                        if (info->linking)
-@@ -2084,21 +2110,23 @@ int ocelot_probe_port(struct ocelot *oce
+@@ -2082,21 +2108,23 @@ int ocelot_probe_port(struct ocelot *oce
                      void __iomem *regs,
                      struct phy_device *phy)
  {
index 4ac275515974c936f756595579660520c7a4dd27..2df6afb20b6541c5675ddf1f1b8f708e3afb98d8 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/ethernet/mscc/ocelot.c
 +++ b/drivers/net/ethernet/mscc/ocelot.c
-@@ -2137,6 +2137,28 @@ static int ocelot_init_timestamp(struct
+@@ -2135,6 +2135,28 @@ static int ocelot_init_timestamp(struct
        return 0;
  }
  
@@ -44,7 +44,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  int ocelot_probe_port(struct ocelot *ocelot, u8 port,
                      void __iomem *regs,
                      struct phy_device *phy)
-@@ -2144,7 +2166,6 @@ int ocelot_probe_port(struct ocelot *oce
+@@ -2142,7 +2164,6 @@ int ocelot_probe_port(struct ocelot *oce
        struct ocelot_port_private *priv;
        struct ocelot_port *ocelot_port;
        struct net_device *dev;
@@ -52,7 +52,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        int err;
  
        dev = alloc_etherdev(sizeof(struct ocelot_port_private));
-@@ -2172,32 +2193,14 @@ int ocelot_probe_port(struct ocelot *oce
+@@ -2170,32 +2191,14 @@ int ocelot_probe_port(struct ocelot *oce
        ocelot_mact_learn(ocelot, PGID_CPU, dev->dev_addr, ocelot_port->pvid,
                          ENTRYTYPE_LOCKED);
  
index 5e4b4331f35fe9748797c9123f88756da3390932..ea01c8b54245f0e3e465be4b8e3f80d7085e8be0 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/ethernet/mscc/ocelot.c
 +++ b/drivers/net/ethernet/mscc/ocelot.c
-@@ -2247,6 +2247,7 @@ int ocelot_init(struct ocelot *ocelot)
+@@ -2245,6 +2245,7 @@ int ocelot_init(struct ocelot *ocelot)
        if (!ocelot->stats_queue)
                return -ENOMEM;
  
index 423db441aa822600b76310e6b7141e2ad649f5eb..4f5ab9ad5b80f974af0f7cf6a645c038502097b8 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        /* Set vlan ingress filter mask to all ports but the CPU port by
         * default.
         */
-@@ -2228,11 +2222,52 @@ int ocelot_probe_port(struct ocelot *oce
+@@ -2226,11 +2220,52 @@ int ocelot_probe_port(struct ocelot *oce
  }
  EXPORT_SYMBOL(ocelot_probe_port);
  
@@ -87,7 +87,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        ocelot->lags = devm_kcalloc(ocelot->dev, ocelot->num_phys_ports,
                                    sizeof(u32), GFP_KERNEL);
-@@ -2312,13 +2347,6 @@ int ocelot_init(struct ocelot *ocelot)
+@@ -2310,13 +2345,6 @@ int ocelot_init(struct ocelot *ocelot)
                ocelot_write_rix(ocelot, 0, ANA_PGID_PGID, PGID_SRC + port);
        }
  
@@ -101,7 +101,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        /* Allow broadcast MAC frames. */
        for (i = ocelot->num_phys_ports + 1; i < PGID_CPU; i++) {
                u32 val = ANA_PGID_PGID_PGID(GENMASK(ocelot->num_phys_ports - 1, 0));
-@@ -2331,13 +2359,6 @@ int ocelot_init(struct ocelot *ocelot)
+@@ -2329,13 +2357,6 @@ int ocelot_init(struct ocelot *ocelot)
        ocelot_write_rix(ocelot, 0, ANA_PGID_PGID, PGID_MCIPV4);
        ocelot_write_rix(ocelot, 0, ANA_PGID_PGID, PGID_MCIPV6);
  
index 454dd35b92384b24a2cad56bdb349d585942624c..8cb8a831aed9859665025bc520b74a15fe1926d3 100644 (file)
@@ -98,7 +98,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  }
  
  static void ocelot_port_adjust_link(struct net_device *dev)
-@@ -2145,11 +2104,53 @@ static int ocelot_init_timestamp(struct
+@@ -2143,11 +2102,53 @@ static int ocelot_init_timestamp(struct
  static void ocelot_init_port(struct ocelot *ocelot, int port)
  {
        struct ocelot_port *ocelot_port = ocelot->ports[port];
index 1aefe3436ff2dc18d11a34e366a5898c5a7e0320..0a1299dd384bd69c31e0a6f3c258f871558e8adb 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/ethernet/mscc/ocelot.c
 +++ b/drivers/net/ethernet/mscc/ocelot.c
-@@ -2101,11 +2101,32 @@ static int ocelot_init_timestamp(struct
+@@ -2099,11 +2099,32 @@ static int ocelot_init_timestamp(struct
        return 0;
  }
  
@@ -54,7 +54,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        INIT_LIST_HEAD(&ocelot_port->skbs);
  
        /* Basic L2 initialization */
-@@ -2126,8 +2147,7 @@ static void ocelot_init_port(struct ocel
+@@ -2124,8 +2145,7 @@ static void ocelot_init_port(struct ocel
                           DEV_MAC_HDX_CFG);
  
        /* Set Max Length and maximum tags allowed */
@@ -64,7 +64,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        ocelot_port_writel(ocelot_port, DEV_MAC_TAGS_CFG_TAG_ID(ETH_P_8021AD) |
                           DEV_MAC_TAGS_CFG_VLAN_AWR_ENA |
                           DEV_MAC_TAGS_CFG_VLAN_LEN_AWR_ENA,
-@@ -2137,20 +2157,6 @@ static void ocelot_init_port(struct ocel
+@@ -2135,20 +2155,6 @@ static void ocelot_init_port(struct ocel
        ocelot_port_writel(ocelot_port, 0, DEV_MAC_FC_MAC_HIGH_CFG);
        ocelot_port_writel(ocelot_port, 0, DEV_MAC_FC_MAC_LOW_CFG);
  
index 9adc0ffff5d61b3db4b15fed0b13775673f692d8..3c9d0336a4bee689275b31700dd96d11cadabbb3 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/ethernet/mscc/ocelot.c
 +++ b/drivers/net/ethernet/mscc/ocelot.c
-@@ -2234,9 +2234,18 @@ void ocelot_set_cpu_port(struct ocelot *
+@@ -2232,9 +2232,18 @@ void ocelot_set_cpu_port(struct ocelot *
         * Only one port can be an NPI at the same time.
         */
        if (cpu < ocelot->num_phys_ports) {
index 5830dc0fa3a471dbb443005538ee6fbfc0bffe79..50a37e550066e842e0ba1853a4a32f3c86da828c 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/ethernet/mscc/ocelot.c
 +++ b/drivers/net/ethernet/mscc/ocelot.c
-@@ -2273,6 +2273,14 @@ int ocelot_init(struct ocelot *ocelot)
+@@ -2271,6 +2271,14 @@ int ocelot_init(struct ocelot *ocelot)
        int i, ret;
        u32 port;
  
index a32b19e0698543ba03ebc0782e57d5103ddccbdc..6fbc0917390a73339cbaa56f97835e4cb0902e7a 100644 (file)
@@ -329,7 +329,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
  static void ocelot_set_aggr_pgids(struct ocelot *ocelot)
  {
-@@ -2123,7 +2136,7 @@ static void ocelot_port_set_mtu(struct o
+@@ -2121,7 +2134,7 @@ static void ocelot_port_set_mtu(struct o
        ocelot_write(ocelot, ocelot_wm_enc(atop_wm), SYS_ATOP_TOT_CFG);
  }
  
@@ -338,7 +338,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  {
        struct ocelot_port *ocelot_port = ocelot->ports[port];
  
-@@ -2170,6 +2183,7 @@ static void ocelot_init_port(struct ocel
+@@ -2168,6 +2181,7 @@ static void ocelot_init_port(struct ocel
        /* Enable vcap lookups */
        ocelot_vcap_enable(ocelot, port);
  }
index 6be37fcc727ac85fa1295097b2f4b962b87924bc..2163c57ac2d5f13b71cf4ab132e9953e28cf32a5 100644 (file)
@@ -96,7 +96,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        }
  }
  EXPORT_SYMBOL(ocelot_get_txtstamp);
-@@ -2210,7 +2201,7 @@ void ocelot_init_port(struct ocelot *oce
+@@ -2208,7 +2199,7 @@ void ocelot_init_port(struct ocelot *oce
  {
        struct ocelot_port *ocelot_port = ocelot->ports[port];
  
@@ -105,7 +105,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        /* Basic L2 initialization */
  
-@@ -2495,9 +2486,7 @@ EXPORT_SYMBOL(ocelot_init);
+@@ -2493,9 +2484,7 @@ EXPORT_SYMBOL(ocelot_init);
  
  void ocelot_deinit(struct ocelot *ocelot)
  {
@@ -115,7 +115,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        int i;
  
        cancel_delayed_work(&ocelot->stats_work);
-@@ -2509,14 +2498,7 @@ void ocelot_deinit(struct ocelot *ocelot
+@@ -2507,14 +2496,7 @@ void ocelot_deinit(struct ocelot *ocelot
  
        for (i = 0; i < ocelot->num_phys_ports; i++) {
                port = ocelot->ports[i];
index e6d3bf79a14d8fe7c6e51bf703636053e2894c57..2bd7dfbfc7656a896bb8aa3ca81b38d3dcfa9ea4 100644 (file)
@@ -41,7 +41,7 @@ Signed-off-by: Xiaoliang Yang <xiaoliang.yang_1@nxp.com>
                ocelot_write_rix(ocelot, val, ANA_PGID_PGID, i);
  
        __dev_mc_sync(dev, ocelot_mc_sync, ocelot_mc_unsync);
-@@ -2412,10 +2412,11 @@ int ocelot_init(struct ocelot *ocelot)
+@@ -2410,10 +2410,11 @@ int ocelot_init(struct ocelot *ocelot)
                     SYS_FRM_AGING_MAX_AGE(307692), SYS_FRM_AGING);
  
        /* Setup flooding PGIDs */
index 0b4cb969550c65325e7c39ff32fb1d4a73954162..18754172a57bf0c308febaee856679d8b7e72364 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 
 --- a/drivers/net/ethernet/mscc/ocelot.c
 +++ b/drivers/net/ethernet/mscc/ocelot.c
-@@ -2342,6 +2342,20 @@ void ocelot_set_cpu_port(struct ocelot *
+@@ -2340,6 +2340,20 @@ void ocelot_set_cpu_port(struct ocelot *
  }
  EXPORT_SYMBOL(ocelot_set_cpu_port);
  
@@ -35,7 +35,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  int ocelot_init(struct ocelot *ocelot)
  {
        char queue_name[32];
-@@ -2479,6 +2493,13 @@ int ocelot_init(struct ocelot *ocelot)
+@@ -2477,6 +2491,13 @@ int ocelot_init(struct ocelot *ocelot)
                                "Timestamp initialization failed\n");
                        return ret;
                }
@@ -49,7 +49,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        }
  
        return 0;
-@@ -2493,6 +2514,8 @@ void ocelot_deinit(struct ocelot *ocelot
+@@ -2491,6 +2512,8 @@ void ocelot_deinit(struct ocelot *ocelot
        cancel_delayed_work(&ocelot->stats_work);
        destroy_workqueue(ocelot->stats_queue);
        mutex_destroy(&ocelot->stats_lock);
index f2d69b6333424832d6da7d9eb56c44e82ecd1d53..4e24fecfdfbb1217e33922ed57b7282f6084fd39 100644 (file)
@@ -128,7 +128,7 @@ Signed-off-by: Vladimir Oltean <vladimir.oltean@nxp.com>
 
 --- a/drivers/net/ethernet/mscc/ocelot.c
 +++ b/drivers/net/ethernet/mscc/ocelot.c
-@@ -2296,6 +2296,18 @@ void ocelot_set_cpu_port(struct ocelot *
+@@ -2294,6 +2294,18 @@ void ocelot_set_cpu_port(struct ocelot *
                         enum ocelot_tag_prefix injection,
                         enum ocelot_tag_prefix extraction)
  {
index fea7921b1d2039139555b0a2b15e6d813dca512c..d43626577b87133a24b845f9f9de8d98b5c47925 100644 (file)
@@ -163,7 +163,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
  
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1233,6 +1233,10 @@ static const struct hc_driver ehci_hc_dr
+@@ -1245,6 +1245,10 @@ static const struct hc_driver ehci_hc_dr
         * device support
         */
        .free_dev =             ehci_remove_device,
@@ -176,7 +176,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
  void ehci_init_driver(struct hc_driver *drv,
 --- a/drivers/usb/host/ehci-hub.c
 +++ b/drivers/usb/host/ehci-hub.c
-@@ -724,145 +724,6 @@ ehci_hub_descriptor (
+@@ -727,145 +727,6 @@ ehci_hub_descriptor (
  }
  
  /*-------------------------------------------------------------------------*/
index d57fb7c01fb90d76b7152378db8e1ec2b86bfab3..00706bc4194189a4c3ce259aaed9dc04a4892de1 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
                        retval = xhci_enter_test_mode(xhci, test_mode, wIndex,
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -3580,6 +3580,129 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
+@@ -3582,6 +3582,129 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
        return 0;
  }
  
index 763f6adc58efa091d80c89707f2df8380cbb3660..8359dfdcbc152092b1f814a11ceebe29b1c0d4e9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/clocksource/Kconfig
 +++ b/drivers/clocksource/Kconfig
-@@ -126,6 +126,15 @@
+@@ -126,6 +126,15 @@ config RDA_TIMER
        help
          Enables the support for the RDA Micro timer driver.
  
@@ -16,7 +16,7 @@
  config SUN4I_TIMER
        bool "Sun4i timer driver" if COMPILE_TEST
        depends on HAS_IOMEM
-@@ -695,5 +704,4 @@
+@@ -695,5 +704,4 @@ config INGENIC_TIMER
        select IRQ_DOMAIN
        help
          Support for the timer/counter unit of the Ingenic JZ SoCs.
@@ -24,7 +24,7 @@
  endmenu
 --- a/drivers/clocksource/Makefile
 +++ b/drivers/clocksource/Makefile
-@@ -61,6 +61,7 @@
+@@ -61,6 +61,7 @@ obj-$(CONFIG_MILBEAUT_TIMER) += timer-mi
  obj-$(CONFIG_SPRD_TIMER)      += timer-sprd.o
  obj-$(CONFIG_NPCM7XX_TIMER)   += timer-npcm7xx.o
  obj-$(CONFIG_RDA_TIMER)               += timer-rda.o
index 7bfbd0a5f6f3d14637fe5ebe893dff64a479d7fa..803614e7c028a9eef731b8ea39237296aff885c0 100644 (file)
@@ -13,7 +13,7 @@
        trailer[2] = 0x10;
        trailer[3] = 0x00;
  
-@@ -61,12 +69,23 @@ static struct sk_buff *trailer_rcv(struc
+@@ -61,12 +66,23 @@ static struct sk_buff *trailer_rcv(struc
                return NULL;
  
        trailer = skb_tail_pointer(skb) - 4;