kernel: bump 4.19 to 4.19.47
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 3 Jun 2019 12:03:29 +0000 (14:03 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 3 Jun 2019 15:00:29 +0000 (17:00 +0200)
Refreshed all patches.

Compile-tested on: imx6
Runtime-tested on: imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/cns3xxx/patches-4.19/075-spi_support.patch
target/linux/generic/hack-4.19/204-module_strip.patch
target/linux/generic/hack-4.19/911-kobject_add_broadcast_uevent.patch

index b73d408556f04916ed0be8b50cb351b903de7452..5a874f75e9eb7476d6d22a9ed423011b1ad27a1e 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .180
 LINUX_VERSION-4.14 = .123
-LINUX_VERSION-4.19 = .46
+LINUX_VERSION-4.19 = .47
 
 LINUX_KERNEL_HASH-4.9.180 = d25a490d62a3e96a587333e163862585eac4086fc8d4893b4ec1711e7d387c5f
 LINUX_KERNEL_HASH-4.14.123 = 25f58cb56bde388ac9bcee984f5f2d0ca094b0a8af6b92ad1f5b2fd0e6725b85
-LINUX_KERNEL_HASH-4.19.46 = 097b52fe8a872259f4a3dba571b2eaf7b9863d9cde5399c6b316dec0ef57e67a
+LINUX_KERNEL_HASH-4.19.47 = 5d08f3890e7ca2b94529675120f170c5b764f795e6dd184a1190c23a40ef5365
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index e4bd1293405031880bbd66dad87750929dedbfe4..afa6d862df1926c1547b37d910bacc3a5c31c2c3 100644 (file)
@@ -39,7 +39,7 @@
  /**
 --- a/drivers/spi/spi.c
 +++ b/drivers/spi/spi.c
-@@ -1018,6 +1018,9 @@ static int spi_transfer_one_message(stru
+@@ -1020,6 +1020,9 @@ static int spi_transfer_one_message(stru
        list_for_each_entry(xfer, &msg->transfers, transfer_list) {
                trace_spi_transfer_start(msg, xfer);
  
index 7fa5d8ddbc02da96762659fe0c027870a9fd8b8d..ce822c7c698303c20965538f347b9a9a551846d5 100644 (file)
@@ -114,7 +114,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -3004,9 +3004,11 @@ static int setup_load_info(struct load_i
+@@ -3009,9 +3009,11 @@ static int setup_load_info(struct load_i
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -127,7 +127,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (flags & MODULE_INIT_IGNORE_VERMAGIC)
                modmagic = NULL;
  
-@@ -3027,6 +3029,7 @@ static int check_modinfo(struct module *
+@@ -3032,6 +3034,7 @@ static int check_modinfo(struct module *
                                mod->name);
                add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
        }
index 888f3fc1e7d3438921bf7873a242c7dc3d5cd1e5..06b94117c111b927c4a9c9992b0e59087096d2c7 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #endif /* _KOBJECT_H_ */
 --- a/lib/kobject_uevent.c
 +++ b/lib/kobject_uevent.c
-@@ -685,6 +685,43 @@ int add_uevent_var(struct kobj_uevent_en
+@@ -688,6 +688,43 @@ int add_uevent_var(struct kobj_uevent_en
  EXPORT_SYMBOL_GPL(add_uevent_var);
  
  #if defined(CONFIG_NET)