build: Use LINUX_DIR for Kernel/Patch
authorMichal Hrusecky <michal.hrusecky@nic.cz>
Thu, 11 Oct 2018 16:23:19 +0000 (18:23 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 30 Jan 2019 12:20:14 +0000 (13:20 +0100)
Use LINUX_DIR as a path when patching kernel. Doesn't break the current usage,
but allows to create packages that will contain variation of a kernel with
kernel being build in some subdirectory of PKG_BUILD_DIR.

Signed-off-by: Michal Hrusecky <michal.hrusecky@nic.cz>
include/quilt.mk

index 61dcc7964cf4315727264d21d00bf186345dfb79..56f674a2f39e490b4574b85266b0e6f350a0a284 100644 (file)
@@ -94,17 +94,17 @@ endef
 
 kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
 define Kernel/Patch/Default
-       $(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
+       $(if $(QUILT),rm -rf $(LINUX_DIR)/patches; mkdir -p $(LINUX_DIR)/patches)
        $(if $(kernel_files),$(CP) $(kernel_files) $(LINUX_DIR)/)
        find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
        if [ -d $(GENERIC_PLATFORM_DIR)/patches$(if $(wildcard $(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER)) ]; then \
                echo "generic patches directory is present. please move your patches to the pending directory" ; \
                exit 1; \
        fi
-       $(call PatchDir,$(PKG_BUILD_DIR),$(GENERIC_BACKPORT_DIR),generic-backport/)
-       $(call PatchDir,$(PKG_BUILD_DIR),$(GENERIC_PATCH_DIR),generic/)
-       $(call PatchDir,$(PKG_BUILD_DIR),$(GENERIC_HACK_DIR),generic-hack/)
-       $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR),platform/)
+       $(call PatchDir,$(LINUX_DIR),$(GENERIC_BACKPORT_DIR),generic-backport/)
+       $(call PatchDir,$(LINUX_DIR),$(GENERIC_PATCH_DIR),generic/)
+       $(call PatchDir,$(LINUX_DIR),$(GENERIC_HACK_DIR),generic-hack/)
+       $(call PatchDir,$(LINUX_DIR),$(PATCH_DIR),platform/)
 endef
 
 define Quilt/RefreshDir